aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2012-07-27 19:03:38 +0800
committermakc <makc@FreeBSD.org>2012-07-27 19:03:38 +0800
commit7e9888a561c1f2a53cfeca5bf54f5278294df386 (patch)
tree167ee4bd8c4cd737246cf4e2c40f36e42042084e /textproc
parent7c887ca2a204b4cd88ce46806edb8ea718e69d9e (diff)
downloadfreebsd-ports-gnome-7e9888a561c1f2a53cfeca5bf54f5278294df386.tar.gz
freebsd-ports-gnome-7e9888a561c1f2a53cfeca5bf54f5278294df386.tar.zst
freebsd-ports-gnome-7e9888a561c1f2a53cfeca5bf54f5278294df386.zip
- Convert my ports to new options framework
- use CONFLICTS_INSTALL - other minor changes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/qstardict/Makefile21
-rw-r--r--textproc/stardict3/Makefile9
2 files changed, 16 insertions, 14 deletions
diff --git a/textproc/qstardict/Makefile b/textproc/qstardict/Makefile
index c1c1900da979..f8837c75b243 100644
--- a/textproc/qstardict/Makefile
+++ b/textproc/qstardict/Makefile
@@ -21,27 +21,28 @@ USE_DOS2UNIX= qstardict.pri
DICPATH= ${LOCALBASE}/share/stardict/dic
-OPTIONS= DBUS "Enable D-BUS support" on
+OPTIONS_DEFINE= DBUS
+OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
+PLIST_SUB+= NLS=""
+.else
QMAKE_ARGS+= NO_TRANSLATIONS=1
PLIST_SUB+= NLS="@comment "
-.else
-PLIST_SUB+= NLS=""
.endif
-.if defined(WITHOUT_DBUS)
-QMAKE_ARGS+= NO_DBUS=1
+.if ${PORT_OPTIONS:MDBUS}
+USE_QT4+= dbus
.else
-LIB_DEPENDS+= QtDBus.4:${PORTSDIR}/devel/dbus-qt4
+QMAKE_ARGS+= NO_DBUS=1
.endif
post-patch:
@${REINPLACE_CMD} -e "s|/usr|${PREFIX}|g" \
${WRKSRC}/qstardict.pri
-.if defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${REINPLACE_CMD} -e "/^INSTALLS/s|docs||g" \
${WRKSRC}/qstardict.pro
.endif
@@ -58,4 +59,4 @@ post-configure:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/stardict3/Makefile b/textproc/stardict3/Makefile
index 3111fa3f6fa3..9e7fb184a3d0 100644
--- a/textproc/stardict3/Makefile
+++ b/textproc/stardict3/Makefile
@@ -35,13 +35,14 @@ INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
PROJECTHOST= stardict-3
-OPTIONS= GNOME "GNOME support" On
+OPTIONS_DEFINE= GNOME
+OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
-CONFLICTS_RUN= stardict-2.[0-9]*
+CONFLICTS_INSTALL= stardict-2.[0-9]*
.include <bsd.port.options.mk>
-.if !defined(WITHOUT_GNOME)
+.if ${PORT_OPTIONS:MGNOME}
USE_GNOME+= gnomeprefix gnomedocutils libgnomeui
GCONF_SCHEMAS= stardict.schemas
INSTALLS_OMF= yes
@@ -57,7 +58,7 @@ MAKE_ARGS+= AUTOMAKE="${TRUE}" ACLOCAL="${TRUE}"
MAN1= stardict.1
post-patch:
-.if defined(WITHOUT_GNOME)
+.if !${PORT_OPTIONS:MGNOME}
${REINPLACE_CMD} -e '/DATADIRNAME=lib/s,lib,share,' ${WRKSRC}/dict/m4/intltool.m4
${REINPLACE_CMD} -e '/^SUBDIRS/s,help,,' ${WRKSRC}/dict/Makefile.in
${REINPLACE_CMD} -e '/^GNOME_DOC_INIT/d' \