aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authordvl <dvl@FreeBSD.org>2015-12-15 07:44:41 +0800
committerdvl <dvl@FreeBSD.org>2015-12-15 07:44:41 +0800
commit879dd120b03723894114f236f97c8dfbe28c53be (patch)
treef88a87978323cad38976e43a6c780ef94c9ddeb5 /textproc
parent6e0d0fd15ae7bf951f334f89c1abb71c70794aae (diff)
downloadfreebsd-ports-gnome-879dd120b03723894114f236f97c8dfbe28c53be.tar.gz
freebsd-ports-gnome-879dd120b03723894114f236f97c8dfbe28c53be.tar.zst
freebsd-ports-gnome-879dd120b03723894114f236f97c8dfbe28c53be.zip
Add textproc/py-curator, index manager for Elasticsearch
Approved by: mat (mentor) Differential Revision: D4555
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile2
-rw-r--r--textproc/py-curator/Makefile24
-rw-r--r--textproc/py-curator/distinfo2
-rw-r--r--textproc/py-curator/pkg-descr6
4 files changed, 34 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 2f03c42dc8e0..496127de0fa6 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -152,6 +152,7 @@
SUBDIR += ekhtml
SUBDIR += el-aspell
SUBDIR += el-hyphen
+ SUBDIR += curator
SUBDIR += elasticsearch
SUBDIR += elasticsearch-plugin-head
SUBDIR += elasticsearch-plugin-hq
@@ -1209,6 +1210,7 @@
SUBDIR += py-chardet
SUBDIR += py-cloud_sptheme
SUBDIR += py-creole
+ SUBDIR += py-curator
SUBDIR += py-diff-match-patch
SUBDIR += py-docutils
SUBDIR += py-dsv
diff --git a/textproc/py-curator/Makefile b/textproc/py-curator/Makefile
new file mode 100644
index 000000000000..db845d7ed25f
--- /dev/null
+++ b/textproc/py-curator/Makefile
@@ -0,0 +1,24 @@
+# Created by: Dan Langille <dvl@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= curator
+PORTVERSION= 3.4.0
+DISTVERSIONPREFIX= v
+CATEGORIES= textproc python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= dvl@FreeBSD.org
+COMMENT= Python index manager for Elasticsearch
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}urllib3>=1.8.3:${PORTSDIR}/net/py-urllib3 \
+ ${PYTHON_PKGNAMEPREFIX}elasticsearch-py>=1.8.0:${PORTSDIR}/textproc/py-elasticsearch-py \
+ ${PYTHON_PKGNAMEPREFIX}click>=3.3:${PORTSDIR}/devel/py-click
+
+USE_GITHUB= yes
+GH_ACCOUNT= elastic
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/textproc/py-curator/distinfo b/textproc/py-curator/distinfo
new file mode 100644
index 000000000000..dc0e98c5a44b
--- /dev/null
+++ b/textproc/py-curator/distinfo
@@ -0,0 +1,2 @@
+SHA256 (elastic-curator-v3.4.0_GH0.tar.gz) = 86e542886d83ad4c499437e42f4ff69d6602314a75c0c156d1c8dd838ab5e605
+SIZE (elastic-curator-v3.4.0_GH0.tar.gz) = 96741
diff --git a/textproc/py-curator/pkg-descr b/textproc/py-curator/pkg-descr
new file mode 100644
index 000000000000..e148c998fb07
--- /dev/null
+++ b/textproc/py-curator/pkg-descr
@@ -0,0 +1,6 @@
+Have indices in Elasticsearch? This is the tool for you!
+
+Like a museum curator manages the exhibits and collections on display,
+Elasticsearch Curator helps you curate, or manage your indices.
+
+WWW: http://curator.readthedocs.org/en/master/