aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-07-29 04:54:04 +0800
committermarino <marino@FreeBSD.org>2014-07-29 04:54:04 +0800
commit9bb82f829eb04aa48ed163569c342f64432843d3 (patch)
treed3e37c0458b023afd80109d998337318c193623b /textproc
parent64ce9fd2806463c419e470b2474c20d9b0e13d31 (diff)
downloadfreebsd-ports-gnome-9bb82f829eb04aa48ed163569c342f64432843d3.tar.gz
freebsd-ports-gnome-9bb82f829eb04aa48ed163569c342f64432843d3.tar.zst
freebsd-ports-gnome-9bb82f829eb04aa48ed163569c342f64432843d3.zip
textproc/extract_url: Fix sample config file in pkg-plist
* remove construct for .sample this this port doesn't install a working config file by default * update pkg-message to tell the user to copy the provided sample file to $HOME and edit accordingly * Fix plist * Respect 80-column limit PR: 191926 Submitted by: maintainer (Horia Racoviceanu)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/extract_url/Makefile9
-rw-r--r--textproc/extract_url/files/pkg-message.in10
-rw-r--r--textproc/extract_url/pkg-plist5
3 files changed, 15 insertions, 9 deletions
diff --git a/textproc/extract_url/Makefile b/textproc/extract_url/Makefile
index 2b7663352c9a..d6d984a60034 100644
--- a/textproc/extract_url/Makefile
+++ b/textproc/extract_url/Makefile
@@ -3,6 +3,7 @@
PORTNAME= extract_url
PORTVERSION= 1.5.8
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= GOOGLE_CODE
PROJECTHOST= extracturl
@@ -17,11 +18,14 @@ BUILD_DEPENDS= p5-MIME-Tools>=0:${PORTSDIR}/mail/p5-MIME-Tools \
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= gmake perl5
-
MAKE_ARGS= all prefix=${PREFIX} man_prefix=${PREFIX}
WRKSRC= ${WRKDIR}/${PORTNAME}
+PLIST_FILES= bin/extract_url \
+ etc/extract_urlview.sample \
+ man/man1/extract_url.1.gz
+
SUB_FILES= pkg-message
OPTIONS_DEFINE= DOCS GETOPT_LONG URI_FIND
@@ -48,7 +52,8 @@ post-patch:
${WRKSRC}/${MAKEFILE}
post-install:
- ${INSTALL_DATA} ${FILESDIR}/${PORTNAME}view ${STAGEDIR}${PREFIX}/etc/${PORTNAME}view.sample
+ ${INSTALL_DATA} ${FILESDIR}/${PORTNAME}view \
+ ${STAGEDIR}${PREFIX}/etc/${PORTNAME}view.sample
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
diff --git a/textproc/extract_url/files/pkg-message.in b/textproc/extract_url/files/pkg-message.in
index af543370f861..f6ad289066f7 100644
--- a/textproc/extract_url/files/pkg-message.in
+++ b/textproc/extract_url/files/pkg-message.in
@@ -2,8 +2,14 @@
extract_url has been installed.
-Sample configuration is installed, please adjust it
+If you don't have ~/.extract_urlview
- %%PREFIX%%/etc/extract_urlview.sample
+the extract_url configuration file can be copied, please type as user:
+
+ su - user
+
+ cp %%PREFIX%%/etc/extract_urlview.sample ~/.extract_urlview
+
+ exit
===============================================================================
diff --git a/textproc/extract_url/pkg-plist b/textproc/extract_url/pkg-plist
deleted file mode 100644
index 117cf54a8bdb..000000000000
--- a/textproc/extract_url/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-bin/extract_url
-@unexec if cmp -s %D/etc/extract_urlview %D/etc/extract_urlview.sample ; then rm -f %D/etc/extract_urlview ; fi
-etc/extract_urlview.sample
-@exec if [ -f %D/etc/extract_urlview ] ; then cp -p %D/%F %B/extract_urlview ; fi
-man/man1/extract_url.1.gz