aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-05-17 01:51:57 +0800
committermarino <marino@FreeBSD.org>2014-05-17 01:51:57 +0800
commita61907ce36f41f41e566075002bfef3a55531e4d (patch)
tree77a61794af54c7c94ae24324c4e323367c676aeb /textproc
parentc58157067b975633415ad9354685fae11012a945 (diff)
downloadfreebsd-ports-gnome-a61907ce36f41f41e566075002bfef3a55531e4d.tar.gz
freebsd-ports-gnome-a61907ce36f41f41e566075002bfef3a55531e4d.tar.zst
freebsd-ports-gnome-a61907ce36f41f41e566075002bfef3a55531e4d.zip
Add new Ada port: textproc/templates_parser
This was part of the Ada Web Server, but it is maintained separated and even needs to be recursively cloned into AWS git repository. Now the AWS template engine is a separate library that AWS will use in the upcoming update. The package description is below. ================================================================ This is the template engine for the Ada Web Server. It is modular and therefore can be split out of AWS and used on its own. As it was designed for generating web pages, it's function is to parse a page template and replace tokens with specified values. This template engine is amazingly fast due to its concurrent cached compiled templates support. WWW: http://docs.adacore.com/aws-docs/templates_parser
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/templates_parser/Makefile52
-rw-r--r--textproc/templates_parser/distinfo2
-rw-r--r--textproc/templates_parser/files/templates_parser.gpr19
-rw-r--r--textproc/templates_parser/pkg-descr9
-rw-r--r--textproc/templates_parser/pkg-plist69
6 files changed, 152 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index e0bcdf91e150..805826d6ddeb 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1435,6 +1435,7 @@
SUBDIR += teckit
SUBDIR += tei-guidelines-p3
SUBDIR += tei-p3
+ SUBDIR += templates_parser
SUBDIR += tet-aspell
SUBDIR += tex2im
SUBDIR += texi2db
diff --git a/textproc/templates_parser/Makefile b/textproc/templates_parser/Makefile
new file mode 100644
index 000000000000..7f754dc5031d
--- /dev/null
+++ b/textproc/templates_parser/Makefile
@@ -0,0 +1,52 @@
+# Created by: John Marino <marino@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= templates_parser
+PORTVERSION= 11.9.0.0
+CATEGORIES= textproc
+MASTER_SITES= http://downloads.dragonlace.net/src/
+
+MAINTAINER= marino@FreeBSD.org
+COMMENT= Web page template engine module for the Ada Web Server
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= gprbuild:${PORTSDIR}/devel/gprbuild \
+ xmlada>=4.4:${PORTSDIR}/textproc/xmlada
+RUN_DEPENDS= xmlada>=4.4:${PORTSDIR}/textproc/xmlada
+
+USES= ada gmake tar:bzip2
+MAKEFILE= makefile
+DESTINC= ${STAGEDIR}${PREFIX}/include/templates_parser
+MAKE_ARGS+= PROCESSORS=${MAKE_JOBS_NUMBER} \
+ HOST=${CONFIGURE_TARGET} \
+ TARGET=${CONFIGURE_TARGET} \
+ prefix=${PREFIX}
+
+PORTDOCS= html
+
+OPTIONS_DEFINE= DOCS
+DOCS_BUILD_DEPENDS= sphinx-build:${PORTSDIR}/textproc/py-sphinx
+
+.include <bsd.port.options.mk>
+
+do-build:
+ # Override build target to avoid -jX getting passed to makefile
+ # Parallel builds are handled with PROCESSORS setting
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS}
+.if ${PORT_OPTIONS:MDOCS}
+ cd ${WRKSRC}/docs && ${SETENV} ${MAKE_ENV} \
+ ${MAKE_CMD} ${MAKE_ARGS} html
+.endif
+
+post-install:
+ ${RM} -rf ${STAGEDIR}${PREFIX}/share/gpr/manifests
+ ${MV} ${DESTINC}.relocatable/templates_parser-conf*.ads \
+ ${DESTINC}.relocatable/templates_parser-configuration.ads
+ ${MV} ${DESTINC}/templates_parser-conf*.ads \
+ ${DESTINC}/templates_parser-configuration.ads
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/gnat
+ ${INSTALL_DATA} ${FILESDIR}/templates_parser.gpr \
+ ${STAGEDIR}${PREFIX}/lib/gnat
+
+.include <bsd.port.mk>
diff --git a/textproc/templates_parser/distinfo b/textproc/templates_parser/distinfo
new file mode 100644
index 000000000000..3799c2e118d9
--- /dev/null
+++ b/textproc/templates_parser/distinfo
@@ -0,0 +1,2 @@
+SHA256 (templates_parser-11.9.0.0.tar.bz2) = 0133de55a834f79a85f620d59c3fd9ddece8f43753813f38427e2362166eff91
+SIZE (templates_parser-11.9.0.0.tar.bz2) = 168785
diff --git a/textproc/templates_parser/files/templates_parser.gpr b/textproc/templates_parser/files/templates_parser.gpr
new file mode 100644
index 000000000000..f0634f7dbcd1
--- /dev/null
+++ b/textproc/templates_parser/files/templates_parser.gpr
@@ -0,0 +1,19 @@
+project Templates_Parser is
+
+ type TP_Kind_Type is ("static", "relocatable");
+ TP_Kind : TP_Kind_Type := external ("LIBRARY_TYPE", "static");
+
+ for Library_Name use "templates_parser";
+ for Library_Kind use TP_Kind;
+ case TP_Kind is
+ when "relocatable" =>
+ for Source_Dirs use ("../../include/templates_parser.relocatable");
+ for Library_Dir use "../../lib/templates_parser.relocatable";
+ for Library_Version use "libtemplates_parser.so";
+ when others =>
+ for Source_Dirs use ("../../include/templates_parser");
+ for Library_Dir use "../../lib/templates_parser";
+ end case;
+ for Externally_Built use "true";
+
+end Templates_Parser;
diff --git a/textproc/templates_parser/pkg-descr b/textproc/templates_parser/pkg-descr
new file mode 100644
index 000000000000..7e33a8737c70
--- /dev/null
+++ b/textproc/templates_parser/pkg-descr
@@ -0,0 +1,9 @@
+This is the template engine for the Ada Web Server. It is modular and
+therefore can be split out of AWS and used on its own.
+
+As it was designed for generating web pages, it's function is to parse
+a page template and replace tokens with specified values. This template
+engine is amazingly fast due to its concurrent cached compiled templates
+support.
+
+WWW: http://docs.adacore.com/aws-docs/templates_parser
diff --git a/textproc/templates_parser/pkg-plist b/textproc/templates_parser/pkg-plist
new file mode 100644
index 000000000000..0d0e256b17c8
--- /dev/null
+++ b/textproc/templates_parser/pkg-plist
@@ -0,0 +1,69 @@
+bin/templates2ada
+bin/templatespp
+include/templates_parser.relocatable/templates_parser-cached_files.adb
+include/templates_parser.relocatable/templates_parser-configuration.ads
+include/templates_parser.relocatable/templates_parser-data.adb
+include/templates_parser.relocatable/templates_parser-debug.ads
+include/templates_parser.relocatable/templates_parser-definitions.adb
+include/templates_parser.relocatable/templates_parser-expr.adb
+include/templates_parser.relocatable/templates_parser-filter.adb
+include/templates_parser.relocatable/templates_parser-input.ads
+include/templates_parser.relocatable/templates_parser-input__standalone.adb
+include/templates_parser.relocatable/templates_parser-macro.adb
+include/templates_parser.relocatable/templates_parser-print_tree.adb
+include/templates_parser.relocatable/templates_parser-query.ads
+include/templates_parser.relocatable/templates_parser-simplifier.adb
+include/templates_parser.relocatable/templates_parser-utils.adb
+include/templates_parser.relocatable/templates_parser-utils.ads
+include/templates_parser.relocatable/templates_parser-xml.ads
+include/templates_parser.relocatable/templates_parser.adb
+include/templates_parser.relocatable/templates_parser.ads
+include/templates_parser.relocatable/templates_parser_tasking.ads
+include/templates_parser.relocatable/templates_parser_tasking__standard_tasking.adb
+include/templates_parser/templates_parser-cached_files.adb
+include/templates_parser/templates_parser-configuration.ads
+include/templates_parser/templates_parser-data.adb
+include/templates_parser/templates_parser-debug.ads
+include/templates_parser/templates_parser-definitions.adb
+include/templates_parser/templates_parser-expr.adb
+include/templates_parser/templates_parser-filter.adb
+include/templates_parser/templates_parser-input.ads
+include/templates_parser/templates_parser-input__standalone.adb
+include/templates_parser/templates_parser-macro.adb
+include/templates_parser/templates_parser-print_tree.adb
+include/templates_parser/templates_parser-query.ads
+include/templates_parser/templates_parser-simplifier.adb
+include/templates_parser/templates_parser-utils.adb
+include/templates_parser/templates_parser-utils.ads
+include/templates_parser/templates_parser-xml.ads
+include/templates_parser/templates_parser.adb
+include/templates_parser/templates_parser.ads
+include/templates_parser/templates_parser_tasking.ads
+include/templates_parser/templates_parser_tasking__standard_tasking.adb
+lib/gnat/templates_parser.gpr
+lib/libtemplates_parser.so
+lib/templates_parser.relocatable/libtemplates_parser-11.9.0w.so
+lib/templates_parser.relocatable/libtemplates_parser.so
+lib/templates_parser.relocatable/templates_parser-configuration__standalone.ali
+lib/templates_parser.relocatable/templates_parser-debug.ali
+lib/templates_parser.relocatable/templates_parser-input__standalone.ali
+lib/templates_parser.relocatable/templates_parser-query.ali
+lib/templates_parser.relocatable/templates_parser-utils.ali
+lib/templates_parser.relocatable/templates_parser-xml.ali
+lib/templates_parser.relocatable/templates_parser.ali
+lib/templates_parser.relocatable/templates_parser_tasking__standard_tasking.ali
+lib/templates_parser/libtemplates_parser.a
+lib/templates_parser/templates_parser-configuration__standalone.ali
+lib/templates_parser/templates_parser-debug.ali
+lib/templates_parser/templates_parser-input__standalone.ali
+lib/templates_parser/templates_parser-query.ali
+lib/templates_parser/templates_parser-utils.ali
+lib/templates_parser/templates_parser-xml.ali
+lib/templates_parser/templates_parser.ali
+lib/templates_parser/templates_parser_tasking__standard_tasking.ali
+share/gpr/templates_parser.gpr
+@dirrm include/templates_parser
+@dirrm include/templates_parser.relocatable
+@dirrm lib/templates_parser
+@dirrm lib/templates_parser.relocatable
+@dirrmtry share/gpr