aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-03-17 05:47:30 +0800
committermiwi <miwi@FreeBSD.org>2009-03-17 05:47:30 +0800
commitabe1eb4848ae791628e40557fd6505a015ddb821 (patch)
tree17d20c56c015dee51b4224eebc53c03c3cd333d5 /textproc
parentbf2d86820f5b72bf97b92d11f68658a0e8ce380d (diff)
downloadfreebsd-ports-gnome-abe1eb4848ae791628e40557fd6505a015ddb821.tar.gz
freebsd-ports-gnome-abe1eb4848ae791628e40557fd6505a015ddb821.tar.zst
freebsd-ports-gnome-abe1eb4848ae791628e40557fd6505a015ddb821.zip
PyStemmer provides access to efficient algorithms for calculating a
"stemmed" form of a word. This is a form with most of the common morphological endings removed; hopefully representing a common linguistic base form. This is most useful in building search engines and information retrieval software; for example, a search with stemming enabled should be able to find a document containing "cycling" given the query "cycles". PyStemmer provides algorithms for several (mainly european) languages, by wrapping the libstemmer library from the Snowball project in a Python module. It also provides access to the classic Porter stemming algorithm for english: although this has been superceded by an improved algorithm, the original algorithm may be of interest to information retrieval researchers wishing to reproduce results of earlier experiments. WWW: http://pypi.python.org/pypi/PyStemmer/ PR: ports/132695 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/pystemmer/Makefile21
-rw-r--r--textproc/pystemmer/distinfo3
-rw-r--r--textproc/pystemmer/pkg-descr16
-rw-r--r--textproc/pystemmer/pkg-plist1
5 files changed, 42 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index fcf72bbfa3d5..cfde2377452b 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -900,6 +900,7 @@
SUBDIR += py2html
SUBDIR += pybook
SUBDIR += pychm
+ SUBDIR += pystemmer
SUBDIR += qstardict
SUBDIR += qt4-clucene
SUBDIR += qt4-xml
diff --git a/textproc/pystemmer/Makefile b/textproc/pystemmer/Makefile
new file mode 100644
index 000000000000..f7b941ca1ccc
--- /dev/null
+++ b/textproc/pystemmer/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: pystemmer
+# Date created: 2009-03-17
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pystemmer
+PORTVERSION= 1.0.1
+CATEGORIES= textproc python
+MASTER_SITES= http://snowball.tartarus.org/wrappers/
+DISTNAME= PyStemmer-${PORTVERSION}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Snowball Stemming Algorithms for Information Retrieval
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= PyStemmer
+
+.include <bsd.port.mk>
diff --git a/textproc/pystemmer/distinfo b/textproc/pystemmer/distinfo
new file mode 100644
index 000000000000..395157e40834
--- /dev/null
+++ b/textproc/pystemmer/distinfo
@@ -0,0 +1,3 @@
+MD5 (PyStemmer-1.0.1.tar.gz) = 5fb09517161de1792b2fc1fd8844038b
+SHA256 (PyStemmer-1.0.1.tar.gz) = 08f0d64e7c49b77cb0f44937c25a04ed17ea1b9db3d830d47a02d2717ae89ebe
+SIZE (PyStemmer-1.0.1.tar.gz) = 331212
diff --git a/textproc/pystemmer/pkg-descr b/textproc/pystemmer/pkg-descr
new file mode 100644
index 000000000000..a505e0793612
--- /dev/null
+++ b/textproc/pystemmer/pkg-descr
@@ -0,0 +1,16 @@
+PyStemmer provides access to efficient algorithms for calculating a
+"stemmed" form of a word. This is a form with most of the common
+morphological endings removed; hopefully representing a common
+linguistic base form. This is most useful in building search engines
+and information retrieval software; for example, a search with stemming
+enabled should be able to find a document containing "cycling" given the
+query "cycles".
+
+PyStemmer provides algorithms for several (mainly european) languages,
+by wrapping the libstemmer library from the Snowball project in a Python
+module. It also provides access to the classic Porter stemming algorithm
+for english: although this has been superceded by an improved algorithm,
+the original algorithm may be of interest to information retrieval
+researchers wishing to reproduce results of earlier experiments.
+
+WWW: http://pypi.python.org/pypi/PyStemmer/
diff --git a/textproc/pystemmer/pkg-plist b/textproc/pystemmer/pkg-plist
new file mode 100644
index 000000000000..23835b241eec
--- /dev/null
+++ b/textproc/pystemmer/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/Stemmer.so