aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorgjb <gjb@FreeBSD.org>2013-01-05 08:41:31 +0800
committergjb <gjb@FreeBSD.org>2013-01-05 08:41:31 +0800
commitb1889e084c861b0da57b2a903791a23897440972 (patch)
treed0fa446f9d297f530b8d49df7057f34bd9e39c07 /textproc
parent520cc5351034ac728cce00c02c4d36b5f8e79c3d (diff)
downloadfreebsd-ports-gnome-b1889e084c861b0da57b2a903791a23897440972.tar.gz
freebsd-ports-gnome-b1889e084c861b0da57b2a903791a23897440972.tar.zst
freebsd-ports-gnome-b1889e084c861b0da57b2a903791a23897440972.zip
Updates to textproc/docproj* ports:
o textproc/docproj-jadetex: - Remove port; functionality is moved to textproc/docproj o textproc/docproj-nojadetex: - Remove extraneous MAINTAINER line - Trim headers o textproc/docproj: - Trim headers - Convert to new options framework - Default to WITH_JADETEX=yes - Make devel/subversion dependency optional while noting it is required for source checkout; this allows us to skip svn and dependencies for release builds - Bump PORTREVISION o Add UPDATING entry explaining who needs to update port origins o Add MOVED entry for textproc/docproj-jadetex
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/docproj-jadetex/Makefile15
-rw-r--r--textproc/docproj-nojadetex/Makefile9
-rw-r--r--textproc/docproj/Makefile49
4 files changed, 23 insertions, 51 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 184d17070956..2c9149395483 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -135,7 +135,6 @@
SUBDIR += docdiff
SUBDIR += doclifter
SUBDIR += docproj
- SUBDIR += docproj-jadetex
SUBDIR += docproj-nojadetex
SUBDIR += dom4j
SUBDIR += domc
diff --git a/textproc/docproj-jadetex/Makefile b/textproc/docproj-jadetex/Makefile
deleted file mode 100644
index 4421eb25979a..000000000000
--- a/textproc/docproj-jadetex/Makefile
+++ /dev/null
@@ -1,15 +0,0 @@
-# New ports collection makefile for: docproj-jadetex
-# Date created: 25 July 2002
-# Whom: Cyrille Lefevre <cyrille.lefevre@laposte.net>
-#
-# $FreeBSD$
-#
-
-PKGNAMESUFFIX= -jadetex
-WITH_JADETEX= yes
-
-MAINTAINER= cyrille.lefevre@laposte.net
-
-MASTERDIR= ${.CURDIR}/../docproj
-
-.include "${MASTERDIR}/Makefile"
diff --git a/textproc/docproj-nojadetex/Makefile b/textproc/docproj-nojadetex/Makefile
index a025f937fcc0..318e2580d7d2 100644
--- a/textproc/docproj-nojadetex/Makefile
+++ b/textproc/docproj-nojadetex/Makefile
@@ -1,14 +1,9 @@
-# New ports collection makefile for: docproj-nojadetex
-# Date created: 25 July 2002
-# Whom: Cyrille Lefevre <cyrille.lefevre@laposte.net>
-#
+# Created by: Cyrille Lefevre <cyrille.lefevre@laposte.net>
# $FreeBSD$
#
PKGNAMESUFFIX= -nojadetex
-WITH_JADETEX= no
-
-MAINTAINER= cyrille.lefevre@laposte.net
+WITHOUT_JADETEX=yes
MASTERDIR= ${.CURDIR}/../docproj
diff --git a/textproc/docproj/Makefile b/textproc/docproj/Makefile
index 9701baccea42..e158a295df05 100644
--- a/textproc/docproj/Makefile
+++ b/textproc/docproj/Makefile
@@ -1,13 +1,10 @@
-# New ports collection makefile for: docproj
-# Date created: 27 June 1998
-# Whom: Nik Clayton <nik@freebsd.org>
-#
+# Created by: Nik Clayton <nik@freebsd.org>
# $FreeBSD$
#
PORTNAME= docproj
PORTVERSION= 1.17
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= textproc
MASTER_SITES= # empty
DISTFILES= # empty
@@ -29,7 +26,6 @@ RUN_DEPENDS= fixrtf:${PORTSDIR}/textproc/fixrtf \
tidy:${PORTSDIR}/www/tidy-lib \
xsltproc:${PORTSDIR}/textproc/libxslt \
peps:${PORTSDIR}/graphics/peps \
- svn:${PORTSDIR}/devel/subversion \
${LOCALBASE}/share/sgml/docbook/dsssl/modular:${PORTSDIR}/textproc/dsssl-docbook-modular \
${LOCALBASE}/share/sgml/html/catalog:${PORTSDIR}/textproc/html \
${LOCALBASE}/share/sgml/linuxdoc:${PORTSDIR}/textproc/linuxdoc \
@@ -41,36 +37,41 @@ RUN_DEPENDS= fixrtf:${PORTSDIR}/textproc/fixrtf \
${LOCALBASE}/share/xml/xmlcharent/catalog:${PORTSDIR}/textproc/xmlcharent \
p5-XML-Parser>=2.41:${PORTSDIR}/textproc/p5-XML-Parser
+OPTIONS_DEFINE= JADETEX OPENJADE CJK SVN
+JADETEX_DESC= Support building additional document formats (PDF)
+OPENJADE_DESC= Install textproc/openjade instead of textproc/jade
+CJK_DESC= CJK (Simplified Chinese Language) support
+SVN_DESC= Subversion support (required to check out sources)
+OPTIONS_DEFAULT= OPENJADE CJK SVN
+
+.if !defined(WITHOUT_JADETEX) || defined(PACKAGE_BUILDING)
+OPTIONS_DEFAULT+= JADETEX
+.endif
+
+.include <bsd.port.options.mk>
+
.include <bsd.port.pre.mk>
-.if defined(WITH_OPENJADE) || ${ARCH} != "i386"
+.if ${PORT_OPTIONS:MOPENJADE} || ${ARCH} != "i386"
RUN_DEPENDS+= openjade:${PORTSDIR}/textproc/openjade \
onsgmls:${PORTSDIR}/textproc/opensp
.else
RUN_DEPENDS+= jade:${PORTSDIR}/textproc/jade
.endif
-.if defined(JADETEX)
-WITH_JADETEX= ${JADETEX}
+.if ${PORT_OPTIONS:MSVN}
+RUN_DEPENDS+= svn:${PORTSDIR}/devel/subversion
.endif
-WITH_JADETEX?=
-.if defined(PACKAGE_BUILDING)
-WITH_JADETEX= yes
-.endif
-
-.if empty(WITH_JADETEX)
-IGNORE= user must set WITH_JADETEX variable to 'yes' or 'no'
-.endif
-.if defined(WITH_JADETEX) && ${WITH_JADETEX} == yes
+.if ${PORT_OPTIONS:MJADETEX}
RUN_DEPENDS+= ${LOCALBASE}/share/texmf/web2c/jadetex.fmt:${PORTSDIR}/print/jadetex
RUN_DEPENDS+= dvips:${PORTSDIR}/print/dvipsk-tetex
-.if !defined(WITHOUT_CJK)
+.if ${PORT_OPTIONS:MCJK}
RUN_DEPENDS+= cjktexsty:${PORTSDIR}/chinese/docproj
.endif
.endif
-.if !defined(WITHOUT_CJK)
+.if ${PORT_OPTIONS:MCJK}
RUN_DEPENDS+= html2text:${PORTSDIR}/textproc/html2text
.endif
@@ -88,20 +89,12 @@ DEPENDS_ARGS+= BATCH=yes
DEPENDS_ARGS+= WITHOUT_X11=${WITHOUT_X11}
.endif
-message-jadetex:
- @${CAT} ${FILESDIR}/JADETEX
- @${FALSE}
-
# generate MINIMALDOCPORTS for src/release/Makefile.inc.docports.
# (XXX: incomplete yet)
minimaldocports:
@${ECHO_CMD} "MINIMALDOCPORTS= \\"
@${MAKE} all-depends-list | ${SED} -e 's,^${PORTSDIR}/, ,' -e 's,$$, \\,'
-.if empty(WITH_JADETEX) && !make(deinstall)
-pre-everything:: message-jadetex
-.endif
-
do-install: # empty
.include <bsd.port.post.mk>