aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2006-04-28 15:34:00 +0800
committerijliao <ijliao@FreeBSD.org>2006-04-28 15:34:00 +0800
commitb517cf74911e959fd64872f4cdfb374aca4feda7 (patch)
treee47f1697bf1f2ac2019e7c08181e9faf86ca1e53 /textproc
parentb515b7a696dd5c6f7a6b2f34dd0546c8b8cc4a90 (diff)
downloadfreebsd-ports-gnome-b517cf74911e959fd64872f4cdfb374aca4feda7.tar.gz
freebsd-ports-gnome-b517cf74911e959fd64872f4cdfb374aca4feda7.tar.zst
freebsd-ports-gnome-b517cf74911e959fd64872f4cdfb374aca4feda7.zip
add iksemel 1.2
XML parser library mainly designed for Jabber applications PR: 96283 Submitted by: trasz <trasz@pin.if.uz.zgora.pl>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/iksemel/Makefile26
-rw-r--r--textproc/iksemel/distinfo3
-rw-r--r--textproc/iksemel/files/patch-Makefile.in11
-rw-r--r--textproc/iksemel/files/patch-doc-Makefile.in20
-rw-r--r--textproc/iksemel/files/patch-ltmain.sh15
-rw-r--r--textproc/iksemel/pkg-descr7
-rw-r--r--textproc/iksemel/pkg-plist8
8 files changed, 91 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 19eacb765062..e06310db6246 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -190,6 +190,7 @@
SUBDIR += iiimf-server
SUBDIR += iiimf-x
SUBDIR += iiimf-x-lib
+ SUBDIR += iksemel
SUBDIR += info2html
SUBDIR += info2man
SUBDIR += info_to_html
diff --git a/textproc/iksemel/Makefile b/textproc/iksemel/Makefile
new file mode 100644
index 000000000000..743314fcfb43
--- /dev/null
+++ b/textproc/iksemel/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: iksemel
+# Date created: 24 April 2006
+# Whom: trasz
+#
+# $FreeBSD$
+#
+
+PORTNAME= iksemel
+PORTVERSION= 1.2
+CATEGORIES= textproc
+MASTER_SITES= http://jabberstudio.2nw.net/iksemel/
+
+MAINTAINER= trasz@pin.if.uz.zgora.pl
+COMMENT= XML parser library mainly designed for Jabber applications
+
+LIB_DEPENDS= gnutls.15:${PORTSDIR}/security/gnutls
+
+USE_GETOPT_LONG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+INSTALLS_SHLIB= yes
+
+INFO= iksemel
+
+.include <bsd.port.mk>
diff --git a/textproc/iksemel/distinfo b/textproc/iksemel/distinfo
new file mode 100644
index 000000000000..5a1c25658edb
--- /dev/null
+++ b/textproc/iksemel/distinfo
@@ -0,0 +1,3 @@
+MD5 (iksemel-1.2.tar.gz) = 82e7c8fdb6211839246b788c040a796b
+SHA256 (iksemel-1.2.tar.gz) = a606e230b22d9d029998b84e5d6311a8ba35a304fe457e254eb5fd19943cd639
+SIZE (iksemel-1.2.tar.gz) = 429405
diff --git a/textproc/iksemel/files/patch-Makefile.in b/textproc/iksemel/files/patch-Makefile.in
new file mode 100644
index 000000000000..2bb41e644f36
--- /dev/null
+++ b/textproc/iksemel/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Mon Apr 24 22:21:34 2006
++++ Makefile.in Mon Apr 24 22:21:37 2006
+@@ -92,7 +92,7 @@
+
+ EXTRA_DIST = HACKING iksemel.pc.in
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = ${prefix}/libdata/pkgconfig
+ pkgconfig_DATA = iksemel.pc
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/textproc/iksemel/files/patch-doc-Makefile.in b/textproc/iksemel/files/patch-doc-Makefile.in
new file mode 100644
index 000000000000..309c44c6c9ea
--- /dev/null
+++ b/textproc/iksemel/files/patch-doc-Makefile.in
@@ -0,0 +1,20 @@
+--- doc/Makefile.in.orig Fri Aug 6 20:39:05 2004
++++ doc/Makefile.in Fri Apr 28 15:25:23 2006
+@@ -93,7 +93,7 @@
+ CONFIG_HEADER = ../include/config.h
+ CONFIG_CLEAN_FILES =
+ TEXI2DVI = texi2dvi
+-INFO_DEPS = iksemel
++INFO_DEPS = iksemel.info
+ DVIS = iksemel.dvi
+ TEXINFOS = iksemel.texi
+ DIST_COMMON = Makefile.am Makefile.in texinfo.tex
+@@ -123,7 +123,7 @@
+ .texi.info:
+ @cd $(srcdir) && rm -f $@ $@-[0-9] $@-[0-9][0-9]
+ cd $(srcdir) \
+- && $(MAKEINFO) `echo $< | sed 's,.*/,,'`
++ && $(MAKEINFO) `echo $< | sed 's,.*/,,'` -o $@
+
+ .texi.dvi:
+ TEXINPUTS=.:$$TEXINPUTS \
diff --git a/textproc/iksemel/files/patch-ltmain.sh b/textproc/iksemel/files/patch-ltmain.sh
new file mode 100644
index 000000000000..f5e16f33bc97
--- /dev/null
+++ b/textproc/iksemel/files/patch-ltmain.sh
@@ -0,0 +1,15 @@
+--- ltmain.sh.orig Fri Apr 28 11:54:06 2006
++++ ltmain.sh Fri Apr 28 11:54:14 2006
+@@ -5550,10 +5550,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false ; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/textproc/iksemel/pkg-descr b/textproc/iksemel/pkg-descr
new file mode 100644
index 000000000000..5b60e1ecace6
--- /dev/null
+++ b/textproc/iksemel/pkg-descr
@@ -0,0 +1,7 @@
+This is an XML parser library mainly designed for Jabber applications.
+It provides SAX, DOM, and special Jabber stream APIs. Library is coded
+in ANSI C except the network code (which is POSIX compatible), thus
+highly portable. Iksemel is released under GNU Lesser General Public
+License. A copy of the license is included in the COPYING file.
+
+WWW: http://iksemel.jabberstudio.org/
diff --git a/textproc/iksemel/pkg-plist b/textproc/iksemel/pkg-plist
new file mode 100644
index 000000000000..4d3742d06642
--- /dev/null
+++ b/textproc/iksemel/pkg-plist
@@ -0,0 +1,8 @@
+bin/ikslint
+bin/iksperf
+bin/iksroster
+include/iksemel.h
+lib/libiksemel.a
+lib/libiksemel.so
+lib/libiksemel.so.3
+libdata/pkgconfig/iksemel.pc