aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2005-09-01 18:57:20 +0800
committertobez <tobez@FreeBSD.org>2005-09-01 18:57:20 +0800
commitb8013c1197a3872c1c960c3abcaed93ed2d66c96 (patch)
treef9d6a306371d9cc477f63a4819eaf8d78a936c6d /textproc
parentbefc2d2032d4da56aab27f3d12f653b75bd4ff42 (diff)
downloadfreebsd-ports-gnome-b8013c1197a3872c1c960c3abcaed93ed2d66c96.tar.gz
freebsd-ports-gnome-b8013c1197a3872c1c960c3abcaed93ed2d66c96.tar.zst
freebsd-ports-gnome-b8013c1197a3872c1c960c3abcaed93ed2d66c96.zip
Add p5-Pod-POM-View-HTML-Filter, a perl module which takes advantage of
existing syntax coloring modules to produce colorful code examples in a POD document.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Pod-POM-View-HTML-Filter/Makefile34
-rw-r--r--textproc/p5-Pod-POM-View-HTML-Filter/distinfo2
-rw-r--r--textproc/p5-Pod-POM-View-HTML-Filter/pkg-descr5
-rw-r--r--textproc/p5-Pod-POM-View-HTML-Filter/pkg-plist11
5 files changed, 53 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 36d0911f5c48..e001268eb363 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -339,6 +339,7 @@
SUBDIR += p5-Pod-DocBook
SUBDIR += p5-Pod-Escapes
SUBDIR += p5-Pod-POM
+ SUBDIR += p5-Pod-POM-View-HTML-Filter
SUBDIR += p5-Pod-Parser
SUBDIR += p5-Pod-ProjectDocs
SUBDIR += p5-Pod-Simple
diff --git a/textproc/p5-Pod-POM-View-HTML-Filter/Makefile b/textproc/p5-Pod-POM-View-HTML-Filter/Makefile
new file mode 100644
index 000000000000..437e85e5ce90
--- /dev/null
+++ b/textproc/p5-Pod-POM-View-HTML-Filter/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: textproc/p5-Pod-POM-View-HTML-Filter
+# Date created: 01 September 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Pod-POM-View-HTML-Filter
+PORTVERSION= 0.05
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Pod
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Use filters on sections of your pod documents
+
+BUILD_DEPENDS= ${SITE_PERL}/Pod/POM.pm:${PORTSDIR}/textproc/p5-Pod-POM \
+ ${SITE_PERL}/Syntax/Highlight/Shell.pm:${PORTSDIR}/www/p5-Syntax-Highlight-Shell \
+ ${SITE_PERL}/Perl/Tidy.pm:${PORTSDIR}/devel/p5-Perl-Tidy \
+ ${SITE_PERL}/Syntax/Highlight/HTML.pm:${PORTSDIR}/www/p5-Syntax-Highlight-HTML
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Pod::POM::View::HTML::Filter.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Port requires perl 5.6.0 or later. Install lang/perl5 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Pod-POM-View-HTML-Filter/distinfo b/textproc/p5-Pod-POM-View-HTML-Filter/distinfo
new file mode 100644
index 000000000000..3fdd9952a005
--- /dev/null
+++ b/textproc/p5-Pod-POM-View-HTML-Filter/distinfo
@@ -0,0 +1,2 @@
+MD5 (Pod-POM-View-HTML-Filter-0.05.tar.gz) = dc29537f51304f58a2cbf27cfcc7a3ae
+SIZE (Pod-POM-View-HTML-Filter-0.05.tar.gz) = 13572
diff --git a/textproc/p5-Pod-POM-View-HTML-Filter/pkg-descr b/textproc/p5-Pod-POM-View-HTML-Filter/pkg-descr
new file mode 100644
index 000000000000..c2db86e38c7a
--- /dev/null
+++ b/textproc/p5-Pod-POM-View-HTML-Filter/pkg-descr
@@ -0,0 +1,5 @@
+The whole idea of this module is to take advantage of all the syntax
+colouring modules that exist (such as Perl::Tidy) to produce colourful
+code examples in a POD document (after conversion to HTML).
+
+WWW: http://search.cpan.org/dist/Pod-POM-View-HTML-Filter
diff --git a/textproc/p5-Pod-POM-View-HTML-Filter/pkg-plist b/textproc/p5-Pod-POM-View-HTML-Filter/pkg-plist
new file mode 100644
index 000000000000..582fefd984b6
--- /dev/null
+++ b/textproc/p5-Pod-POM-View-HTML-Filter/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/Pod/POM/View/HTML/Filter.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod/POM/View/HTML/Filter/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod/POM/View/HTML/Filter
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod/POM/View/HTML 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod/POM/View 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Pod/POM/View/HTML 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod/POM 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Pod/POM/View 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Pod/POM 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Pod 2>/dev/null || true