aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-08-01 11:33:57 +0800
committerclsung <clsung@FreeBSD.org>2006-08-01 11:33:57 +0800
commitc56494dd5f31f566748b96c4cef08c506da7cbaa (patch)
tree5271d9e4bd25866b93cccefeacbf4a950a4f57a7 /textproc
parent1d34a31b700bb0bd82d5647eb59dee37efc1b342 (diff)
downloadfreebsd-ports-gnome-c56494dd5f31f566748b96c4cef08c506da7cbaa.tar.gz
freebsd-ports-gnome-c56494dd5f31f566748b96c4cef08c506da7cbaa.tar.zst
freebsd-ports-gnome-c56494dd5f31f566748b96c4cef08c506da7cbaa.zip
- p5-XML-RSS-Feed provide the ability of Persistant XML RSS Encapsulation
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-XML-RSS-Feed/Makefile38
-rw-r--r--textproc/p5-XML-RSS-Feed/distinfo3
-rw-r--r--textproc/p5-XML-RSS-Feed/pkg-descr3
-rw-r--r--textproc/p5-XML-RSS-Feed/pkg-plist12
5 files changed, 57 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index d318196ce9d0..808e46805a57 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -601,6 +601,7 @@
SUBDIR += p5-XML-Quote
SUBDIR += p5-XML-RAI
SUBDIR += p5-XML-RSS
+ SUBDIR += p5-XML-RSS-Feed
SUBDIR += p5-XML-RSS-JavaScript
SUBDIR += p5-XML-RSS-LibXML
SUBDIR += p5-XML-RSS-Liberal
diff --git a/textproc/p5-XML-RSS-Feed/Makefile b/textproc/p5-XML-RSS-Feed/Makefile
new file mode 100644
index 000000000000..2a804e59445c
--- /dev/null
+++ b/textproc/p5-XML-RSS-Feed/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: XML::RSS::Feed
+# Date created: Aug 1, 2006
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-RSS-Feed
+PORTVERSION= 2.2
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Persistant XML RSS Encapsulation
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
+ ${SITE_PERL}/XML/RSS.pm:${PORTSDIR}/textproc/p5-XML-RSS \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::RSS::Feed.3 \
+ XML::RSS::Headline.3 \
+ XML::RSS::Headline::Fark.3 \
+ XML::RSS::Headline::PerlJobs.3 \
+ XML::RSS::Headline::UsePerlJournals.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-XML-RSS-Feed/distinfo b/textproc/p5-XML-RSS-Feed/distinfo
new file mode 100644
index 000000000000..1a2b05e8f011
--- /dev/null
+++ b/textproc/p5-XML-RSS-Feed/distinfo
@@ -0,0 +1,3 @@
+MD5 (XML-RSS-Feed-2.2.tar.gz) = d976806ef05a1e4357c1c0e830424cb2
+SHA256 (XML-RSS-Feed-2.2.tar.gz) = 9dde1621f1caf34b5d19842f7f4cc3debf8e2d4135a67033f951eba44a2f5753
+SIZE (XML-RSS-Feed-2.2.tar.gz) = 34442
diff --git a/textproc/p5-XML-RSS-Feed/pkg-descr b/textproc/p5-XML-RSS-Feed/pkg-descr
new file mode 100644
index 000000000000..f778c3c87233
--- /dev/null
+++ b/textproc/p5-XML-RSS-Feed/pkg-descr
@@ -0,0 +1,3 @@
+XML::RSS::Feed - Persistant XML RSS Encapsulation
+
+WWW: http://search.cpan.org/dist/XML-RSS-Feed/
diff --git a/textproc/p5-XML-RSS-Feed/pkg-plist b/textproc/p5-XML-RSS-Feed/pkg-plist
new file mode 100644
index 000000000000..3f11b2f784c7
--- /dev/null
+++ b/textproc/p5-XML-RSS-Feed/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/XML/RSS/Feed.pm
+%%SITE_PERL%%/XML/RSS/Headline.pm
+%%SITE_PERL%%/XML/RSS/Headline/Fark.pm
+%%SITE_PERL%%/XML/RSS/Headline/PerlJobs.pm
+%%SITE_PERL%%/XML/RSS/Headline/UsePerlJournals.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/RSS/Feed/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/RSS/Feed
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/RSS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML
+@dirrm %%SITE_PERL%%/XML/RSS/Headline
+@dirrmtry %%SITE_PERL%%/XML/RSS
+@dirrmtry %%SITE_PERL%%/XML