aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2012-05-24 10:28:19 +0800
committerwen <wen@FreeBSD.org>2012-05-24 10:28:19 +0800
commitc752a447e3bbf571411004023183d07392aa9a08 (patch)
tree99fb5a5a1025246616820d15576f13e836be50db /textproc
parent60a591f5ce5aaddc70cf6767f69407780d94c2a5 (diff)
downloadfreebsd-ports-gnome-c752a447e3bbf571411004023183d07392aa9a08.tar.gz
freebsd-ports-gnome-c752a447e3bbf571411004023183d07392aa9a08.tar.zst
freebsd-ports-gnome-c752a447e3bbf571411004023183d07392aa9a08.zip
Whoosh is a fast, featureful full-text indexing and searching library
implemented in pure Python. Programmers can use it to easily add search functionality to their applications and websites. Every part of how Whoosh works can be extended or replaced to meet your needs exactly. Some of Whoosh's features include: - Pythonic API. - Pure-Python. No compilation or binary packages needed, no mysterious crashes. - Fielded indexing and search. - Fast indexing and retrieval -- faster than any other pure-Python, scoring, full-text search solution I know of. - Pluggable scoring algorithm (including BM25F), text analysis, storage, posting format, etc. - Powerful query language. - Pure Python spell-checker (as far as I know, the only one). WWW: http://bitbucket.org/mchaput/whoosh PR: 167185 Submitted by: Luiz Gustavo <luizgustavo@luizgustavo.pro.br>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-whoosh/Makefile24
-rw-r--r--textproc/py-whoosh/distinfo2
-rw-r--r--textproc/py-whoosh/pkg-descr19
4 files changed, 46 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index f9e949d221ad..9f49a5740c50 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1153,6 +1153,7 @@
SUBDIR += py-translationstring
SUBDIR += py-tvgrab
SUBDIR += py-twistedLore
+ SUBDIR += py-whoosh
SUBDIR += py-wicked
SUBDIR += py-wordnet
SUBDIR += py-wtforms
diff --git a/textproc/py-whoosh/Makefile b/textproc/py-whoosh/Makefile
new file mode 100644
index 000000000000..28d49223c2df
--- /dev/null
+++ b/textproc/py-whoosh/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: py-whoosh
+# Date created: 2012-04-21
+# Whom: gugabsd <gugabsd@mundounix.com.br>
+#
+# $FreeBSD$
+#
+
+PORTNAME= whoosh
+PORTVERSION= 2.3.2
+CATEGORIES= textproc www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= Whoosh-${PORTVERSION}
+
+MAINTAINER= gugabsd@mundounix.com.br
+COMMENT= Featureful full-text indexing and searching in Python
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_PKGNAME= Whoosh
+
+.include <bsd.port.mk>
diff --git a/textproc/py-whoosh/distinfo b/textproc/py-whoosh/distinfo
new file mode 100644
index 000000000000..f8dc4ac3364e
--- /dev/null
+++ b/textproc/py-whoosh/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Whoosh-2.3.2.tar.gz) = 15d451a6045bffed6dfc141a72647ec350e08d218ac0f550b0120af81e5152c7
+SIZE (Whoosh-2.3.2.tar.gz) = 882717
diff --git a/textproc/py-whoosh/pkg-descr b/textproc/py-whoosh/pkg-descr
new file mode 100644
index 000000000000..06b7feab9cca
--- /dev/null
+++ b/textproc/py-whoosh/pkg-descr
@@ -0,0 +1,19 @@
+Whoosh is a fast, featureful full-text indexing and searching library
+implemented in pure Python. Programmers can use it to easily add search
+functionality to their applications and websites. Every part of how Whoosh
+works can be extended or replaced to meet your needs exactly.
+
+Some of Whoosh's features include:
+
+- Pythonic API.
+- Pure-Python. No compilation or binary packages needed, no mysterious
+ crashes.
+- Fielded indexing and search.
+- Fast indexing and retrieval -- faster than any other pure-Python, scoring,
+ full-text search solution I know of.
+- Pluggable scoring algorithm (including BM25F), text analysis, storage,
+ posting format, etc.
+- Powerful query language.
+- Pure Python spell-checker (as far as I know, the only one).
+
+WWW: http://bitbucket.org/mchaput/whoosh