aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2013-07-08 06:51:15 +0800
committernivit <nivit@FreeBSD.org>2013-07-08 06:51:15 +0800
commitccb78214350a12e1bd2d5dfacdaceb6c5cc331fa (patch)
tree8e92f1dd28f3ec74f7dded449917db0600a29a8f /textproc
parent02b4e321987e7d788b3cf4c611199d38ffa2400a (diff)
downloadfreebsd-ports-gnome-ccb78214350a12e1bd2d5dfacdaceb6c5cc331fa.tar.gz
freebsd-ports-gnome-ccb78214350a12e1bd2d5dfacdaceb6c5cc331fa.tar.zst
freebsd-ports-gnome-ccb78214350a12e1bd2d5dfacdaceb6c5cc331fa.zip
- Fix build with Python 3.2 [1]
Build log: http://goo.gl/W77Ku Reported by: eadler (via private email) [1] Approved by: wen (mantainer, via private email)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/py-MarkupSafe/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/textproc/py-MarkupSafe/Makefile b/textproc/py-MarkupSafe/Makefile
index c7450dc592f8..791ce0e70033 100644
--- a/textproc/py-MarkupSafe/Makefile
+++ b/textproc/py-MarkupSafe/Makefile
@@ -18,6 +18,14 @@ PYEASYINSTALL_ARCHDEP= no
.include <bsd.port.pre.mk>
+.if ${PYTHON_VERSION} == python3.2
+PY2TO3_CMD= ${LOCALBASE}/bin/2to3-${PYTHON_VER}
+PY2TO3_ARGS= --no-diffs --fix=all --nobackups --verbose --write
+
+pre-build:
+ @${PY2TO3_CMD} ${PY2TO3_ARGS} ${WRKSRC}/markupsafe
+.endif
+
.if ${PYTHON_REL} >= 320
.include "${PORTSDIR}/devel/py-virtualenv/files/py3k-fix-pkg-plist.inc"
.endif