aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authoryoichi <yoichi@FreeBSD.org>2002-02-18 16:42:36 +0800
committeryoichi <yoichi@FreeBSD.org>2002-02-18 16:42:36 +0800
commitd0148a52faebbc65069359b200b0f2b0d4d495d8 (patch)
tree25d547770a63d887533c7fd91a8879c0a4b028d5 /textproc
parentb45e78eee70d8dc879ed9e3398c474aade78c168 (diff)
downloadfreebsd-ports-gnome-d0148a52faebbc65069359b200b0f2b0d4d495d8.tar.gz
freebsd-ports-gnome-d0148a52faebbc65069359b200b0f2b0d4d495d8.tar.zst
freebsd-ports-gnome-d0148a52faebbc65069359b200b0f2b0d4d495d8.zip
Add xml-lite.el, provides a simple indentation engine for XML.
PR: ports/35067 Submitted by: Kimura Fuyuki <fuyuki@mj.0038.net>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/xml-lite.el/Makefile32
-rw-r--r--textproc/xml-lite.el/distinfo1
-rw-r--r--textproc/xml-lite.el/pkg-comment1
-rw-r--r--textproc/xml-lite.el/pkg-descr8
-rw-r--r--textproc/xml-lite.el/pkg-message4
-rw-r--r--textproc/xml-lite.el/pkg-plist1
7 files changed, 48 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 8686407cf286..cab2a14bbc4d 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -290,6 +290,7 @@
SUBDIR += xlhtml
SUBDIR += xls2xml
SUBDIR += xml-i18n-tools
+ SUBDIR += xml-lite.el
SUBDIR += xml4j
SUBDIR += xmlcharent
SUBDIR += xmlpp
diff --git a/textproc/xml-lite.el/Makefile b/textproc/xml-lite.el/Makefile
new file mode 100644
index 000000000000..441c1d048450
--- /dev/null
+++ b/textproc/xml-lite.el/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: xml-lite.el
+# Date created: 18 February 2002
+# Whom: Kimura Fuyuki <fuyuki@mj.0038.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xml-lite.el
+PORTVERSION= 1.24
+CATEGORIES= textproc elisp
+MASTER_SITES= http://members.ozemail.com.au/~mdub/software/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= fuyuki@mj.0038.net
+
+EMACS_PORT_NAME?= emacs21
+EMACS_NO_BUILD_DEPENDS= YES
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+LISPDIR= ${EMACS_VERSION_SITE_LISPDIR}
+
+do-install:
+ ${INSTALL_DATA} ${DISTDIR}/${DISTNAME} ${PREFIX}/${LISPDIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/textproc/xml-lite.el/distinfo b/textproc/xml-lite.el/distinfo
new file mode 100644
index 000000000000..0b64fa8c64bb
--- /dev/null
+++ b/textproc/xml-lite.el/distinfo
@@ -0,0 +1 @@
+MD5 (xml-lite.el) = e27039158cd4ab27c99f7f0b9cf1b347
diff --git a/textproc/xml-lite.el/pkg-comment b/textproc/xml-lite.el/pkg-comment
new file mode 100644
index 000000000000..0ac00415979a
--- /dev/null
+++ b/textproc/xml-lite.el/pkg-comment
@@ -0,0 +1 @@
+A simple XML-editing for GNU Emacs
diff --git a/textproc/xml-lite.el/pkg-descr b/textproc/xml-lite.el/pkg-descr
new file mode 100644
index 000000000000..f7c49c787e70
--- /dev/null
+++ b/textproc/xml-lite.el/pkg-descr
@@ -0,0 +1,8 @@
+This package provides a simple indentation engine for XML. It is
+intended for use in situations where the full power of the popular
+PSGML package (DTD parsing, syntax checking) is not required.
+
+WWW: http://www.bigfoot.com/~mdub/
+
+- Kimura Fuyuki
+fuyuki@mj.0038.net
diff --git a/textproc/xml-lite.el/pkg-message b/textproc/xml-lite.el/pkg-message
new file mode 100644
index 000000000000..5e2c02ef3e8a
--- /dev/null
+++ b/textproc/xml-lite.el/pkg-message
@@ -0,0 +1,4 @@
+To use xml-lite-mode, add to your ~/.emacs the following lines:
+
+(autoload 'xml-lite-mode "xml-lite" "XML-Lite mode" t)
+(add-to-list 'auto-mode-alist '("\\.xml\\'" . xml-lite-mode))
diff --git a/textproc/xml-lite.el/pkg-plist b/textproc/xml-lite.el/pkg-plist
new file mode 100644
index 000000000000..9ad528b79048
--- /dev/null
+++ b/textproc/xml-lite.el/pkg-plist
@@ -0,0 +1 @@
+%%EMACS_VERSION_SITE_LISPDIR%%/xml-lite.el