aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-09-09 07:37:23 +0800
committerjbeich <jbeich@FreeBSD.org>2016-09-09 07:37:23 +0800
commitd2c341933bee77b5b4de8fa8e6cc0880f01188ac (patch)
tree041e57e39cdc966dd491d9802b3ddfad46775f96 /textproc
parent68411425e434de87bd1ff8669128db760dc6ded6 (diff)
downloadfreebsd-ports-gnome-d2c341933bee77b5b4de8fa8e6cc0880f01188ac.tar.gz
freebsd-ports-gnome-d2c341933bee77b5b4de8fa8e6cc0880f01188ac.tar.zst
freebsd-ports-gnome-d2c341933bee77b5b4de8fa8e6cc0880f01188ac.zip
textproc/py-cloud_sptheme: unbreak after r415071
PR: 212496 Submitted by: w.schwarzenfeld@utanet.at
Diffstat (limited to 'textproc')
-rw-r--r--textproc/py-cloud_sptheme/Makefile4
-rw-r--r--textproc/py-cloud_sptheme/files/patch-index__styling.py14
2 files changed, 15 insertions, 3 deletions
diff --git a/textproc/py-cloud_sptheme/Makefile b/textproc/py-cloud_sptheme/Makefile
index 5dd670e053ac..4c8572e19828 100644
--- a/textproc/py-cloud_sptheme/Makefile
+++ b/textproc/py-cloud_sptheme/Makefile
@@ -14,11 +14,9 @@ COMMENT= Sphinx theme
LICENSE= BSD3CLAUSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=0:textproc/py-sphinx
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=1.1:textproc/py-sphinx
RUN_DEPENDS:= ${BUILD_DEPENDS}
-BROKEN= does not build
-
USES= python
USE_PYTHON= distutils autoplist
PYDISTUTILS_BUILDARGS= build_sphinx -E
diff --git a/textproc/py-cloud_sptheme/files/patch-index__styling.py b/textproc/py-cloud_sptheme/files/patch-index__styling.py
new file mode 100644
index 000000000000..43ead1289a61
--- /dev/null
+++ b/textproc/py-cloud_sptheme/files/patch-index__styling.py
@@ -0,0 +1,14 @@
+--- cloud_sptheme/ext/index_styling.py.orig 2016-09-08 20:32:45 UTC
++++ cloud_sptheme/ext/index_styling.py
+@@ -49,8 +49,9 @@ def mangle_index(app, pagename, template
+ fmt = format_index_name
+ for key, entries in ctx['genindexentries']:
+ for idx, entry in enumerate(entries):
+- name, (links, subitems) = entry
+- entries[idx] = fmt(name), (links, subitems)
++ name, data = entry
++ entries[idx] = fmt(name), data
++ subitems = data[1]
+ for idx, entry in enumerate(subitems):
+ name, links = entry
+ subitems[idx] = fmt(name), links