aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-08-21 22:55:43 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-08-21 22:55:43 +0800
commitd6eb94a00231f69f7cafe15074076d95468988df (patch)
tree036c24888ef699a36a0db41d047b3d0e7e3acbc8 /textproc
parentcac6415533f6217327d3ba62d8b8231cbf4be182 (diff)
downloadfreebsd-ports-gnome-d6eb94a00231f69f7cafe15074076d95468988df.tar.gz
freebsd-ports-gnome-d6eb94a00231f69f7cafe15074076d95468988df.tar.zst
freebsd-ports-gnome-d6eb94a00231f69f7cafe15074076d95468988df.zip
- Use RUN_DEPENDS:=BUILD_DEPENDS
- Add BUILD_DEPENDS - Cosmetic change
Diffstat (limited to 'textproc')
-rw-r--r--textproc/p5-CSS-Packer/Makefile3
-rw-r--r--textproc/p5-HTML-Packer/Makefile3
-rw-r--r--textproc/p5-JavaScript-Packer/Makefile3
-rw-r--r--textproc/p5-Lingua-Ispell/Makefile4
-rw-r--r--textproc/p5-SVG-Parser/Makefile4
-rw-r--r--textproc/p5-Sphinx-Config/Makefile2
-rw-r--r--textproc/p5-Sphinx-Manager/Makefile5
-rw-r--r--textproc/p5-Text-Prefix-XS/Makefile3
8 files changed, 9 insertions, 18 deletions
diff --git a/textproc/p5-CSS-Packer/Makefile b/textproc/p5-CSS-Packer/Makefile
index 45ba10faaee4..8d8e583acad4 100644
--- a/textproc/p5-CSS-Packer/Makefile
+++ b/textproc/p5-CSS-Packer/Makefile
@@ -16,8 +16,7 @@ MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Another CSS minifier
BUILD_DEPENDS= p5-Regexp-RegGrp>=1.001.001:${PORTSDIR}/devel/p5-Regexp-RegGrp
-RUN_DEPENDS= p5-Regexp-RegGrp>=1.001.001:${PORTSDIR}/devel/p5-Regexp-RegGrp
-
+RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Pod>=1.22:${PORTSDIR}/devel/p5-Test-Pod
USE_PERL5= configure
diff --git a/textproc/p5-HTML-Packer/Makefile b/textproc/p5-HTML-Packer/Makefile
index 3914d27239b1..4aa6fcd1983f 100644
--- a/textproc/p5-HTML-Packer/Makefile
+++ b/textproc/p5-HTML-Packer/Makefile
@@ -16,8 +16,7 @@ MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Another HTML code cleaner
BUILD_DEPENDS= p5-Regexp-RegGrp>=1.001.001:${PORTSDIR}/devel/p5-Regexp-RegGrp
-RUN_DEPENDS= p5-Regexp-RegGrp>=1.001.001:${PORTSDIR}/devel/p5-Regexp-RegGrp
-
+RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Pod>=1.22:${PORTSDIR}/devel/p5-Test-Pod
USE_PERL5= configure
diff --git a/textproc/p5-JavaScript-Packer/Makefile b/textproc/p5-JavaScript-Packer/Makefile
index 65dcbcbfe7d9..be705d92aa75 100644
--- a/textproc/p5-JavaScript-Packer/Makefile
+++ b/textproc/p5-JavaScript-Packer/Makefile
@@ -16,8 +16,7 @@ MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Perl version of Dean Edwards' Packer.js
BUILD_DEPENDS= p5-Regexp-RegGrp>=1.001.001:${PORTSDIR}/devel/p5-Regexp-RegGrp
-RUN_DEPENDS= p5-Regexp-RegGrp>=1.001.001:${PORTSDIR}/devel/p5-Regexp-RegGrp
-
+RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Pod>=1.22:${PORTSDIR}/devel/p5-Test-Pod
USE_PERL5= configure
diff --git a/textproc/p5-Lingua-Ispell/Makefile b/textproc/p5-Lingua-Ispell/Makefile
index fae37b691b35..2248ee013377 100644
--- a/textproc/p5-Lingua-Ispell/Makefile
+++ b/textproc/p5-Lingua-Ispell/Makefile
@@ -15,11 +15,11 @@ MAINTAINER= sunpoet@FreeBSD.org
COMMENT= A Perl module that encapsulates access to the Ispell program
BUILD_DEPENDS= ${LOCALBASE}/bin/ispell:${PORTSDIR}/textproc/ispell
-RUN_DEPENDS= ${LOCALBASE}/bin/ispell:${PORTSDIR}/textproc/ispell
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+REINPLACE_ARGS= -i ''
USE_PERL5= configure
USES= perl5
-REINPLACE_ARGS= -i ''
MAN3= Lingua::Ispell.3
diff --git a/textproc/p5-SVG-Parser/Makefile b/textproc/p5-SVG-Parser/Makefile
index f0e13f453075..32d572ed7f67 100644
--- a/textproc/p5-SVG-Parser/Makefile
+++ b/textproc/p5-SVG-Parser/Makefile
@@ -17,9 +17,7 @@ COMMENT= XML Parser for SVG documents
BUILD_DEPENDS= p5-SVG>=2:${PORTSDIR}/textproc/p5-SVG \
p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
p5-XML-SAX>=0:${PORTSDIR}/textproc/p5-XML-SAX
-RUN_DEPENDS= p5-SVG>=2:${PORTSDIR}/textproc/p5-SVG \
- p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
- p5-XML-SAX>=0:${PORTSDIR}/textproc/p5-XML-SAX
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PERL5= modbuild
USES= perl5
diff --git a/textproc/p5-Sphinx-Config/Makefile b/textproc/p5-Sphinx-Config/Makefile
index 08559b01c73d..98377e336661 100644
--- a/textproc/p5-Sphinx-Config/Makefile
+++ b/textproc/p5-Sphinx-Config/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Sphinx search engine configuration file read/modify/write
BUILD_DEPENDS= p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils
-RUN_DEPENDS= p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PERL5= configure
USES= perl5
diff --git a/textproc/p5-Sphinx-Manager/Makefile b/textproc/p5-Sphinx-Manager/Makefile
index d7ea2644456c..6c8d2914c7b1 100644
--- a/textproc/p5-Sphinx-Manager/Makefile
+++ b/textproc/p5-Sphinx-Manager/Makefile
@@ -18,10 +18,7 @@ BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class \
p5-Proc-ProcessTable>=0:${PORTSDIR}/devel/p5-Proc-ProcessTable \
p5-Sphinx-Config>=0.09:${PORTSDIR}/textproc/p5-Sphinx-Config
-RUN_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
- p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class \
- p5-Proc-ProcessTable>=0:${PORTSDIR}/devel/p5-Proc-ProcessTable \
- p5-Sphinx-Config>=0.09:${PORTSDIR}/textproc/p5-Sphinx-Config
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PERL5= configure
USES= perl5
diff --git a/textproc/p5-Text-Prefix-XS/Makefile b/textproc/p5-Text-Prefix-XS/Makefile
index 8bc96f5d6abc..9c2b722345ef 100644
--- a/textproc/p5-Text-Prefix-XS/Makefile
+++ b/textproc/p5-Text-Prefix-XS/Makefile
@@ -15,8 +15,7 @@ MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Fast prefix searching
BUILD_DEPENDS= p5-Digest-SHA1>=1:${PORTSDIR}/security/p5-Digest-SHA1
-RUN_DEPENDS= p5-Digest-SHA1>=1:${PORTSDIR}/security/p5-Digest-SHA1
-
+RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Deep>=0.108:${PORTSDIR}/devel/p5-Test-Deep
USE_PERL5= configure