aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2001-10-05 16:55:59 +0800
committerpetef <petef@FreeBSD.org>2001-10-05 16:55:59 +0800
commitdfdd6d878e6a391a9833c386297d3608293cab60 (patch)
treea4a5ffa3ed6c5e2038a624e50776f92deba59b0c /textproc
parenta746d3659f643670c7f936a52c14104528415de2 (diff)
downloadfreebsd-ports-gnome-dfdd6d878e6a391a9833c386297d3608293cab60.tar.gz
freebsd-ports-gnome-dfdd6d878e6a391a9833c386297d3608293cab60.tar.zst
freebsd-ports-gnome-dfdd6d878e6a391a9833c386297d3608293cab60.zip
Add p5-Parse-Syslog-0.03, Perl5 routines that present a simple interface to
parse syslog files. PR: 30978 Submitted by: Stephen J. Roznowski <sjr@home.com>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Parse-Syslog/Makefile22
-rw-r--r--textproc/p5-Parse-Syslog/distinfo1
-rw-r--r--textproc/p5-Parse-Syslog/pkg-comment1
-rw-r--r--textproc/p5-Parse-Syslog/pkg-descr6
-rw-r--r--textproc/p5-Parse-Syslog/pkg-plist5
6 files changed, 36 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 14b20496761b..c887c6b77f68 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -100,6 +100,7 @@
SUBDIR += p5-LJ-SpellCheck
SUBDIR += p5-Lingua-Ispell
SUBDIR += p5-PDF-Create
+ SUBDIR += p5-Parse-Syslog
SUBDIR += p5-Sort-ArbBiLex
SUBDIR += p5-Sort-Fields
SUBDIR += p5-Sort-PolySort
diff --git a/textproc/p5-Parse-Syslog/Makefile b/textproc/p5-Parse-Syslog/Makefile
new file mode 100644
index 000000000000..17428b82cba5
--- /dev/null
+++ b/textproc/p5-Parse-Syslog/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Parse-Syslog
+# Date created: 27 August 2001
+# Whom: Stephen Roznowski (sjr@home.com)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Parse-Syslog
+PORTVERSION= 0.03
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Parse
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Parse::Syslog.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Parse-Syslog/distinfo b/textproc/p5-Parse-Syslog/distinfo
new file mode 100644
index 000000000000..480f784d3002
--- /dev/null
+++ b/textproc/p5-Parse-Syslog/distinfo
@@ -0,0 +1 @@
+MD5 (Parse-Syslog-0.03.tar.gz) = 1cfe359fd8a9a297fcf72ed48258987e
diff --git a/textproc/p5-Parse-Syslog/pkg-comment b/textproc/p5-Parse-Syslog/pkg-comment
new file mode 100644
index 000000000000..c3a3d29bbe81
--- /dev/null
+++ b/textproc/p5-Parse-Syslog/pkg-comment
@@ -0,0 +1 @@
+Perl5 routines that present a simple interface to parse syslog files
diff --git a/textproc/p5-Parse-Syslog/pkg-descr b/textproc/p5-Parse-Syslog/pkg-descr
new file mode 100644
index 000000000000..b9170a81edef
--- /dev/null
+++ b/textproc/p5-Parse-Syslog/pkg-descr
@@ -0,0 +1,6 @@
+Parse::Syslog presents a simple interface to parse syslog
+files: you create a parser on a file (with new) and call
+next to get one line at a time with Unix-timestamp, host,
+program, pid and text returned in a hash-reference.
+
+WWW: http://search.cpan.org/search?dist=Parse-Syslog
diff --git a/textproc/p5-Parse-Syslog/pkg-plist b/textproc/p5-Parse-Syslog/pkg-plist
new file mode 100644
index 000000000000..35a768f8afa6
--- /dev/null
+++ b/textproc/p5-Parse-Syslog/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/Parse/Syslog.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Parse/Syslog/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Parse/Syslog
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Parse 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Parse 2>/dev/null || true