aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-03-14 23:52:28 +0800
committermat <mat@FreeBSD.org>2016-03-14 23:52:28 +0800
commitdff7433d4dfe31d9500e935f584a6acb6fe604c7 (patch)
treef4e93dfbca0b4789bd46b31a25429996b43f70c4 /textproc
parentb2acc3d9084db1fc4177b6dc5b3f79915bfc2aa5 (diff)
downloadfreebsd-ports-gnome-dff7433d4dfe31d9500e935f584a6acb6fe604c7.tar.gz
freebsd-ports-gnome-dff7433d4dfe31d9500e935f584a6acb6fe604c7.tar.zst
freebsd-ports-gnome-dff7433d4dfe31d9500e935f584a6acb6fe604c7.zip
Install examples.
Sponsored by: Absolight
Diffstat (limited to 'textproc')
-rw-r--r--textproc/p5-Perl-Lint/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/textproc/p5-Perl-Lint/Makefile b/textproc/p5-Perl-Lint/Makefile
index eeb04cf352f1..8d81d3fcb402 100644
--- a/textproc/p5-Perl-Lint/Makefile
+++ b/textproc/p5-Perl-Lint/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Perl-Lint
PORTVERSION= 0.23
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:MOZNION
@@ -31,6 +31,14 @@ TEST_DEPENDS= p5-Text-TestBase>=0:${PORTSDIR}/textproc/p5-Text-TestBase
USES= perl5
USE_PERL5= modbuildtiny
+OPTIONS_DEFINE= EXAMPLES
+
+PORTEXAMPLES= lint.pl lint_string.pl
+
+post-install-EXAMPLES-on:
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/eg/|} ${STAGEDIR}${EXAMPLESDIR}
+
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} >= 502000