aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-11-13 21:22:44 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-11-13 21:22:44 +0800
commite2f63c3879e6e94cf417eed044ec0f617ce391a5 (patch)
tree83ebe301331d18287127d04f51b961235548e810 /textproc
parenta3b16b850498346600608ccc7202b5e835c5c2e5 (diff)
downloadfreebsd-ports-gnome-e2f63c3879e6e94cf417eed044ec0f617ce391a5.tar.gz
freebsd-ports-gnome-e2f63c3879e6e94cf417eed044ec0f617ce391a5.tar.zst
freebsd-ports-gnome-e2f63c3879e6e94cf417eed044ec0f617ce391a5.zip
- Add p5-Marpa-HTML 0.102
Marpa::HTML does "high-level" parsing of HTML. It allows handlers to be specified for elements, terminals and other components in the hierarchical structure of an HTML document. Marpa::HTML is an extremely liberal HTML parser. Marpa::HTML does not reject any documents, no mater how poorly they fit the HTML standards. WWW: http://search.cpan.org/dist/Marpa-HTML/ Feature safe: yes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Marpa-HTML/Makefile44
-rw-r--r--textproc/p5-Marpa-HTML/distinfo2
-rw-r--r--textproc/p5-Marpa-HTML/pkg-descr7
-rw-r--r--textproc/p5-Marpa-HTML/pkg-plist16
5 files changed, 70 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 4253cdb1794e..76ab63f47d84 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -587,6 +587,7 @@
SUBDIR += p5-Makefile-DOM
SUBDIR += p5-Makefile-Parser
SUBDIR += p5-Markapl
+ SUBDIR += p5-Marpa-HTML
SUBDIR += p5-MathML-Entities
SUBDIR += p5-Net-IDN-Encode
SUBDIR += p5-Net-YASA
diff --git a/textproc/p5-Marpa-HTML/Makefile b/textproc/p5-Marpa-HTML/Makefile
new file mode 100644
index 000000000000..f840eb36192b
--- /dev/null
+++ b/textproc/p5-Marpa-HTML/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: p5-Marpa-HTML
+# Date created: 2011-10-25
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Marpa-HTML
+PORTVERSION= 0.104
+CATEGORIES= textproc lang perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:JKEGL
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION}000
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= High-level HTML Parser
+
+BUILD_DEPENDS= p5-HTML-Parser>=3.64:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-Marpa-PP>=0.010:${PORTSDIR}/lang/p5-Marpa-PP \
+ p5-Marpa-XS>=0.020:${PORTSDIR}/lang/p5-Marpa-XS
+RUN_DEPENDS= p5-HTML-Parser>=3.64:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-Marpa-PP>=0.010:${PORTSDIR}/lang/p5-Marpa-PP \
+ p5-Marpa-XS>=0.020:${PORTSDIR}/lang/p5-Marpa-XS
+
+PERL_CONFIGURE= 5.10.0+
+
+MAN1= html_fmt.1 \
+ html_score.1
+MAN3= Marpa::HTML.3 \
+ Marpa::HTML::Support.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501200
+BUILD_DEPENDS+= p5-Data-Dumper>=2.125:${PORTSDIR}/devel/p5-Data-Dumper
+RUN_DEPENDS+= p5-Data-Dumper>=2.125:${PORTSDIR}/devel/p5-Data-Dumper
+TEST_DEPENDS+= p5-Test-Simple>=0.94:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|lib/Marpa/Support.pod|lib/Marpa/HTML/Support.pod|' ${WRKSRC}/Build.PL
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Marpa-HTML/distinfo b/textproc/p5-Marpa-HTML/distinfo
new file mode 100644
index 000000000000..11d7099ad1a4
--- /dev/null
+++ b/textproc/p5-Marpa-HTML/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Marpa-HTML-0.104000.tar.gz) = eb5874b6cefdf6720b1f09484d89c9fa1658f4ed55c7a34a527f8ce678b45b34
+SIZE (Marpa-HTML-0.104000.tar.gz) = 79273
diff --git a/textproc/p5-Marpa-HTML/pkg-descr b/textproc/p5-Marpa-HTML/pkg-descr
new file mode 100644
index 000000000000..f5813b755061
--- /dev/null
+++ b/textproc/p5-Marpa-HTML/pkg-descr
@@ -0,0 +1,7 @@
+Marpa::HTML does "high-level" parsing of HTML. It allows handlers to be
+specified for elements, terminals and other components in the hierarchical
+structure of an HTML document. Marpa::HTML is an extremely liberal HTML parser.
+Marpa::HTML does not reject any documents, no mater how poorly they fit the HTML
+standards.
+
+WWW: http://search.cpan.org/dist/Marpa-HTML/
diff --git a/textproc/p5-Marpa-HTML/pkg-plist b/textproc/p5-Marpa-HTML/pkg-plist
new file mode 100644
index 000000000000..1634be9fc332
--- /dev/null
+++ b/textproc/p5-Marpa-HTML/pkg-plist
@@ -0,0 +1,16 @@
+bin/html_fmt
+bin/html_score
+%%SITE_PERL%%/Marpa/HTML.pm
+%%SITE_PERL%%/Marpa/HTML.pod
+%%SITE_PERL%%/Marpa/HTML/Callback.pm
+%%SITE_PERL%%/Marpa/HTML/Offset.pm
+%%SITE_PERL%%/Marpa/HTML/Support.pod
+%%SITE_PERL%%/Marpa/HTML/Test.pm
+%%SITE_PERL%%/Marpa/HTML/Test/Util.pm
+%%SITE_PERL%%/Marpa/HTML/Version.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Marpa/HTML/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Marpa/HTML
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Marpa
+@dirrm %%SITE_PERL%%/Marpa/HTML/Test
+@dirrm %%SITE_PERL%%/Marpa/HTML
+@dirrmtry %%SITE_PERL%%/Marpa