aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-01-22 15:51:28 +0800
committermiwi <miwi@FreeBSD.org>2007-01-22 15:51:28 +0800
commitfaec6eff2529335c6be51bcfd92f20950713cbb9 (patch)
tree4c3565e654e56df0c6dcd667a64a0474e0782b17 /textproc
parentd3c7781e61e3bcee6eea3d493b132043a8ff91ea (diff)
downloadfreebsd-ports-gnome-faec6eff2529335c6be51bcfd92f20950713cbb9.tar.gz
freebsd-ports-gnome-faec6eff2529335c6be51bcfd92f20950713cbb9.tar.zst
freebsd-ports-gnome-faec6eff2529335c6be51bcfd92f20950713cbb9.zip
Weka is a collection of machine learning algorithms for data mining tasks. The
algorithms can either be applied directly to a dataset or called from your own Java code. Weka contains tools for data pre-processing, classification, regression, clustering, association rules, and visualization. It is also well-suited for developing new machine learning schemes. WWW: http://www.cs.waikato.ac.nz/ml/weka/ PR: ports/108143 Submitted by: Simon Olofsson <simon at olofsson.de>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/weka/Makefile37
-rw-r--r--textproc/weka/distinfo3
-rw-r--r--textproc/weka/files/weka.sh.in5
-rw-r--r--textproc/weka/pkg-descr7
5 files changed, 53 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 4dca7a9849b4..3fda39c01d1d 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -930,6 +930,7 @@
SUBDIR += wdiff
SUBDIR += webcpp
SUBDIR += website
+ SUBDIR += weka
SUBDIR += word2x
SUBDIR += wordnet
SUBDIR += words
diff --git a/textproc/weka/Makefile b/textproc/weka/Makefile
new file mode 100644
index 000000000000..8db00148c8dd
--- /dev/null
+++ b/textproc/weka/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: weka
+# Date created: 2007-01-20
+# Whom: Simon Olofsson <simon@olofsson.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= weka
+DISTVERSION= 3-4-9
+CATEGORIES= textproc java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= simon@olofsson.de
+COMMENT= Data Mining Software in Java
+
+USE_ZIP= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+NO_BUILD= yes
+
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
+
+SUB_FILES= ${PORTNAME}.sh
+SUB_LIST= JARNAME=${PORTNAME}.jar
+
+PLIST_FILES= %%DATADIR%%/${PORTNAME}.jar \
+ bin/${PORTNAME}
+PLIST_DIRS= %%DATADIR%%
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.jar \
+ ${DATADIR}/${PORTNAME}.jar
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/textproc/weka/distinfo b/textproc/weka/distinfo
new file mode 100644
index 000000000000..37e058eab673
--- /dev/null
+++ b/textproc/weka/distinfo
@@ -0,0 +1,3 @@
+MD5 (weka-3-4-9.zip) = a720f833dc71bc03210737d34ef8203e
+SHA256 (weka-3-4-9.zip) = 93db295cdd8265be0a901738c9fead74cddbd0217a6cba258c37f77bac6ecb5e
+SIZE (weka-3-4-9.zip) = 10385909
diff --git a/textproc/weka/files/weka.sh.in b/textproc/weka/files/weka.sh.in
new file mode 100644
index 000000000000..4c4c27df9607
--- /dev/null
+++ b/textproc/weka/files/weka.sh.in
@@ -0,0 +1,5 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+exec "%%LOCALBASE%%/bin/java" -jar "%%DATADIR%%/%%JARNAME%%" "$@"
diff --git a/textproc/weka/pkg-descr b/textproc/weka/pkg-descr
new file mode 100644
index 000000000000..9b54b7e837e6
--- /dev/null
+++ b/textproc/weka/pkg-descr
@@ -0,0 +1,7 @@
+Weka is a collection of machine learning algorithms for data mining tasks. The
+algorithms can either be applied directly to a dataset or called from your own
+Java code. Weka contains tools for data pre-processing, classification,
+regression, clustering, association rules, and visualization. It is also
+well-suited for developing new machine learning schemes.
+
+WWW: http://www.cs.waikato.ac.nz/ml/weka/