aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2006-07-12 13:53:15 +0800
committerrafan <rafan@FreeBSD.org>2006-07-12 13:53:15 +0800
commit03c2907fa274ef5bc2dfba9e73745fc589f3527e (patch)
tree8621893ccb5633fc2f6cd22246d45476e959411a /textproc
parent4b64f308afdf7bfacf9938caaa6cbd023e8c64d0 (diff)
downloadfreebsd-ports-gnome-03c2907fa274ef5bc2dfba9e73745fc589f3527e.tar.gz
freebsd-ports-gnome-03c2907fa274ef5bc2dfba9e73745fc589f3527e.tar.zst
freebsd-ports-gnome-03c2907fa274ef5bc2dfba9e73745fc589f3527e.zip
Add csvdiff 1.3, compare/diff two (comma) seperated files with each
other. PR: ports/100097 Submitted by: chinsan <chinsan.tw at gmail.com>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/csvdiff/Makefile36
-rw-r--r--textproc/csvdiff/distinfo3
-rw-r--r--textproc/csvdiff/pkg-descr9
4 files changed, 49 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index e108b1b6165d..8cb12c2d0ff1 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -60,6 +60,7 @@
SUBDIR += csb-aspell
SUBDIR += csv2latex
SUBDIR += csv2xml
+ SUBDIR += csvdiff
SUBDIR += ctpp
SUBDIR += cwtext
SUBDIR += cy-aspell
diff --git a/textproc/csvdiff/Makefile b/textproc/csvdiff/Makefile
new file mode 100644
index 000000000000..7c393c08f770
--- /dev/null
+++ b/textproc/csvdiff/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: csvdiff
+# Date created: 2006/07/12
+# Whom: chinsan <chinsan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= csvdiff
+PORTVERSION= 1.3
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}_${PORTVERSION:S,.,-,g}
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= Compare/diff two (comma) seperated files with each other
+
+NO_BUILD= yes
+USE_PERL5= yes
+PLIST_FILES= bin/csvdiff
+WRKSRC= ${WRKDIR}
+.if !defined(NOPORTDOCS)
+PORTDOCS= CHANGES README TODO
+.endif
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl \
+ ${PREFIX}/bin/${PORTNAME}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/$i ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/csvdiff/distinfo b/textproc/csvdiff/distinfo
new file mode 100644
index 000000000000..6d5dd89bcff6
--- /dev/null
+++ b/textproc/csvdiff/distinfo
@@ -0,0 +1,3 @@
+MD5 (csvdiff_1-3.tar.gz) = ffcafdf67c0526fe56fe1c2aa96475c8
+SHA256 (csvdiff_1-3.tar.gz) = 60b2680c748763ea19f5b0ab710d86cb44a33433be5fe0b117c3a15a0962ac91
+SIZE (csvdiff_1-3.tar.gz) = 14739
diff --git a/textproc/csvdiff/pkg-descr b/textproc/csvdiff/pkg-descr
new file mode 100644
index 000000000000..9f9ba51174f5
--- /dev/null
+++ b/textproc/csvdiff/pkg-descr
@@ -0,0 +1,9 @@
+csvdiff is a Perl script to diff/compare two csv files with the possibility
+to select the separator.
+
+Differences will be shown like:
+"Column XYZ in record 999" is different.
+After this, the actual and the expected result for this
+column will be shown.
+
+WWW: http://csvdiff.sourceforge.net/