aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2004-06-29 01:29:40 +0800
committerknu <knu@FreeBSD.org>2004-06-29 01:29:40 +0800
commit0cb8602a06c4f4422681f21e0ef61b4c1bb3b489 (patch)
tree02c073b35e1418d6f7064ad1c43a54646f50c921 /textproc
parente73df32f97a64d19c79a98af0ba898d9df976438 (diff)
downloadfreebsd-ports-gnome-0cb8602a06c4f4422681f21e0ef61b4c1bb3b489.tar.gz
freebsd-ports-gnome-0cb8602a06c4f4422681f21e0ef61b4c1bb3b489.tar.zst
freebsd-ports-gnome-0cb8602a06c4f4422681f21e0ef61b4c1bb3b489.zip
xslt4r no longer seems to be maintained, so replace it with another
newer XSLT library implementation by Gregoire Lejeune. http://www.webtime-project.net/ruby-xslt/ This update of course breaks the API compatibility.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/ruby-xslt/Makefile23
-rw-r--r--textproc/ruby-xslt/distinfo4
-rw-r--r--textproc/ruby-xslt/pkg-descr6
-rw-r--r--textproc/ruby-xslt/pkg-plist38
4 files changed, 41 insertions, 30 deletions
diff --git a/textproc/ruby-xslt/Makefile b/textproc/ruby-xslt/Makefile
index 3fc88d392b21..4c71c0d26ced 100644
--- a/textproc/ruby-xslt/Makefile
+++ b/textproc/ruby-xslt/Makefile
@@ -6,35 +6,28 @@
#
PORTNAME= xslt
-PORTVERSION= 0.0.2
+PORTVERSION= 0.3.0
CATEGORIES= textproc ruby
-MASTER_SITES= http://www.fantasy-coders.de/ruby/xslt4r/
+MASTER_SITES= http://www.webtime-project.net/ruby-xslt/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
-DISTNAME= ${PORTNAME}4r-${PORTVERSION}
+DISTNAME= ruby-${PORTNAME}_${PORTVERSION}
DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
COMMENT= An XSLT processor in pure Ruby
-RUN_DEPENDS= ${RUBY_SITELIBDIR}/xpathtree.rb:${PORTSDIR}/textproc/ruby-xmlscan-old
-
USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
-RUBY_SHEBANG_FILES= ${WRKSRC}/xslt.rb
-
-NO_BUILD= yes
+WRKSRC= ${WRKDIR}/ruby-${PORTNAME}
-DOCS= ChangeLog ToDo
+DOCS= AUTHORS README docs/*.rd doc
-do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/xslt.rb ${RUBY_SITELIBDIR}/
- ${LN} -sf ${RUBY_SITELIBDIR}/xslt.rb ${LOCALBASE}/bin/xslt
+post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/test/*.x* ${RUBY_MODEXAMPLESDIR}
${MKDIR} ${RUBY_MODDOCDIR}
.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}
+ ${CP} -R ${WRKSRC}/${f} ${RUBY_MODDOCDIR}
.endfor
.endif
diff --git a/textproc/ruby-xslt/distinfo b/textproc/ruby-xslt/distinfo
index 0ad8d2aced9a..085714cf3e6b 100644
--- a/textproc/ruby-xslt/distinfo
+++ b/textproc/ruby-xslt/distinfo
@@ -1,2 +1,2 @@
-MD5 (ruby/xslt4r-0.0.2.tar.gz) = 50504106dbe6bf479a825782842b52fa
-SIZE (ruby/xslt4r-0.0.2.tar.gz) = 52434
+MD5 (ruby/ruby-xslt_0.3.0.tar.gz) = d477d012feb9c3a01a4525a8b8f7950f
+SIZE (ruby/ruby-xslt_0.3.0.tar.gz) = 23124
diff --git a/textproc/ruby-xslt/pkg-descr b/textproc/ruby-xslt/pkg-descr
index 3ea1b1d2126f..23ede8bccecf 100644
--- a/textproc/ruby-xslt/pkg-descr
+++ b/textproc/ruby-xslt/pkg-descr
@@ -1,4 +1,4 @@
-This is XSLT4R, an XSLT processor in pure Ruby.
+This is a Ruby class for processing XSLT.
-Author: Michael Neumann <neumann@s-direktnet.de>
-WWW: http://www.ruby-lang.org/raa/list.rhtml?name=xslt4r
+Author: Gregoire Lejeune <glejeune.lejeune@free.fr>
+WWW: http://www.webtime-project.net/ruby-xslt/
diff --git a/textproc/ruby-xslt/pkg-plist b/textproc/ruby-xslt/pkg-plist
index 01ed233de5ee..ce114373554a 100644
--- a/textproc/ruby-xslt/pkg-plist
+++ b/textproc/ruby-xslt/pkg-plist
@@ -1,11 +1,29 @@
-bin/xslt
-%%RUBY_SITELIBDIR%%/xslt.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/data.xml
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/stylesheet.xsl
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/stylesheet2.xsl
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test.xml
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test_style.xsl
-%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ChangeLog
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ToDo
+%%RUBY_SITEARCHLIBDIR%%/xml/xslt.so
+@unexec /bin/rmdir %%RUBY_SITEARCHLIBDIR%%/xml 2>/dev/null || true
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/AUTHORS
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/xslt.en.rd
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/doc/classes/XML.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/doc/classes/XML/XSLT.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/doc/classes/XML/XSLT.src/M000001.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/doc/classes/XML/XSLT.src/M000002.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/doc/classes/XML/XSLT.src/M000003.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/doc/classes/XML/XSLT.src/M000004.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/doc/classes/XML/XSLT.src/M000005.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/doc/classes/XML/XSLT.src/M000006.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/doc/classes/XML/XSLT.src/M000007.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/doc/classes/XML/XSLT.src/M000008.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/doc/classes/XML/XSLT.src/M000009.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/doc/created.rid
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/doc/files/xslt_c.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/doc/fr_class_index.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/doc/fr_file_index.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/doc/fr_method_index.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/doc/index.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/doc/rdoc-style.css
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%/doc/files
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%/doc/classes/XML/XSLT.src
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%/doc/classes/XML
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%/doc/classes
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%/doc
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%