aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-11-21 03:46:02 +0800
committerpi <pi@FreeBSD.org>2016-11-21 03:46:02 +0800
commit0da948aa87b17d83b1d848394f4984c74dc8beb4 (patch)
treedf0ed3b1914682fec9b4d5a3de43558f16bc2b84 /textproc
parentfbabf698217c8df9b4822991266ab91612f3ea8a (diff)
downloadfreebsd-ports-gnome-0da948aa87b17d83b1d848394f4984c74dc8beb4.tar.gz
freebsd-ports-gnome-0da948aa87b17d83b1d848394f4984c74dc8beb4.tar.zst
freebsd-ports-gnome-0da948aa87b17d83b1d848394f4984c74dc8beb4.zip
textproc/fzf: Update 13.4 -> 0.15.8
PR: 214678 Changes: https://github.com/junegunn/fzf/blob/master/CHANGELOG.md Submitted by: Sascha Holzleiter <sascha@root-login.org> (maintainer)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/fzf/Makefile24
-rw-r--r--textproc/fzf/distinfo12
-rw-r--r--textproc/fzf/files/patch-src_options.go11
-rw-r--r--textproc/fzf/files/patch-src_terminal.go11
4 files changed, 24 insertions, 34 deletions
diff --git a/textproc/fzf/Makefile b/textproc/fzf/Makefile
index 61364d83db55..8140f93738dc 100644
--- a/textproc/fzf/Makefile
+++ b/textproc/fzf/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= fzf
-PORTVERSION= 0.13.4
+PORTVERSION= 0.15.8
CATEGORIES= textproc
MAINTAINER= sascha@root-login.org
@@ -11,22 +11,20 @@ COMMENT= Blazing fast command-line fuzzy finder
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= go-runewidth>0:devel/go-runewidth \
- go-shellwords>0:devel/go-shellwords
-
USES= compiler go ncurses
USE_GITHUB= yes
GH_ACCOUNT= junegunn
+GH_SUBDIR:= src/github.com/${GH_ACCOUNT}/${PORTNAME}
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
-
-GO_TARGET= ${GO_PKGNAME}/src/fzf
-MAKE_ENV+= CGO_CPPFLAGS="-I${NCURSESINC}"
+GH_TUPLE= junegunn:go-runewidth:63c378b:runwidth/src/github.com/junegunn/go-runewidth \
+ junegunn:go-shellwords:35d512a:shellwords/src/github.com/junegunn/go-shellwords \
+ junegunn:go-isatty:66b8e73:isatty/src/github.com/junegunn/go-isatty
PLIST_FILES= bin/fzf man/man1/fzf.1.gz
+STRIP= # do not strip go binaries
+
OPTIONS_DEFINE= TMUX
TMUX_DESC= Install fzf-tmux (depends on BASH)
@@ -35,6 +33,14 @@ OPTIONS_DEFAULT= TMUX
TMUX_RUN_DEPENDS= bash:shells/bash
TMUX_PLIST_FILES= bin/fzf-tmux man/man1/fzf-tmux.1.gz
+do-build:
+ @cd ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}/src/fzf; \
+ ${SETENV} ${BUILD_ENV} GOPATH=${WRKSRC} \
+ go build -o bin/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}/src/${PORTNAME}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
post-install:
${INSTALL_MAN} ${WRKSRC}/man/man1/fzf.1 ${STAGEDIR}${MANPREFIX}/man/man1
diff --git a/textproc/fzf/distinfo b/textproc/fzf/distinfo
index 87c6831fd57d..6852d1ba81e5 100644
--- a/textproc/fzf/distinfo
+++ b/textproc/fzf/distinfo
@@ -1,3 +1,9 @@
-TIMESTAMP = 1471256085
-SHA256 (junegunn-fzf-0.13.4_GH0.tar.gz) = ba561de9393c7f5604f3463c0d48960b86690afe8396f2c9672d3c4777960c7c
-SIZE (junegunn-fzf-0.13.4_GH0.tar.gz) = 107907
+TIMESTAMP = 1479595305
+SHA256 (junegunn-fzf-0.15.8_GH0.tar.gz) = f02ba45837e8583a3aa4e54a7d0b7d493f5314be6923ca80a639b43d6c0f4a4f
+SIZE (junegunn-fzf-0.15.8_GH0.tar.gz) = 120461
+SHA256 (junegunn-go-runewidth-63c378b_GH0.tar.gz) = e7cba5116e6f7051984005f5ab6c23d448307a6fced09eb9bd1bf49f3317b36d
+SIZE (junegunn-go-runewidth-63c378b_GH0.tar.gz) = 4503
+SHA256 (junegunn-go-shellwords-35d512a_GH0.tar.gz) = ea496265b81c60c0d590e369ca7cbcf3e87ec39d6f49c7462a7ab0483582b6fa
+SIZE (junegunn-go-shellwords-35d512a_GH0.tar.gz) = 2340
+SHA256 (junegunn-go-isatty-66b8e73_GH0.tar.gz) = 261ec4d11cc7615205c67a1dd9ffe1f88166fc50db0022700a82f39ab7e47b0d
+SIZE (junegunn-go-isatty-66b8e73_GH0.tar.gz) = 1956
diff --git a/textproc/fzf/files/patch-src_options.go b/textproc/fzf/files/patch-src_options.go
deleted file mode 100644
index 4c3480a65689..000000000000
--- a/textproc/fzf/files/patch-src_options.go
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/options.go.orig 2016-08-08 11:09:38 UTC
-+++ src/options.go
-@@ -10,7 +10,7 @@ import (
-
- "github.com/junegunn/fzf/src/curses"
-
-- "github.com/junegunn/go-shellwords"
-+ "github.com/mattn/go-shellwords"
- )
-
- const usage = `usage: fzf [options]
diff --git a/textproc/fzf/files/patch-src_terminal.go b/textproc/fzf/files/patch-src_terminal.go
deleted file mode 100644
index ac065109724e..000000000000
--- a/textproc/fzf/files/patch-src_terminal.go
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/terminal.go.orig 2016-07-15 16:06:53 UTC
-+++ src/terminal.go
-@@ -15,7 +15,7 @@ import (
- C "github.com/junegunn/fzf/src/curses"
- "github.com/junegunn/fzf/src/util"
-
-- "github.com/junegunn/go-runewidth"
-+ "github.com/mattn/go-runewidth"
- )
-
- type jumpMode int