aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormatusita <matusita@FreeBSD.org>2003-06-14 22:23:21 +0800
committermatusita <matusita@FreeBSD.org>2003-06-14 22:23:21 +0800
commit1b18d7340770c08267c15ee05fa2ea82e74eb1ff (patch)
treecabd09e7b25b0775f05b7a7baf43d655fc1c954d /textproc
parentfcd1b110da0bfb7ff0a52d412b4f06cecfbafdfa (diff)
downloadfreebsd-ports-gnome-1b18d7340770c08267c15ee05fa2ea82e74eb1ff.tar.gz
freebsd-ports-gnome-1b18d7340770c08267c15ee05fa2ea82e74eb1ff.tar.zst
freebsd-ports-gnome-1b18d7340770c08267c15ee05fa2ea82e74eb1ff.zip
New port: ruby-diff
This is a ruby library, implements Algorithm::Diff of Perl. This library is needed for aswiki, which will be commited later. Reviewed by: kuriyama, knu
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/ruby-diff/Makefile22
-rw-r--r--textproc/ruby-diff/distinfo1
-rw-r--r--textproc/ruby-diff/pkg-descr10
-rw-r--r--textproc/ruby-diff/pkg-plist2
5 files changed, 36 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 00b30af7f53e..8787580627c0 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -348,6 +348,7 @@
SUBDIR += ruby-amatch
SUBDIR += ruby-amrita
SUBDIR += ruby-csv
+ SUBDIR += ruby-diff
SUBDIR += ruby-format
SUBDIR += ruby-formvalidator
SUBDIR += ruby-gdome
diff --git a/textproc/ruby-diff/Makefile b/textproc/ruby-diff/Makefile
new file mode 100644
index 000000000000..8c0c22b82f3b
--- /dev/null
+++ b/textproc/ruby-diff/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: ruby-diff
+# Date created: 13 June 2003
+# Whom: Makoto Matsushita <matusita@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= diff
+PORTVERSION= 0.4
+CATEGORIES= textproc ruby
+MASTER_SITES= http://www.rubynet.org/mirrors/diff/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= matusita@FreeBSD.org
+COMMENT= Ruby implementation of Perl's Algorithm::Diff
+
+USE_RUBY= YES
+USE_RUBY_SETUP= YES
+RUBY_SETUP= install.rb
+
+.include <bsd.port.mk>
diff --git a/textproc/ruby-diff/distinfo b/textproc/ruby-diff/distinfo
new file mode 100644
index 000000000000..36bee2b43325
--- /dev/null
+++ b/textproc/ruby-diff/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/diff-0.4.tar.gz) = 3e832de40dc1866dddc64978fe67e4c8
diff --git a/textproc/ruby-diff/pkg-descr b/textproc/ruby-diff/pkg-descr
new file mode 100644
index 000000000000..9385ea90271b
--- /dev/null
+++ b/textproc/ruby-diff/pkg-descr
@@ -0,0 +1,10 @@
+The diff algorithm computes the differences between two arrays of elements,
+like the unix program "diff". diff.rb is a Ruby conversion of the Perl's
+Algorithm::Diff. It can diff Arrays by each element or Strings by each
+character, or your own class if you implement the interface. The algorithm
+is complete, stable (TestUnit test available), but the interface may change
+before a 1.0 release.
+
+ -- excerpt from RAA (Ruby Application Archive)
+
+WWW: http://www.rubynet.org/mirrors/diff/
diff --git a/textproc/ruby-diff/pkg-plist b/textproc/ruby-diff/pkg-plist
new file mode 100644
index 000000000000..eff858dc7926
--- /dev/null
+++ b/textproc/ruby-diff/pkg-plist
@@ -0,0 +1,2 @@
+%%RUBY_SITELIBDIR%%/algorithm/diff.rb
+@dirrm %%RUBY_SITELIBDIR%%/algorithm