aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2003-07-08 08:31:30 +0800
committeradamw <adamw@FreeBSD.org>2003-07-08 08:31:30 +0800
commit2985f71445feb466f8f79921d6688608495643cd (patch)
tree14cc480edc5e353cd6d462d2603b9802a287473f /textproc
parente63e0f79f10945fc7326e9b3843d6e7333d31500 (diff)
downloadfreebsd-ports-gnome-2985f71445feb466f8f79921d6688608495643cd.tar.gz
freebsd-ports-gnome-2985f71445feb466f8f79921d6688608495643cd.tar.zst
freebsd-ports-gnome-2985f71445feb466f8f79921d6688608495643cd.zip
Add p5-WordNet-QueryData
WordNet::QueryData provides a direct interface to the WordNet database files. It requires the WordNet package. It allows the user direct access to the full WordNet semantic lexicon. All parts of speech are supported and access is generally very efficient because the index and morphical exclusion tables are loaded at initialization. This initialization step is slow (appx. 10-15 seconds), but queries are very fast thereafter---thousands of queries can be completed every second.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-WordNet-QueryData/Makefile25
-rw-r--r--textproc/p5-WordNet-QueryData/distinfo1
-rw-r--r--textproc/p5-WordNet-QueryData/pkg-descr11
-rw-r--r--textproc/p5-WordNet-QueryData/pkg-plist4
5 files changed, 42 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index a0e455850718..9b0070e4a8af 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -252,6 +252,7 @@
SUBDIR += p5-Tree-Nary
SUBDIR += p5-URI-Find
SUBDIR += p5-WDDX
+ SUBDIR += p5-WordNet-QueryData
SUBDIR += p5-XML-Catalog
SUBDIR += p5-XML-DBMS
SUBDIR += p5-XML-DOM
diff --git a/textproc/p5-WordNet-QueryData/Makefile b/textproc/p5-WordNet-QueryData/Makefile
new file mode 100644
index 000000000000..d079a3b27631
--- /dev/null
+++ b/textproc/p5-WordNet-QueryData/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-WordNet-QueryData
+# Date created: 07 July 2003
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WordNet-QueryData
+PORTVERSION= 1.28
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WordNet
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Perl interface to the WordNet database files
+
+LIB_DEPENDS= wn1.7:${PORTSDIR}/textproc/wordnet
+
+PERL_CONFIGURE= yes
+CONFIGURE_ENV= WNHOME=${LOCALBASE}/share/WordNet-1.7.1
+
+MAN3= WordNet::QueryData.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-WordNet-QueryData/distinfo b/textproc/p5-WordNet-QueryData/distinfo
new file mode 100644
index 000000000000..b12631914d9b
--- /dev/null
+++ b/textproc/p5-WordNet-QueryData/distinfo
@@ -0,0 +1 @@
+MD5 (WordNet-QueryData-1.28.tar.gz) = 2e59b756371caa6a2dbb8b3f1770a19c
diff --git a/textproc/p5-WordNet-QueryData/pkg-descr b/textproc/p5-WordNet-QueryData/pkg-descr
new file mode 100644
index 000000000000..39f886398892
--- /dev/null
+++ b/textproc/p5-WordNet-QueryData/pkg-descr
@@ -0,0 +1,11 @@
+From the README:
+
+WordNet::QueryData provides a direct interface to the WordNet database files.
+It requires the WordNet package (http://www.cogsci.princeton.edu/~wn/). It
+allows the user direct access to the full WordNet semantic lexicon. All parts
+of speech are supported and access is generally very efficient because the
+index and morphical exclusion tables are loaded at initialization. This
+initialization step is slow (appx. 10-15 seconds), but queries are very fast
+thereafter---thousands of queries can be completed every second.
+
+WWW: http://www.ai.mit.edu/people/jrennie/WordNet/
diff --git a/textproc/p5-WordNet-QueryData/pkg-plist b/textproc/p5-WordNet-QueryData/pkg-plist
new file mode 100644
index 000000000000..b26cb5515696
--- /dev/null
+++ b/textproc/p5-WordNet-QueryData/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/WordNet/QueryData.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WordNet/QueryData/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/WordNet 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/WordNet 2>/dev/null || true