aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-08-21 22:08:06 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-08-21 22:08:06 +0800
commit31445311fce915521f6c1940134b8dc155688036 (patch)
treea29fe29c38d5df1895cfbe84019093fae61a6b42 /textproc
parent3672f197c67f0c967088c7faaced7d9627772e4d (diff)
downloadfreebsd-ports-gnome-31445311fce915521f6c1940134b8dc155688036.tar.gz
freebsd-ports-gnome-31445311fce915521f6c1940134b8dc155688036.tar.zst
freebsd-ports-gnome-31445311fce915521f6c1940134b8dc155688036.zip
- Convert to new perl framework
Diffstat (limited to 'textproc')
-rw-r--r--textproc/p5-CSS-Minifier-XS/Makefile3
-rw-r--r--textproc/p5-CSS-Minifier/Makefile3
-rw-r--r--textproc/p5-CSS-Packer/Makefile3
-rw-r--r--textproc/p5-Excel-Writer-XLSX/Makefile3
-rw-r--r--textproc/p5-HTML-Entities-Interpolate/Makefile3
-rw-r--r--textproc/p5-HTML-Packer/Makefile3
-rw-r--r--textproc/p5-JavaScript-Minifier-XS/Makefile3
-rw-r--r--textproc/p5-JavaScript-Packer/Makefile3
-rw-r--r--textproc/p5-Lingua-EN-FindNumber/Makefile3
-rw-r--r--textproc/p5-Lingua-EN-Words2Nums/Makefile3
-rw-r--r--textproc/p5-Lingua-Ident/Makefile3
-rw-r--r--textproc/p5-Lingua-Ispell/Makefile3
-rw-r--r--textproc/p5-Marpa-HTML/Makefile3
-rw-r--r--textproc/p5-SVG-Parser/Makefile3
-rw-r--r--textproc/p5-Sphinx-Config/Makefile3
-rw-r--r--textproc/p5-Sphinx-Manager/Makefile3
-rw-r--r--textproc/p5-String-ToIdentifier-EN/Makefile3
-rw-r--r--textproc/p5-Template-Plugin-Filter-Minify-CSS-XS/Makefile3
-rw-r--r--textproc/p5-Template-Plugin-Filter-Minify-CSS/Makefile3
-rw-r--r--textproc/p5-Template-Plugin-Filter-Minify-JavaScript-XS/Makefile3
-rw-r--r--textproc/p5-Template-Plugin-Filter-Minify-JavaScript/Makefile3
-rw-r--r--textproc/p5-Text-Padding/Makefile3
-rw-r--r--textproc/p5-Text-Prefix-XS/Makefile3
-rw-r--r--textproc/p5-Tk-Pod/Makefile3
-rw-r--r--textproc/p5-Unicode-Collate/Makefile3
-rw-r--r--textproc/p5-Validator-Custom/Makefile3
-rw-r--r--textproc/p5-XML-LibXML-Cache/Makefile3
-rw-r--r--textproc/p5-XML-LibXML-PrettyPrint/Makefile3
-rw-r--r--textproc/p5-XML-Parsepp/Makefile3
-rw-r--r--textproc/p5-XML-SAX-Base/Makefile3
-rw-r--r--textproc/p5-XML-Toolkit/Makefile3
-rw-r--r--textproc/p5-XML-XML2JSON/Makefile3
32 files changed, 64 insertions, 32 deletions
diff --git a/textproc/p5-CSS-Minifier-XS/Makefile b/textproc/p5-CSS-Minifier-XS/Makefile
index 34a18039ed89..1fb78cb29731 100644
--- a/textproc/p5-CSS-Minifier-XS/Makefile
+++ b/textproc/p5-CSS-Minifier-XS/Makefile
@@ -17,7 +17,8 @@ TEST_DEPENDS= p5-CSS-Minifier>=0:${PORTSDIR}/textproc/p5-CSS-Minifier \
p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod \
p5-Test-Pod-Coverage>=1:${PORTSDIR}/devel/p5-Test-Pod-Coverage
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= CSS::Minifier::XS.3
diff --git a/textproc/p5-CSS-Minifier/Makefile b/textproc/p5-CSS-Minifier/Makefile
index 313923394843..64eb6b93d778 100644
--- a/textproc/p5-CSS-Minifier/Makefile
+++ b/textproc/p5-CSS-Minifier/Makefile
@@ -13,7 +13,8 @@ COMMENT= Perl extension for minifying CSS
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= CSS::Minifier.3
diff --git a/textproc/p5-CSS-Packer/Makefile b/textproc/p5-CSS-Packer/Makefile
index 4cc88fb3e921..45ba10faaee4 100644
--- a/textproc/p5-CSS-Packer/Makefile
+++ b/textproc/p5-CSS-Packer/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= p5-Regexp-RegGrp>=1.001.001:${PORTSDIR}/devel/p5-Regexp-RegGrp
TEST_DEPENDS= p5-Test-Pod>=1.22:${PORTSDIR}/devel/p5-Test-Pod
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= CSS::Packer.3
diff --git a/textproc/p5-Excel-Writer-XLSX/Makefile b/textproc/p5-Excel-Writer-XLSX/Makefile
index c45cb853d746..546c5b85273c 100644
--- a/textproc/p5-Excel-Writer-XLSX/Makefile
+++ b/textproc/p5-Excel-Writer-XLSX/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Date-Calc>=0:${PORTSDIR}/devel/p5-Date-Calc \
p5-Date-Manip>=0:${PORTSDIR}/devel/p5-Date-Manip
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN1= extract_vba.1
MAN3= Excel::Writer::XLSX.3 \
diff --git a/textproc/p5-HTML-Entities-Interpolate/Makefile b/textproc/p5-HTML-Entities-Interpolate/Makefile
index 3bf27b766a2f..0c0e31231ae5 100644
--- a/textproc/p5-HTML-Entities-Interpolate/Makefile
+++ b/textproc/p5-HTML-Entities-Interpolate/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Pod>=1.45:${PORTSDIR}/devel/p5-Test-Pod
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= HTML::Entities::Interpolate.3
diff --git a/textproc/p5-HTML-Packer/Makefile b/textproc/p5-HTML-Packer/Makefile
index 891bd1e89ed5..3914d27239b1 100644
--- a/textproc/p5-HTML-Packer/Makefile
+++ b/textproc/p5-HTML-Packer/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= p5-Regexp-RegGrp>=1.001.001:${PORTSDIR}/devel/p5-Regexp-RegGrp
TEST_DEPENDS= p5-Test-Pod>=1.22:${PORTSDIR}/devel/p5-Test-Pod
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= HTML::Packer.3
diff --git a/textproc/p5-JavaScript-Minifier-XS/Makefile b/textproc/p5-JavaScript-Minifier-XS/Makefile
index ed01713b5ea4..e791906f123d 100644
--- a/textproc/p5-JavaScript-Minifier-XS/Makefile
+++ b/textproc/p5-JavaScript-Minifier-XS/Makefile
@@ -17,7 +17,8 @@ TEST_DEPENDS= p5-JavaScript-Minifier>=0:${PORTSDIR}/textproc/p5-JavaScript-Minif
p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod \
p5-Test-Pod-Coverage>=1:${PORTSDIR}/devel/p5-Test-Pod-Coverage
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= JavaScript::Minifier::XS.3
diff --git a/textproc/p5-JavaScript-Packer/Makefile b/textproc/p5-JavaScript-Packer/Makefile
index f473c6e2f11a..65dcbcbfe7d9 100644
--- a/textproc/p5-JavaScript-Packer/Makefile
+++ b/textproc/p5-JavaScript-Packer/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= p5-Regexp-RegGrp>=1.001.001:${PORTSDIR}/devel/p5-Regexp-RegGrp
TEST_DEPENDS= p5-Test-Pod>=1.22:${PORTSDIR}/devel/p5-Test-Pod
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= JavaScript::Packer.3
diff --git a/textproc/p5-Lingua-EN-FindNumber/Makefile b/textproc/p5-Lingua-EN-FindNumber/Makefile
index b41470e2b52d..9cd15a16204a 100644
--- a/textproc/p5-Lingua-EN-FindNumber/Makefile
+++ b/textproc/p5-Lingua-EN-FindNumber/Makefile
@@ -18,7 +18,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod \
p5-Test-Pod-Coverage>=1:${PORTSDIR}/devel/p5-Test-Pod-Coverage
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Lingua::EN::FindNumber.3
diff --git a/textproc/p5-Lingua-EN-Words2Nums/Makefile b/textproc/p5-Lingua-EN-Words2Nums/Makefile
index 16c2e683433e..9a457a97c137 100644
--- a/textproc/p5-Lingua-EN-Words2Nums/Makefile
+++ b/textproc/p5-Lingua-EN-Words2Nums/Makefile
@@ -13,7 +13,8 @@ COMMENT= Convert English text to numbers
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Lingua::EN::Words2Nums.3
diff --git a/textproc/p5-Lingua-Ident/Makefile b/textproc/p5-Lingua-Ident/Makefile
index 21fef7c6e887..a07ed55fe7b4 100644
--- a/textproc/p5-Lingua-Ident/Makefile
+++ b/textproc/p5-Lingua-Ident/Makefile
@@ -15,7 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Statistical language identification
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN1= trainlid.1
MAN3= Lingua::Ident.3
diff --git a/textproc/p5-Lingua-Ispell/Makefile b/textproc/p5-Lingua-Ispell/Makefile
index 04752d2d652a..fae37b691b35 100644
--- a/textproc/p5-Lingua-Ispell/Makefile
+++ b/textproc/p5-Lingua-Ispell/Makefile
@@ -17,7 +17,8 @@ COMMENT= A Perl module that encapsulates access to the Ispell program
BUILD_DEPENDS= ${LOCALBASE}/bin/ispell:${PORTSDIR}/textproc/ispell
RUN_DEPENDS= ${LOCALBASE}/bin/ispell:${PORTSDIR}/textproc/ispell
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
REINPLACE_ARGS= -i ''
MAN3= Lingua::Ispell.3
diff --git a/textproc/p5-Marpa-HTML/Makefile b/textproc/p5-Marpa-HTML/Makefile
index a30a86299476..8b53b35d5b61 100644
--- a/textproc/p5-Marpa-HTML/Makefile
+++ b/textproc/p5-Marpa-HTML/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= p5-HTML-Parser>=3.64:${PORTSDIR}/www/p5-HTML-Parser \
p5-Marpa-XS>=0.026:${PORTSDIR}/lang/p5-Marpa-XS
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN1= html_fmt.1 \
html_score.1
diff --git a/textproc/p5-SVG-Parser/Makefile b/textproc/p5-SVG-Parser/Makefile
index 788cabaca986..f0e13f453075 100644
--- a/textproc/p5-SVG-Parser/Makefile
+++ b/textproc/p5-SVG-Parser/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS= p5-SVG>=2:${PORTSDIR}/textproc/p5-SVG \
p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
p5-XML-SAX>=0:${PORTSDIR}/textproc/p5-XML-SAX
-PERL_MODBUILD= yes
+USE_PERL5= modbuild
+USES= perl5
MAN3= SVG::Parser.3 \
SVG::Parser::Expat.3 \
diff --git a/textproc/p5-Sphinx-Config/Makefile b/textproc/p5-Sphinx-Config/Makefile
index 9bf3bb671bda..08559b01c73d 100644
--- a/textproc/p5-Sphinx-Config/Makefile
+++ b/textproc/p5-Sphinx-Config/Makefile
@@ -17,7 +17,8 @@ COMMENT= Sphinx search engine configuration file read/modify/write
BUILD_DEPENDS= p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils
RUN_DEPENDS= p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Sphinx::Config.3
diff --git a/textproc/p5-Sphinx-Manager/Makefile b/textproc/p5-Sphinx-Manager/Makefile
index d29f87ec63f2..d7ea2644456c 100644
--- a/textproc/p5-Sphinx-Manager/Makefile
+++ b/textproc/p5-Sphinx-Manager/Makefile
@@ -23,7 +23,8 @@ RUN_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-Proc-ProcessTable>=0:${PORTSDIR}/devel/p5-Proc-ProcessTable \
p5-Sphinx-Config>=0.09:${PORTSDIR}/textproc/p5-Sphinx-Config
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Sphinx::Manager.3
diff --git a/textproc/p5-String-ToIdentifier-EN/Makefile b/textproc/p5-String-ToIdentifier-EN/Makefile
index cf4b65fb03c1..ea208480b1a1 100644
--- a/textproc/p5-String-ToIdentifier-EN/Makefile
+++ b/textproc/p5-String-ToIdentifier-EN/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Pod>=1.14:${PORTSDIR}/devel/p5-Test-Pod \
p5-Test-Pod-Coverage>=1.04:${PORTSDIR}/devel/p5-Test-Pod-Coverage
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= String::ToIdentifier::EN.3 \
String::ToIdentifier::EN::Unicode.3
diff --git a/textproc/p5-Template-Plugin-Filter-Minify-CSS-XS/Makefile b/textproc/p5-Template-Plugin-Filter-Minify-CSS-XS/Makefile
index bc87d2e33ead..c1594b90c7d0 100644
--- a/textproc/p5-Template-Plugin-Filter-Minify-CSS-XS/Makefile
+++ b/textproc/p5-Template-Plugin-Filter-Minify-CSS-XS/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-CSS-Minifier-XS>=0:${PORTSDIR}/textproc/p5-CSS-Minifier-XS \
RUN_DEPENDS= p5-CSS-Minifier-XS>=0:${PORTSDIR}/textproc/p5-CSS-Minifier-XS \
p5-Template-Toolkit>=2:${PORTSDIR}/www/p5-Template-Toolkit
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Template::Plugin::Filter::Minify::CSS::XS.3
diff --git a/textproc/p5-Template-Plugin-Filter-Minify-CSS/Makefile b/textproc/p5-Template-Plugin-Filter-Minify-CSS/Makefile
index 624833108703..35e38fc0091b 100644
--- a/textproc/p5-Template-Plugin-Filter-Minify-CSS/Makefile
+++ b/textproc/p5-Template-Plugin-Filter-Minify-CSS/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-CSS-Minifier>=0:${PORTSDIR}/textproc/p5-CSS-Minifier \
RUN_DEPENDS= p5-CSS-Minifier>=0:${PORTSDIR}/textproc/p5-CSS-Minifier \
p5-Template-Toolkit>=2:${PORTSDIR}/www/p5-Template-Toolkit
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Template::Plugin::Filter::Minify::CSS.3
diff --git a/textproc/p5-Template-Plugin-Filter-Minify-JavaScript-XS/Makefile b/textproc/p5-Template-Plugin-Filter-Minify-JavaScript-XS/Makefile
index d6bc2e675ad0..e925c6952a38 100644
--- a/textproc/p5-Template-Plugin-Filter-Minify-JavaScript-XS/Makefile
+++ b/textproc/p5-Template-Plugin-Filter-Minify-JavaScript-XS/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-JavaScript-Minifier-XS>=0:${PORTSDIR}/textproc/p5-JavaScript-M
RUN_DEPENDS= p5-JavaScript-Minifier-XS>=0:${PORTSDIR}/textproc/p5-JavaScript-Minifier-XS \
p5-Template-Toolkit>=2:${PORTSDIR}/www/p5-Template-Toolkit
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Template::Plugin::Filter::Minify::JavaScript::XS.3
diff --git a/textproc/p5-Template-Plugin-Filter-Minify-JavaScript/Makefile b/textproc/p5-Template-Plugin-Filter-Minify-JavaScript/Makefile
index 8f854b90d2c7..e0b121cd124d 100644
--- a/textproc/p5-Template-Plugin-Filter-Minify-JavaScript/Makefile
+++ b/textproc/p5-Template-Plugin-Filter-Minify-JavaScript/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-JavaScript-Minifier>=0:${PORTSDIR}/textproc/p5-JavaScript-Mini
RUN_DEPENDS= p5-JavaScript-Minifier>=0:${PORTSDIR}/textproc/p5-JavaScript-Minifier \
p5-Template-Toolkit>=2:${PORTSDIR}/www/p5-Template-Toolkit
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Template::Plugin::Filter::Minify::JavaScript.3
diff --git a/textproc/p5-Text-Padding/Makefile b/textproc/p5-Text-Padding/Makefile
index a3793644edbd..bf21f44774f5 100644
--- a/textproc/p5-Text-Padding/Makefile
+++ b/textproc/p5-Text-Padding/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
p5-Text-Truncate>=0:${PORTSDIR}/textproc/p5-Text-Truncate
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USE_PERL5= modbuild
+USES= perl5
MAN3= Text::Padding.3
diff --git a/textproc/p5-Text-Prefix-XS/Makefile b/textproc/p5-Text-Prefix-XS/Makefile
index 96e403d5e4da..8bc96f5d6abc 100644
--- a/textproc/p5-Text-Prefix-XS/Makefile
+++ b/textproc/p5-Text-Prefix-XS/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= p5-Digest-SHA1>=1:${PORTSDIR}/security/p5-Digest-SHA1
TEST_DEPENDS= p5-Test-Deep>=0.108:${PORTSDIR}/devel/p5-Test-Deep
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Text::Prefix::XS.3
diff --git a/textproc/p5-Tk-Pod/Makefile b/textproc/p5-Tk-Pod/Makefile
index 48792eaf0a09..20189c80979e 100644
--- a/textproc/p5-Tk-Pod/Makefile
+++ b/textproc/p5-Tk-Pod/Makefile
@@ -16,7 +16,8 @@ LICENSE_COMB= dual
BUILD_DEPENDS= p5-Tk>=800.004:${PORTSDIR}/x11-toolkits/p5-Tk
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN1= tkmore.1 \
tkpod.1
diff --git a/textproc/p5-Unicode-Collate/Makefile b/textproc/p5-Unicode-Collate/Makefile
index 753b79a09a9e..e4ce1f53b294 100644
--- a/textproc/p5-Unicode-Collate/Makefile
+++ b/textproc/p5-Unicode-Collate/Makefile
@@ -14,7 +14,8 @@ COMMENT= Unicode Collation Algorithm
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Unicode::Collate.3 \
Unicode::Collate::CJK::Big5.3 \
diff --git a/textproc/p5-Validator-Custom/Makefile b/textproc/p5-Validator-Custom/Makefile
index e33809b87cc9..d2dbed216c61 100644
--- a/textproc/p5-Validator-Custom/Makefile
+++ b/textproc/p5-Validator-Custom/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
p5-Test-Pod>=1.22:${PORTSDIR}/devel/p5-Test-Pod
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Validator::Custom.3 \
Validator::Custom::Guide.3 \
diff --git a/textproc/p5-XML-LibXML-Cache/Makefile b/textproc/p5-XML-LibXML-Cache/Makefile
index ac12090fb3b8..00054c4928ee 100644
--- a/textproc/p5-XML-LibXML-Cache/Makefile
+++ b/textproc/p5-XML-LibXML-Cache/Makefile
@@ -24,7 +24,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-File-Touch>=0:${PORTSDIR}/devel/p5-File-Touch \
p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= XML::LibXML::Cache.3 \
XML::LibXML::Cache::Base.3 \
diff --git a/textproc/p5-XML-LibXML-PrettyPrint/Makefile b/textproc/p5-XML-LibXML-PrettyPrint/Makefile
index c11632225fe0..d8f4a9291779 100644
--- a/textproc/p5-XML-LibXML-PrettyPrint/Makefile
+++ b/textproc/p5-XML-LibXML-PrettyPrint/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-Pragmatic>=0:${PORTSDIR}/devel/p5-Pragmatic \
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Warn>=0.20:${PORTSDIR}/devel/p5-Test-Warn
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= XML::LibXML::PrettyPrint.3
diff --git a/textproc/p5-XML-Parsepp/Makefile b/textproc/p5-XML-Parsepp/Makefile
index 97ed410c8299..e6585eb080bf 100644
--- a/textproc/p5-XML-Parsepp/Makefile
+++ b/textproc/p5-XML-Parsepp/Makefile
@@ -17,7 +17,8 @@ COMMENT= Simplified pure Perl parser for XML
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= 5.14.0+
+USE_PERL5= 5.14.0+ configure
+USES= perl5
MAN3= XML::Parsepp.3
diff --git a/textproc/p5-XML-SAX-Base/Makefile b/textproc/p5-XML-SAX-Base/Makefile
index 893e8c20c555..d7a9729776bb 100644
--- a/textproc/p5-XML-SAX-Base/Makefile
+++ b/textproc/p5-XML-SAX-Base/Makefile
@@ -15,7 +15,8 @@ LICENSE_COMB= dual
CONFLICTS= p5-XML-SAX-0.[0-8]* p5-XML-SAX-0.9[0-8]*
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= XML::SAX::Base.3 \
XML::SAX::BuildSAXBase.3 \
diff --git a/textproc/p5-XML-Toolkit/Makefile b/textproc/p5-XML-Toolkit/Makefile
index 4a17e2fe92cf..b9ef2433621a 100644
--- a/textproc/p5-XML-Toolkit/Makefile
+++ b/textproc/p5-XML-Toolkit/Makefile
@@ -36,7 +36,8 @@ TEST_DEPENDS= p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep \
p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
p5-Test-XML>=0:${PORTSDIR}/devel/p5-Test-XML
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= XML::Filter::Moose.3 \
XML::Generator::Moose.3 \
diff --git a/textproc/p5-XML-XML2JSON/Makefile b/textproc/p5-XML-XML2JSON/Makefile
index 3940b8767940..f8e0825bd7ae 100644
--- a/textproc/p5-XML-XML2JSON/Makefile
+++ b/textproc/p5-XML-XML2JSON/Makefile
@@ -24,7 +24,8 @@ JSON_XS_DESC= Use JSON::XS
JSON_DESC= Use JSON
JSON_DWIW_DESC= Use JSON::DWIW
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= XML::XML2JSON.3