aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormfechner <mfechner@FreeBSD.org>2018-06-21 23:28:59 +0800
committermfechner <mfechner@FreeBSD.org>2018-06-21 23:28:59 +0800
commit31f2dd526ba9ee43cea6709aaa2d612c5bf1bf88 (patch)
tree29c5dc8fb297b1ac1d745b704772c44aed3b8039 /textproc
parentf564709cd0df3b5f5c1f6c2f2e19180fc6eccec3 (diff)
downloadfreebsd-ports-gnome-31f2dd526ba9ee43cea6709aaa2d612c5bf1bf88.tar.gz
freebsd-ports-gnome-31f2dd526ba9ee43cea6709aaa2d612c5bf1bf88.tar.zst
freebsd-ports-gnome-31f2dd526ba9ee43cea6709aaa2d612c5bf1bf88.zip
New ports required for gitlab 10.8.x.
Reviewed by: mat, swills (mentor) Approved by: swills (mentor) Differential Revision: https://reviews.freebsd.org/D15945
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/rubygem-github-markup16/Makefile34
-rw-r--r--textproc/rubygem-github-markup16/distinfo3
-rw-r--r--textproc/rubygem-github-markup16/pkg-descr4
4 files changed, 42 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 7e99f8bda9bd..f988967dd3eb 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1522,6 +1522,7 @@
SUBDIR += rubygem-github-linguist
SUBDIR += rubygem-github-linguist53
SUBDIR += rubygem-github-markup
+ SUBDIR += rubygem-github-markup16
SUBDIR += rubygem-gitlab-grit
SUBDIR += rubygem-gitlab-linguist
SUBDIR += rubygem-gitlab-markup
diff --git a/textproc/rubygem-github-markup16/Makefile b/textproc/rubygem-github-markup16/Makefile
new file mode 100644
index 000000000000..bb96acfc21ac
--- /dev/null
+++ b/textproc/rubygem-github-markup16/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= github-markup
+PORTVERSION= 1.6.2
+CATEGORIES= textproc rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 16
+
+MAINTAINER= mfechner@FreeBSD.org
+COMMENT= Render any fancy markup
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+CONFLICTS_INSTALL= textproc/rubygem-github-markup
+
+USES= gem shebangfix
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+REINPLACE_ARGS= -i ''
+
+PLIST_FILES= bin/github-markup
+
+SHEBANG_FILES= script/bootstrap \
+ script/cibuild
+
+PORTSCOUT= limit:^1\.6\.
+
+post-patch:
+ @${REINPLACE_CMD} -e '1d' ${WRKSRC}/lib/github/commands/rest2html
+
+.include <bsd.port.mk>
diff --git a/textproc/rubygem-github-markup16/distinfo b/textproc/rubygem-github-markup16/distinfo
new file mode 100644
index 000000000000..a0b55eb8b96e
--- /dev/null
+++ b/textproc/rubygem-github-markup16/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1512841300
+SHA256 (rubygem/github-markup-1.6.2.gem) = 86515b18da25a91e1b88e58d79f3bf2a89a2a329f6c0439657ed6235836bec27
+SIZE (rubygem/github-markup-1.6.2.gem) = 30720
diff --git a/textproc/rubygem-github-markup16/pkg-descr b/textproc/rubygem-github-markup16/pkg-descr
new file mode 100644
index 000000000000..759f801ba57a
--- /dev/null
+++ b/textproc/rubygem-github-markup16/pkg-descr
@@ -0,0 +1,4 @@
+This gem is used by GitHub to render any fancy markup such as Markdown,
+Textile, Org-Mode, etc. Fork it and add your own!
+
+WWW: https://github.com/github/markup