aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-06-11 09:44:15 +0800
committerlinimon <linimon@FreeBSD.org>2018-06-11 09:44:15 +0800
commit39e31de51fbf694ff20f162572dc22c61f7d1b9d (patch)
treed21fd4ee60da4c705d6bb2d4d0222a7e7af7ef7b /textproc
parent1ddd46af14a4033deba9f651fa531f8aa83ea3f7 (diff)
downloadfreebsd-ports-gnome-39e31de51fbf694ff20f162572dc22c61f7d1b9d.tar.gz
freebsd-ports-gnome-39e31de51fbf694ff20f162572dc22c61f7d1b9d.tar.zst
freebsd-ports-gnome-39e31de51fbf694ff20f162572dc22c61f7d1b9d.zip
Fix port builds for architectures which remain on gcc as the default compiler.
This will primarily help powerpc64. For archs where clang is the default compiler, these changes will have no effect, as the base compiler already has these capabilities (primarily, but not exclusively, c++-11). Tested for no-harm on amd64. While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/kiss-templates/Makefile5
-rw-r--r--textproc/libwpd010/Makefile2
-rw-r--r--textproc/mythes/Makefile2
-rw-r--r--textproc/rubygem-liquid-tag-parser/Makefile2
4 files changed, 4 insertions, 7 deletions
diff --git a/textproc/kiss-templates/Makefile b/textproc/kiss-templates/Makefile
index 5a12bd9c2049..60c7c966579a 100644
--- a/textproc/kiss-templates/Makefile
+++ b/textproc/kiss-templates/Makefile
@@ -12,8 +12,7 @@ COMMENT= Type safe "Keep it simple, stupid" text templates for C++
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_powerpc64= fails to compile: No known features for CXX compiler GNU
-
+USES= cmake compiler:c++11-lang
USE_GITHUB= yes
GH_ACCOUNT= rbock
@@ -26,8 +25,6 @@ PLIST_FILES= bin/kiste2cpp \
include/kiste/serializer_builder.h \
include/kiste/terminal.h
-USES= cmake
-
OPTIONS_DEFINE= TEST
TEST_DESC= Build with unit tests
TEST_BUILD_DEPENDS= boost-libs>=1.55:devel/boost-libs
diff --git a/textproc/libwpd010/Makefile b/textproc/libwpd010/Makefile
index 9c8aa662822f..66d113ac42e9 100644
--- a/textproc/libwpd010/Makefile
+++ b/textproc/libwpd010/Makefile
@@ -19,7 +19,7 @@ LICENSE_FILE_MPL20= ${WRKSRC}/COPYING.MPL
BUILD_DEPENDS= ${LOCALBASE}/include/boost/spirit/include/qi.hpp:devel/boost-libs
LIB_DEPENDS= librevenge-0.0.so:textproc/librevenge
-USES= libtool pathfix pkgconfig tar:bzip2
+USES= compiler:c++11-lang libtool pathfix pkgconfig tar:bzip2
GNU_CONFIGURE= yes
USE_GNOME= libgsf
USE_LDCONFIG= yes
diff --git a/textproc/mythes/Makefile b/textproc/mythes/Makefile
index 23dbc153b0fa..77c7089966ec 100644
--- a/textproc/mythes/Makefile
+++ b/textproc/mythes/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell
-USES= libtool pathfix perl5 pkgconfig shebangfix
+USES= compiler:c++11-lib libtool pathfix perl5 pkgconfig shebangfix
USE_LDCONFIG= yes
USE_PERL5= run
SHEBANG_FILES= th_gen_idx.pl
diff --git a/textproc/rubygem-liquid-tag-parser/Makefile b/textproc/rubygem-liquid-tag-parser/Makefile
index 4d6e2d31ca87..e5677fab77d9 100644
--- a/textproc/rubygem-liquid-tag-parser/Makefile
+++ b/textproc/rubygem-liquid-tag-parser/Makefile
@@ -15,8 +15,8 @@ RUN_DEPENDS= rubygem-extras>=0.3:devel/rubygem-extras \
rubygem-liquid>=3.0:textproc/rubygem-liquid
NO_ARCH= yes
+USES= compiler:c++11-lang gem
USE_RUBY= yes
-USES= gem
# Disable rdoc
OPTIONS_EXCLUDE=DOCS