aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2013-09-08 03:49:41 +0800
committerbsam <bsam@FreeBSD.org>2013-09-08 03:49:41 +0800
commit3e50a1f1008125d1fcb80824f0b07c82b4441181 (patch)
tree44170eaab332d8a08ad941e3638a2e1e422229c8 /textproc
parente40957d48800f7febe079c19e8783f52b1a7e5c5 (diff)
downloadfreebsd-ports-gnome-3e50a1f1008125d1fcb80824f0b07c82b4441181.tar.gz
freebsd-ports-gnome-3e50a1f1008125d1fcb80824f0b07c82b4441181.tar.zst
freebsd-ports-gnome-3e50a1f1008125d1fcb80824f0b07c82b4441181.zip
Introduce variable ICONV_PREFIX at Mk/Uses/iconv.mk. The default for
pre 100043 is ${LOCALBASE} and /usr otherwise. Convert all ports to new variable usage. Approved by: portmgr (bapt, implicit)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/libxml2/Makefile2
-rw-r--r--textproc/py-libxml2/Makefile3
2 files changed, 3 insertions, 2 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index 7ee713651d37..b2b36c8ada89 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -20,7 +20,7 @@ USE_CSTD= gnu89
GNU_CONFIGURE= yes
USES= pathfix gmake iconv pkgconfig
USE_LDCONFIG= yes
-CONFIGURE_ARGS?=--with-iconv=${LOCALBASE} \
+CONFIGURE_ARGS?=--with-iconv=${ICONV_PREFIX} \
--with-html-dir=${PREFIX}/share/doc \
--with-html-subdir=${PORTNAME} \
--with-lzma=/usr \
diff --git a/textproc/py-libxml2/Makefile b/textproc/py-libxml2/Makefile
index 42fbf66ed23a..90d7977a7149 100644
--- a/textproc/py-libxml2/Makefile
+++ b/textproc/py-libxml2/Makefile
@@ -16,9 +16,10 @@ PLIST= ${.CURDIR}/pkg-plist
USE_GNOME+= libxml2
USE_PYTHON= -2.7
+USES= iconv
CPPFLAGS+= `${PYTHON_VERSION}-config --cflags`
LDFLAGS+= -L${LOCALBASE}/lib `${PYTHON_VERSION}-config --libs`
-CONFIGURE_ARGS= --with-iconv=${LOCALBASE} \
+CONFIGURE_ARGS= --with-iconv=${ICONV_PREFIX} \
--with-html-dir=${PREFIX}/share/doc \
--with-html-subdir=${PORTNAME} \
--with-python=${PYTHON_CMD}