aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-04-23 21:25:16 +0800
committertijl <tijl@FreeBSD.org>2014-04-23 21:25:16 +0800
commit55e5c34e31b90aa95311b10bd4a3072f2163ebfe (patch)
tree69c07cdc4812f0f8be0cc44c38513f540c058778 /textproc
parent0c15193d405451f0e1452ba981c8efb1df1447dd (diff)
downloadfreebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.tar.gz
freebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.tar.zst
freebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.zip
When linking a library libA with a library libB using libtool, if libB.la
exists, libtool will add all libraries libB.la refers to (dependency_libs field) to the linker command line and store them in the dependency_libs field of libA.la. So everything that subsequently links with libA will also link to these extra libraries. This causes too much overlinking. This commit modifies Mk/Uses/libtool.mk so it empties the dependency_libs field in .la libraries during staging. However, because .la libraries have very limited use when dependency_libs is empty it makes sense to completely remove them during staging. So with this commit USES=libtool is modified to remove .la libraries and a new form (USES=libtool:keepla) is introduced in case they need to be kept (dependency_libs is still emptied). PORTREVISION is bumped on all ports with USES=libtool that install .la libraries. Most ports are also changed to add :keepla because .la libraries have to be kept around as long as there are dependent ports with .la libraries that refer to them in their dependency_libs field. In most cases :keepla can be removed again as soon as all dependent ports that install .la libraries have some form of USES=libtool added to their Makefile. PR: ports/188759 Exp-run: bdrewery Approved by: portmgr (bdrewery)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/gtkspell3/Makefile3
-rw-r--r--textproc/libmwaw/Makefile4
-rw-r--r--textproc/libodfgen/Makefile4
-rw-r--r--textproc/libwps/Makefile4
-rw-r--r--textproc/libxml2/Makefile4
-rw-r--r--textproc/raptor2/Makefile4
-rw-r--r--textproc/sablotron/Makefile4
-rw-r--r--textproc/scim-table-imengine/Makefile4
8 files changed, 16 insertions, 15 deletions
diff --git a/textproc/gtkspell3/Makefile b/textproc/gtkspell3/Makefile
index 4a78242bd69c..a6f201fbfe6c 100644
--- a/textproc/gtkspell3/Makefile
+++ b/textproc/gtkspell3/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gtkspell3
PORTVERSION= 3.0.4
+PORTREVISION= 1
CATEGORIES= textproc gnome
MASTER_SITES= SF/gtkspell/${PORTVERSION}
@@ -13,7 +14,7 @@ BUILD_DEPENDS= vapigen:${PORTSDIR}/lang/vala-vapigen
LIB_DEPENDS= libenchant.so:${PORTSDIR}/textproc/enchant
USE_GNOME= gnomehier gnomeprefix gtk30 intlhack introspection:build
-USES= gettext gmake libtool pathfix pkgconfig
+USES= gettext gmake libtool:keepla pathfix pkgconfig
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/textproc/libmwaw/Makefile b/textproc/libmwaw/Makefile
index d1570b610dc7..6cb933a03998 100644
--- a/textproc/libmwaw/Makefile
+++ b/textproc/libmwaw/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libmwaw
PORTVERSION= 0.1.11
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -20,8 +20,8 @@ CONFIGURE_ARGS= --disable-werror
CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
+USES= compiler:features libtool:keepla pathfix pkgconfig tar:xz
USE_LDCONFIG= yes
-USES= libtool pkgconfig pathfix tar:xz compiler:features
PORTDOCS= *
DOCS_BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen
diff --git a/textproc/libodfgen/Makefile b/textproc/libodfgen/Makefile
index e2a5d7f990dc..94bce07a4979 100644
--- a/textproc/libodfgen/Makefile
+++ b/textproc/libodfgen/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libodfgen
PORTVERSION= 0.0.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= SF/libwpd/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -23,9 +23,9 @@ CONFIGURE_ARGS= --disable-werror
CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
+USES= libtool:keepla pathfix pkgconfig
USE_LDCONFIG= yes
USE_XZ= yes
-USES= libtool pkgconfig pathfix
PORTDOCS= *
DOCS_BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen
diff --git a/textproc/libwps/Makefile b/textproc/libwps/Makefile
index c759754d1056..d31a882b6385 100644
--- a/textproc/libwps/Makefile
+++ b/textproc/libwps/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libwps
PORTVERSION= 0.2.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -20,7 +20,7 @@ OPTIONS_DEFINE= DOCS
CONFIGURE_ARGS= --disable-werror
CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
-USES= libtool pkgconfig pathfix compiler:features
+USES= compiler:features libtool:keepla pathfix pkgconfig
USE_LDCONFIG= yes
PORTDOCS= *
DOCS_BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index 2159c33e732f..07f771486d43 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -4,7 +4,7 @@
PORTNAME= libxml2
PORTVERSION= 2.8.0
-PORTREVISION?= 4
+PORTREVISION?= 5
CATEGORIES?= textproc gnome
MASTER_SITES= ftp://xmlsoft.org/libxml2/ \
http://xmlsoft.org/sources/ \
@@ -17,7 +17,7 @@ COMMENT?= XML parser library for GNOME
.if !defined(REFERENCE_PORT)
USE_CSTD= gnu89
GNU_CONFIGURE= yes
-USES= gmake iconv libtool pathfix pkgconfig
+USES= gmake iconv libtool:keepla pathfix pkgconfig
USE_LDCONFIG= yes
CONFIGURE_ARGS?=--with-iconv=${ICONV_PREFIX} \
--with-html-dir=${PREFIX}/share/doc \
diff --git a/textproc/raptor2/Makefile b/textproc/raptor2/Makefile
index 44ce97a012cb..83162d1f2b6e 100644
--- a/textproc/raptor2/Makefile
+++ b/textproc/raptor2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= raptor2
PORTVERSION= 2.0.13
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= textproc
MASTER_SITES= http://download.librdf.org/source/ \
SF/librdf/${PORTNAME}/${PORTVERSION}
@@ -23,7 +23,7 @@ LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
CONFLICTS= raptor-1.4.1[0-9]* raptor-1.4.21
USE_GNOME= libxml2 libxslt
-USES= pathfix pkgconfig libtool
+USES= libtool:keepla pathfix pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-xml2-config=${LOCALBASE}/bin/xml2-config \
--with-curl-config=${LOCALBASE}/bin/curl-config \
diff --git a/textproc/sablotron/Makefile b/textproc/sablotron/Makefile
index 7db777151951..ad0982e7d8dd 100644
--- a/textproc/sablotron/Makefile
+++ b/textproc/sablotron/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Sablot
PORTVERSION= 1.0.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= SF/sablotron/sablotron-${PORTVERSION}
@@ -33,7 +33,7 @@ DOM_CONFIGURE_ENABLE= dom
DOCUMENT_ERRORS_CONFIGURE_ENABLE= document-errors
GNU_CONFIGURE= yes
-USES= gmake iconv libtool
+USES= gmake iconv libtool:keepla
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lexpat ${ICONV_LIB}
diff --git a/textproc/scim-table-imengine/Makefile b/textproc/scim-table-imengine/Makefile
index 41bc1021f8e2..c27dceab57c2 100644
--- a/textproc/scim-table-imengine/Makefile
+++ b/textproc/scim-table-imengine/Makefile
@@ -3,7 +3,7 @@
PORTNAME= scim-table-imengine
PORTVERSION= 0.5.10
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc
MASTER_SITES= SF/scim/scim-tables/${PORTVERSION}
DISTNAME= scim-tables-${PORTVERSION}
@@ -15,7 +15,7 @@ BUILD_DEPENDS= scim:${PORTSDIR}/textproc/scim
RUN_DEPENDS= scim:${PORTSDIR}/textproc/scim
GNU_CONFIGURE= yes
-USES= gettext gmake libtool pkgconfig
+USES= gettext gmake libtool:keepla pkgconfig
CONFIGURE_ARGS= --disable-skim-support
CPPFLAGS+= -I${LOCALBASE}/include -D__STDC_ISO_10646__