aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2011-08-14 03:37:58 +0800
committerpgj <pgj@FreeBSD.org>2011-08-14 03:37:58 +0800
commit7e8fe78c259fa34ee1f54780e4ac952fad86a43e (patch)
tree4fb641d871a90cd4bc923f666d282c0aa3e1bd0c /textproc
parentf1d3974008af74c0801c1a61bf313165daa988a0 (diff)
downloadfreebsd-ports-gnome-7e8fe78c259fa34ee1f54780e4ac952fad86a43e.tar.gz
freebsd-ports-gnome-7e8fe78c259fa34ee1f54780e4ac952fad86a43e.tar.zst
freebsd-ports-gnome-7e8fe78c259fa34ee1f54780e4ac952fad86a43e.zip
A fast parser combinator library, aimed particularly at dealing efficiently
with network protocols and complicated text/binary file formats. This library is basically a translation of the original attoparsec library to use text instead of bytestrings. WWW: http://patch-tag.com/r/felipe/attoparsec-text/home Obtained from: FreeBSD Haskell
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/hs-attoparsec-text/Makefile20
-rw-r--r--textproc/hs-attoparsec-text/distinfo2
-rw-r--r--textproc/hs-attoparsec-text/pkg-descr7
4 files changed, 30 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 35dce1bf84ff..94fb3bfbf8fd 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -234,6 +234,7 @@
SUBDIR += hs-HaXml
SUBDIR += hs-attoparsec
SUBDIR += hs-attoparsec-enumerator
+ SUBDIR += hs-attoparsec-text
SUBDIR += hs-bytestring-csv
SUBDIR += hs-case-insensitive
SUBDIR += hs-citeproc-hs
diff --git a/textproc/hs-attoparsec-text/Makefile b/textproc/hs-attoparsec-text/Makefile
new file mode 100644
index 000000000000..b61c881de59c
--- /dev/null
+++ b/textproc/hs-attoparsec-text/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: hs-attoparsec-text
+# Date created: March 13, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= attoparsec-text
+PORTVERSION= 0.8.5.1
+CATEGORIES= textproc haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Fast combinator parsing for texts
+
+LICENSE= BSD
+
+USE_CABAL= attoparsec>=0.7 text>=0.10
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/textproc/hs-attoparsec-text/distinfo b/textproc/hs-attoparsec-text/distinfo
new file mode 100644
index 000000000000..bc2bfe3cb8a8
--- /dev/null
+++ b/textproc/hs-attoparsec-text/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/attoparsec-text-0.8.5.1.tar.gz) = 1fc43122266653776bb157b9c6ffd7419651672f4b78e5cda61b0a2771fcc0c6
+SIZE (cabal/attoparsec-text-0.8.5.1.tar.gz) = 16729
diff --git a/textproc/hs-attoparsec-text/pkg-descr b/textproc/hs-attoparsec-text/pkg-descr
new file mode 100644
index 000000000000..96dcf9511b5a
--- /dev/null
+++ b/textproc/hs-attoparsec-text/pkg-descr
@@ -0,0 +1,7 @@
+A fast parser combinator library, aimed particularly at dealing efficiently
+with network protocols and complicated text/binary file formats.
+
+This library is basically a translation of the original attoparsec library
+to use text instead of bytestrings.
+
+WWW: http://patch-tag.com/r/felipe/attoparsec-text/home