aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2005-05-17 06:03:14 +0800
committermezz <mezz@FreeBSD.org>2005-05-17 06:03:14 +0800
commit812085d4447350aef027b4d95b42af37a496f414 (patch)
tree30b9d6d1015b835c3c3e8cc81f42110c17e787b2 /textproc
parent2d24bcdc09052bfb34405eb7d9b345489b68286f (diff)
downloadfreebsd-ports-gnome-812085d4447350aef027b4d95b42af37a496f414.tar.gz
freebsd-ports-gnome-812085d4447350aef027b4d95b42af37a496f414.tar.zst
freebsd-ports-gnome-812085d4447350aef027b4d95b42af37a496f414.zip
Use glib20 port instead included to solve the AbiWord crash when you click for
open/save dialog. With help: marcus and kwm via IRC #freebsd-gnome
Diffstat (limited to 'textproc')
-rw-r--r--textproc/wv/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/textproc/wv/Makefile b/textproc/wv/Makefile
index 3fea3b925b5e..9abf254732d6 100644
--- a/textproc/wv/Makefile
+++ b/textproc/wv/Makefile
@@ -7,7 +7,7 @@
PORTNAME= wv
PORTVERSION= 1.0.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= wvware
@@ -23,11 +23,13 @@ RUN_DEPENDS= lynx:${PORTSDIR}/www/lynx-ssl
.endif
USE_GETOPT_LONG= yes
-USE_GNOME= gnometarget pkgconfig
+USE_GNOME= gnometarget pkgconfig glib20
USE_GMAKE= yes
USE_LIBTOOL_VER=15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --with-exporter --with-libwmf=${LOCALBASE}
+CONFIGURE_ARGS= --with-exporter \
+ --with-glib=glib2 \
+ --with-libwmf=${LOCALBASE}
MAKEFILE= GNUmakefile
MAKE_ARGS= pkgconfigdir="${PREFIX}/libdata/pkgconfig"
INSTALLS_SHLIB= yes
@@ -39,11 +41,4 @@ MLINKS= wvWare.1 wvConvert.1
CPPFLAGS= -I${LOCALBASE}/include/libpng -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
-.if ${MACHINE_ARCH:L} == "amd64"
-USE_GNOME+= glib20
-CONFIGURE_ARGS+= --with-glib
-.else
-CONFIGURE_ARGS+= --without-glib
-.endif
-
.include <bsd.port.mk>