aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-06-24 18:21:15 +0800
committerpgj <pgj@FreeBSD.org>2012-06-24 18:21:15 +0800
commit8cc4db3b15b55c490232da2538ef17ba17b705e2 (patch)
treebf23b59ea3e1a6d31344b90151f6cd9d0ffc989a /textproc
parent5cbe721fac6b41129f8a9a531e5c656bf6f6e264 (diff)
downloadfreebsd-ports-gnome-8cc4db3b15b55c490232da2538ef17ba17b705e2.tar.gz
freebsd-ports-gnome-8cc4db3b15b55c490232da2538ef17ba17b705e2.tar.zst
freebsd-ports-gnome-8cc4db3b15b55c490232da2538ef17ba17b705e2.zip
This package uses tagstream-conduit for its parser. It automatically
balances mismatched tags, so that there shouldn't be any parse failures. It does not handle a full HTML document rendering, such as adding missing html and head tags. WWW: https://github.com/snoyberg/xml Obtained from: FreeBSD Haskell
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/hs-html-conduit/Makefile24
-rw-r--r--textproc/hs-html-conduit/distinfo2
-rw-r--r--textproc/hs-html-conduit/pkg-descr6
4 files changed, 33 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index ae43d27ad026..293d1de2f318 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -252,6 +252,7 @@
SUBDIR += hs-highlighting-kate
SUBDIR += hs-hs-bibutils
SUBDIR += hs-html
+ SUBDIR += hs-html-conduit
SUBDIR += hs-hxt
SUBDIR += hs-hxt-charproperties
SUBDIR += hs-hxt-regex-xmlschema
diff --git a/textproc/hs-html-conduit/Makefile b/textproc/hs-html-conduit/Makefile
new file mode 100644
index 000000000000..cad543ceabd2
--- /dev/null
+++ b/textproc/hs-html-conduit/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: hs-html-conduit
+# Date created: June 10, 2012
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= html-conduit
+PORTVERSION= 0.0.1
+CATEGORIES= textproc haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Parse HTML documents using xml-conduit datatypes
+
+LICENSE= MIT
+
+CABAL_SETUP= Setup.hs
+
+USE_CABAL= conduit>=0.4 filesystem-conduit>=0.4 resourcet>=0.3 \
+ system-filepath>=0.4 tagstream-conduit>=0.3 text \
+ transformers xml-conduit>=0.7 xml-types>=0.3
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/textproc/hs-html-conduit/distinfo b/textproc/hs-html-conduit/distinfo
new file mode 100644
index 000000000000..3bb2ed927126
--- /dev/null
+++ b/textproc/hs-html-conduit/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/html-conduit-0.0.1.tar.gz) = 87866c66961b457450b5b739e485113ae3c238a2e594b4215e16666184bc9f6d
+SIZE (cabal/html-conduit-0.0.1.tar.gz) = 3285
diff --git a/textproc/hs-html-conduit/pkg-descr b/textproc/hs-html-conduit/pkg-descr
new file mode 100644
index 000000000000..7947a18ad839
--- /dev/null
+++ b/textproc/hs-html-conduit/pkg-descr
@@ -0,0 +1,6 @@
+This package uses tagstream-conduit for its parser. It automatically
+balances mismatched tags, so that there shouldn't be any parse failures.
+It does not handle a full HTML document rendering, such as adding missing
+html and head tags.
+
+WWW: https://github.com/snoyberg/xml