aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-05-31 06:13:43 +0800
committeraaron <aaron@FreeBSD.org>2006-05-31 06:13:43 +0800
commit980631ee59372e01a098b2714218113e41c2091a (patch)
tree6a5ddb424840551de64cd3cfe6c686b0a52f060c /textproc
parentee09b48d1748279bba15a70c56c79021f0e84ae7 (diff)
downloadfreebsd-ports-gnome-980631ee59372e01a098b2714218113e41c2091a.tar.gz
freebsd-ports-gnome-980631ee59372e01a098b2714218113e41c2091a.tar.zst
freebsd-ports-gnome-980631ee59372e01a098b2714218113e41c2091a.zip
Adding port textproc/p5-Parse-Flex, a fast, XS-based flex parser.
- minor 'make test' failure reported to vendor Approved by: tobez (implicit)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Parse-Flex/Makefile32
-rw-r--r--textproc/p5-Parse-Flex/distinfo2
-rw-r--r--textproc/p5-Parse-Flex/pkg-descr18
-rw-r--r--textproc/p5-Parse-Flex/pkg-plist8
5 files changed, 61 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 64dd18868506..d06028ca23ef 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -376,6 +376,7 @@
SUBDIR += p5-PPI
SUBDIR += p5-PPI-HTML
SUBDIR += p5-Parse-FixedLength
+ SUBDIR += p5-Parse-Flex
SUBDIR += p5-Parse-PhoneNumber
SUBDIR += p5-Parse-Syslog
SUBDIR += p5-Perl-Critic
diff --git a/textproc/p5-Parse-Flex/Makefile b/textproc/p5-Parse-Flex/Makefile
new file mode 100644
index 000000000000..5a3f99973673
--- /dev/null
+++ b/textproc/p5-Parse-Flex/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Parse-Flex
+# Date created: 30 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Parse-Flex
+PORTVERSION= 0.11
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Parse
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= The Fastest Lexer in the West
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ ${SITE_PERL}/XSLoader.pm:${PORTSDIR}/devel/p5-XSLoader
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Parse::Flex.3 Parse::Flex::Generate.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Parse-Flex/distinfo b/textproc/p5-Parse-Flex/distinfo
new file mode 100644
index 000000000000..5b0ac650c473
--- /dev/null
+++ b/textproc/p5-Parse-Flex/distinfo
@@ -0,0 +1,2 @@
+MD5 (Parse-Flex-0.11.tar.gz) = df7abef53e9afa49e3510bf267a020c1
+SIZE (Parse-Flex-0.11.tar.gz) = 10240
diff --git a/textproc/p5-Parse-Flex/pkg-descr b/textproc/p5-Parse-Flex/pkg-descr
new file mode 100644
index 000000000000..894ce62d3f33
--- /dev/null
+++ b/textproc/p5-Parse-Flex/pkg-descr
@@ -0,0 +1,18 @@
+Parse::Flex works similar to Parse::Lex, but it uses XS for faster
+performance.
+
+This module allows you to construct a lexer analyzer with your custom
+rules. Parse::Flex is not intended to be used directly; instead, use the
+script makelexer.pl to submit your grammar file. The output of the script
+is a custom shared library and a custom .pm module which, among other
+things, will transparently load the library and provide interface to your
+(custom) lexer. In other words, you supply a grammar.l file to
+makelexer.pl and you receive Flex01.pm and Flex02.so . Then, use only the
+Flex01.pm - since Flex01.pm will automatically load Flex01.so.
+
+The grammar.l file requires the same syntax as flex(1); that is, the
+actions are written in C . See the flex(1) documentation to learn the
+syntax, or fetch the sample t/grammar.l file inside this package.
+
+WWW: http://search.cpan.org/dist/Parse-Flex
+Author: Ioannis Tambouras <ioannis@earthlink.net>
diff --git a/textproc/p5-Parse-Flex/pkg-plist b/textproc/p5-Parse-Flex/pkg-plist
new file mode 100644
index 000000000000..e1b251f1c438
--- /dev/null
+++ b/textproc/p5-Parse-Flex/pkg-plist
@@ -0,0 +1,8 @@
+bin/makelexer.pl
+%%SITE_PERL%%/Parse/Flex.pm
+%%SITE_PERL%%/Parse/Flex/Generate.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse/Flex/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse/Flex
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse
+@dirrm %%SITE_PERL%%/Parse/Flex
+@dirrmtry %%SITE_PERL%%/Parse