aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2011-07-31 00:13:04 +0800
committertota <tota@FreeBSD.org>2011-07-31 00:13:04 +0800
commit9e85aa02d65ddd31f27b93a762f6ce490cc828d1 (patch)
tree5522beeff698e09ec3104a79dfcf7e0b3159b9ca /textproc
parentab042203fca891677d1bb7b0774109bc0a611bf8 (diff)
downloadfreebsd-ports-gnome-9e85aa02d65ddd31f27b93a762f6ce490cc828d1.tar.gz
freebsd-ports-gnome-9e85aa02d65ddd31f27b93a762f6ce490cc828d1.tar.zst
freebsd-ports-gnome-9e85aa02d65ddd31f27b93a762f6ce490cc828d1.zip
- Add a new port: textproc/ruby-hikidoc
'HikiDoc' is a text-to-HTML conversion tool for web writers. HikiDoc allows you to write using an easy-to-read, easy-to-write plain text format, then convert it to structurally valid HTML (or XHTML). WWW: http://rubyforge.org/projects/hikidoc/
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/ruby-hikidoc/Makefile37
-rw-r--r--textproc/ruby-hikidoc/distinfo2
-rw-r--r--textproc/ruby-hikidoc/pkg-descr5
4 files changed, 45 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 679ecbf9d387..148dbe4384ad 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1160,6 +1160,7 @@
SUBDIR += ruby-format
SUBDIR += ruby-formvalidator
SUBDIR += ruby-gdome
+ SUBDIR += ruby-hikidoc
SUBDIR += ruby-html-fillinform
SUBDIR += ruby-html-template
SUBDIR += ruby-htmlrepair
diff --git a/textproc/ruby-hikidoc/Makefile b/textproc/ruby-hikidoc/Makefile
new file mode 100644
index 000000000000..0127d803e8bd
--- /dev/null
+++ b/textproc/ruby-hikidoc/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: ruby-hikidoc
+# Date created: 2011-07-30
+# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hikidoc
+PORTVERSION= 0.0.6
+CATEGORIES= textproc ruby
+MASTER_SITES= RF
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= ${RUBY_PKGNAMEPREFIX:S|${RUBY_SUFFIX}-||}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= A text-to-HTML conversion tool for web writers
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+RUBY_SHEBANG_FILES= bin/hikidoc
+
+PORTDOCS= NEWS NEWS.ja README README.ja \
+ TextFormattingRules TextFormattingRules.ja
+
+PLIST_FILES= bin/hikidoc \
+ %%RUBY_SITELIBDIR%%/hikidoc.rb
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ @${INSTALL_DATA} ${INSTALL_WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/ruby-hikidoc/distinfo b/textproc/ruby-hikidoc/distinfo
new file mode 100644
index 000000000000..6e3891db50ee
--- /dev/null
+++ b/textproc/ruby-hikidoc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ruby/hikidoc-0.0.6.tgz) = c248335b90efab89cf5a029195f23248c7f9f1b23a42889056bc08891dddb5dc
+SIZE (ruby/hikidoc-0.0.6.tgz) = 26370
diff --git a/textproc/ruby-hikidoc/pkg-descr b/textproc/ruby-hikidoc/pkg-descr
new file mode 100644
index 000000000000..06bf8b685b59
--- /dev/null
+++ b/textproc/ruby-hikidoc/pkg-descr
@@ -0,0 +1,5 @@
+'HikiDoc' is a text-to-HTML conversion tool for web writers. HikiDoc
+allows you to write using an easy-to-read, easy-to-write plain text
+format, then convert it to structurally valid HTML (or XHTML).
+
+WWW: http://rubyforge.org/projects/hikidoc/