aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2016-03-15 00:10:26 +0800
committerfeld <feld@FreeBSD.org>2016-03-15 00:10:26 +0800
commitadfde3e0f007e38648c2731d34670c14fa185112 (patch)
tree5e6aac48cf819c64df02456bc54380ae5524519e /textproc
parent6962f62f20ce4211f44aebfbbb0f2519e13bc22d (diff)
downloadfreebsd-ports-gnome-adfde3e0f007e38648c2731d34670c14fa185112.tar.gz
freebsd-ports-gnome-adfde3e0f007e38648c2731d34670c14fa185112.tar.zst
freebsd-ports-gnome-adfde3e0f007e38648c2731d34670c14fa185112.zip
textproc/kibana42, kibana43, kibana44: Fix ability to customize settings
Changes: - Allows user to customize some Kibana's settings without interfering with the deinstallation process of the package (bug #207209) Drawbacks: - Kibana takes couple of minutes to start for the first time after package installation or settings' change (There's a warning in the log about that) - ${WWWDIR}/optimize folder is now writable, weakening the security. Although, given the architecture of Kibana it's inevitable PR: 207209
Diffstat (limited to 'textproc')
-rw-r--r--textproc/kibana42/Makefile2
-rw-r--r--textproc/kibana42/pkg-plist29
-rw-r--r--textproc/kibana43/Makefile1
-rw-r--r--textproc/kibana43/pkg-plist30
-rw-r--r--textproc/kibana44/Makefile1
-rw-r--r--textproc/kibana44/pkg-plist30
6 files changed, 10 insertions, 83 deletions
diff --git a/textproc/kibana42/Makefile b/textproc/kibana42/Makefile
index b72b3824259f..0c69249d5daa 100644
--- a/textproc/kibana42/Makefile
+++ b/textproc/kibana42/Makefile
@@ -4,6 +4,7 @@
PORTNAME= kibana
PORTVERSION?= 4.2.2
DISTVERSIONSUFFIX= -linux-x86
+PORTREVISION?= 1
CATEGORIES= textproc www
MASTER_SITES= https://download.elastic.co/kibana/kibana/ \
http://download.elastic.co/kibana/kibana/
@@ -26,6 +27,7 @@ do-install:
${MKDIR} ${STAGEDIR}${WWWDIR}
cd ${WRKSRC} && \
${RM} -r bin config node && \
+ ${RM} -r optimize/* && \
${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}
.include <bsd.port.mk>
diff --git a/textproc/kibana42/pkg-plist b/textproc/kibana42/pkg-plist
index 44254222b132..6eba23d3cfa6 100644
--- a/textproc/kibana42/pkg-plist
+++ b/textproc/kibana42/pkg-plist
@@ -1,3 +1,4 @@
+@preunexec rm -rf %D/%%WWWDIR%%/optimize/* 2>&1 >/dev/null || true
@sample etc/kibana.yml.sample
%%WWWDIR%%/LICENSE.txt
%%WWWDIR%%/README.txt
@@ -10932,33 +10933,6 @@
%%WWWDIR%%/node_modules/whatwg-fetch/README.md
%%WWWDIR%%/node_modules/whatwg-fetch/fetch.js
%%WWWDIR%%/node_modules/whatwg-fetch/package.json
-%%WWWDIR%%/optimize/bundles/commons.bundle.js
-%%WWWDIR%%/optimize/bundles/commons.style.css
-%%WWWDIR%%/optimize/bundles/kibana.bundle.js
-%%WWWDIR%%/optimize/bundles/kibana.entry.js
-%%WWWDIR%%/optimize/bundles/kibana.style.css
-%%WWWDIR%%/optimize/bundles/node_modules/bootstrap/fonts/glyphicons-halflings-regular.eot
-%%WWWDIR%%/optimize/bundles/node_modules/bootstrap/fonts/glyphicons-halflings-regular.svg
-%%WWWDIR%%/optimize/bundles/node_modules/bootstrap/fonts/glyphicons-halflings-regular.ttf
-%%WWWDIR%%/optimize/bundles/node_modules/bootstrap/fonts/glyphicons-halflings-regular.woff
-%%WWWDIR%%/optimize/bundles/node_modules/bootstrap/fonts/glyphicons-halflings-regular.woff2
-%%WWWDIR%%/optimize/bundles/node_modules/font-awesome/fonts/fontawesome-webfont.eot
-%%WWWDIR%%/optimize/bundles/node_modules/font-awesome/fonts/fontawesome-webfont.svg
-%%WWWDIR%%/optimize/bundles/node_modules/font-awesome/fonts/fontawesome-webfont.ttf
-%%WWWDIR%%/optimize/bundles/node_modules/font-awesome/fonts/fontawesome-webfont.woff
-%%WWWDIR%%/optimize/bundles/node_modules/font-awesome/fonts/fontawesome-webfont.woff2
-%%WWWDIR%%/optimize/bundles/src/ui/public/images/elk.ico
-%%WWWDIR%%/optimize/bundles/src/ui/public/stringify/icons/cv.png
-%%WWWDIR%%/optimize/bundles/src/ui/public/stringify/icons/de.png
-%%WWWDIR%%/optimize/bundles/src/ui/public/stringify/icons/go.png
-%%WWWDIR%%/optimize/bundles/src/ui/public/stringify/icons/ne.png
-%%WWWDIR%%/optimize/bundles/src/ui/public/stringify/icons/ni.png
-%%WWWDIR%%/optimize/bundles/src/ui/public/stringify/icons/stop.png
-%%WWWDIR%%/optimize/bundles/src/ui/public/stringify/icons/us.png
-%%WWWDIR%%/optimize/bundles/statusPage.bundle.js
-%%WWWDIR%%/optimize/bundles/statusPage.entry.js
-%%WWWDIR%%/optimize/bundles/statusPage.style.css
-%%WWWDIR%%/optimize/bundles/webpack.records
%%WWWDIR%%/package.json
%%WWWDIR%%/src/cli/Command.js
%%WWWDIR%%/src/cli/Log.js
@@ -11779,4 +11753,5 @@
%%WWWDIR%%/webpackShims/ui-bootstrap.js
@dir %%WWWDIR%%/installedPlugins
@dir %%WWWDIR%%/node_modules/rimraf/node_modules
+@dir(www,www) %%WWWDIR%%/optimize
@dir %%WWWDIR%%/src/ui/public/factories
diff --git a/textproc/kibana43/Makefile b/textproc/kibana43/Makefile
index a8717fad0f93..cb71ba2ca200 100644
--- a/textproc/kibana43/Makefile
+++ b/textproc/kibana43/Makefile
@@ -2,6 +2,7 @@
# $FreeBSD$
PORTVERSION= 4.3.2
+PORTREVISION= 1
PKGNAMESUFFIX= 43
MASTERDIR= ${.CURDIR}/../kibana42
PKGDIR= ${.CURDIR}
diff --git a/textproc/kibana43/pkg-plist b/textproc/kibana43/pkg-plist
index 46c50382ab2b..297ed5f87317 100644
--- a/textproc/kibana43/pkg-plist
+++ b/textproc/kibana43/pkg-plist
@@ -1,3 +1,4 @@
+@preunexec rm -rf %D/%%WWWDIR%%/optimize/* 2>&1 >/dev/null || true
@sample etc/kibana.yml.sample
%%WWWDIR%%/LICENSE.txt
%%WWWDIR%%/README.txt
@@ -10856,34 +10857,6 @@
%%WWWDIR%%/node_modules/whatwg-fetch/README.md
%%WWWDIR%%/node_modules/whatwg-fetch/fetch.js
%%WWWDIR%%/node_modules/whatwg-fetch/package.json
-%%WWWDIR%%/optimize/bundles/commons.bundle.js
-%%WWWDIR%%/optimize/bundles/commons.style.css
-%%WWWDIR%%/optimize/bundles/kibana.bundle.js
-%%WWWDIR%%/optimize/bundles/kibana.entry.js
-%%WWWDIR%%/optimize/bundles/kibana.style.css
-%%WWWDIR%%/optimize/bundles/node_modules/bootstrap/fonts/glyphicons-halflings-regular.eot
-%%WWWDIR%%/optimize/bundles/node_modules/bootstrap/fonts/glyphicons-halflings-regular.svg
-%%WWWDIR%%/optimize/bundles/node_modules/bootstrap/fonts/glyphicons-halflings-regular.ttf
-%%WWWDIR%%/optimize/bundles/node_modules/bootstrap/fonts/glyphicons-halflings-regular.woff
-%%WWWDIR%%/optimize/bundles/node_modules/bootstrap/fonts/glyphicons-halflings-regular.woff2
-%%WWWDIR%%/optimize/bundles/node_modules/font-awesome/fonts/fontawesome-webfont.eot
-%%WWWDIR%%/optimize/bundles/node_modules/font-awesome/fonts/fontawesome-webfont.svg
-%%WWWDIR%%/optimize/bundles/node_modules/font-awesome/fonts/fontawesome-webfont.ttf
-%%WWWDIR%%/optimize/bundles/node_modules/font-awesome/fonts/fontawesome-webfont.woff
-%%WWWDIR%%/optimize/bundles/node_modules/font-awesome/fonts/fontawesome-webfont.woff2
-%%WWWDIR%%/optimize/bundles/src/ui/public/images/elk.ico
-%%WWWDIR%%/optimize/bundles/src/ui/public/images/kibana.svg
-%%WWWDIR%%/optimize/bundles/src/ui/public/stringify/icons/cv.png
-%%WWWDIR%%/optimize/bundles/src/ui/public/stringify/icons/de.png
-%%WWWDIR%%/optimize/bundles/src/ui/public/stringify/icons/go.png
-%%WWWDIR%%/optimize/bundles/src/ui/public/stringify/icons/ne.png
-%%WWWDIR%%/optimize/bundles/src/ui/public/stringify/icons/ni.png
-%%WWWDIR%%/optimize/bundles/src/ui/public/stringify/icons/stop.png
-%%WWWDIR%%/optimize/bundles/src/ui/public/stringify/icons/us.png
-%%WWWDIR%%/optimize/bundles/statusPage.bundle.js
-%%WWWDIR%%/optimize/bundles/statusPage.entry.js
-%%WWWDIR%%/optimize/bundles/statusPage.style.css
-%%WWWDIR%%/optimize/bundles/webpack.records
%%WWWDIR%%/package.json
%%WWWDIR%%/src/cli/Command.js
%%WWWDIR%%/src/cli/Log.js
@@ -11711,4 +11684,5 @@
%%WWWDIR%%/webpackShims/ui-bootstrap.js
@dir %%WWWDIR%%/installedPlugins
@dir %%WWWDIR%%/node_modules/rimraf/node_modules
+@dir(www,www) %%WWWDIR%%/optimize
@dir %%WWWDIR%%/src/ui/public/factories
diff --git a/textproc/kibana44/Makefile b/textproc/kibana44/Makefile
index 5865eb63e6d6..5620585fb684 100644
--- a/textproc/kibana44/Makefile
+++ b/textproc/kibana44/Makefile
@@ -2,6 +2,7 @@
# $FreeBSD$
PORTVERSION= 4.4.1
+PORTREVISION= 1
PKGNAMESUFFIX= 44
MASTERDIR= ${.CURDIR}/../kibana42
PKGDIR= ${.CURDIR}
diff --git a/textproc/kibana44/pkg-plist b/textproc/kibana44/pkg-plist
index dbd0fe499e50..d72dec17105d 100644
--- a/textproc/kibana44/pkg-plist
+++ b/textproc/kibana44/pkg-plist
@@ -1,3 +1,4 @@
+@preunexec rm -rf %D/%%WWWDIR%%/optimize/* 2>&1 >/dev/null || true
@sample etc/kibana.yml.sample
%%WWWDIR%%/LICENSE.txt
%%WWWDIR%%/README.txt
@@ -11066,34 +11067,6 @@
%%WWWDIR%%/node_modules/wreck/node_modules/hoek/lib/index.js
%%WWWDIR%%/node_modules/wreck/node_modules/hoek/package.json
%%WWWDIR%%/node_modules/wreck/package.json
-%%WWWDIR%%/optimize/bundles/commons.bundle.js
-%%WWWDIR%%/optimize/bundles/commons.style.css
-%%WWWDIR%%/optimize/bundles/kibana.bundle.js
-%%WWWDIR%%/optimize/bundles/kibana.entry.js
-%%WWWDIR%%/optimize/bundles/kibana.style.css
-%%WWWDIR%%/optimize/bundles/node_modules/bootstrap/fonts/glyphicons-halflings-regular.eot
-%%WWWDIR%%/optimize/bundles/node_modules/bootstrap/fonts/glyphicons-halflings-regular.svg
-%%WWWDIR%%/optimize/bundles/node_modules/bootstrap/fonts/glyphicons-halflings-regular.ttf
-%%WWWDIR%%/optimize/bundles/node_modules/bootstrap/fonts/glyphicons-halflings-regular.woff
-%%WWWDIR%%/optimize/bundles/node_modules/bootstrap/fonts/glyphicons-halflings-regular.woff2
-%%WWWDIR%%/optimize/bundles/node_modules/font-awesome/fonts/fontawesome-webfont.eot
-%%WWWDIR%%/optimize/bundles/node_modules/font-awesome/fonts/fontawesome-webfont.svg
-%%WWWDIR%%/optimize/bundles/node_modules/font-awesome/fonts/fontawesome-webfont.ttf
-%%WWWDIR%%/optimize/bundles/node_modules/font-awesome/fonts/fontawesome-webfont.woff
-%%WWWDIR%%/optimize/bundles/node_modules/font-awesome/fonts/fontawesome-webfont.woff2
-%%WWWDIR%%/optimize/bundles/src/ui/public/images/elk.ico
-%%WWWDIR%%/optimize/bundles/src/ui/public/images/kibana.svg
-%%WWWDIR%%/optimize/bundles/src/ui/public/stringify/icons/cv.png
-%%WWWDIR%%/optimize/bundles/src/ui/public/stringify/icons/de.png
-%%WWWDIR%%/optimize/bundles/src/ui/public/stringify/icons/go.png
-%%WWWDIR%%/optimize/bundles/src/ui/public/stringify/icons/ne.png
-%%WWWDIR%%/optimize/bundles/src/ui/public/stringify/icons/ni.png
-%%WWWDIR%%/optimize/bundles/src/ui/public/stringify/icons/stop.png
-%%WWWDIR%%/optimize/bundles/src/ui/public/stringify/icons/us.png
-%%WWWDIR%%/optimize/bundles/statusPage.bundle.js
-%%WWWDIR%%/optimize/bundles/statusPage.entry.js
-%%WWWDIR%%/optimize/bundles/statusPage.style.css
-%%WWWDIR%%/optimize/bundles/webpack.records
%%WWWDIR%%/package.json
%%WWWDIR%%/src/cli/Command.js
%%WWWDIR%%/src/cli/Log.js
@@ -11947,4 +11920,5 @@
%%WWWDIR%%/webpackShims/ui-bootstrap.js
@dir %%WWWDIR%%/installedPlugins
@dir %%WWWDIR%%/node_modules/rimraf/node_modules
+@dir(www,www) %%WWWDIR%%/optimize
@dir %%WWWDIR%%/src/ui/public/factories