aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2010-06-25 01:20:01 +0800
committermezz <mezz@FreeBSD.org>2010-06-25 01:20:01 +0800
commitb39d2317424a595e29c216d109710fa40cc23214 (patch)
tree87331e9b5976e6e1d32ef4e606995e77c30c810f /textproc
parent548bcd069ee21e552bf21771506bb0a782d6de73 (diff)
downloadfreebsd-ports-gnome-b39d2317424a595e29c216d109710fa40cc23214.tar.gz
freebsd-ports-gnome-b39d2317424a595e29c216d109710fa40cc23214.tar.zst
freebsd-ports-gnome-b39d2317424a595e29c216d109710fa40cc23214.zip
Add an option to build libxml w/out threads support.
PR: ports/146582 Submitted by: Alexander Kriventsov <avk@vl.ru> Feature safe: yes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/libxml2/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index ead0af74a12c..08c2c5a96f0a 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -5,6 +5,7 @@
# $FreeBSD$
#
# WITHOUT_SCHEMA disable XML schema support
+# WITHOUT_THREADS disable threads support
# WITH_MEM_DEBUG enable memory debugging (DEVELOPERS ONLY!)
# WITH_XMLLINT_HIST enable history for xmllint
# WITH_THREAD_ALLOC enable per-thread memory (DEVELOPERS ONLY!)
@@ -46,6 +47,10 @@ MAN3= libxml.3
CONFIGURE_ARGS+= --without-schemas
.endif
+.if defined(WITHOUT_THREADS)
+CONFIGURE_ARGS+= --without-threads
+.endif
+
.if defined(WITH_MEM_DEBUG)
CONFIGURE_ARGS+= --with-mem-debug
.endif