aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-01-07 06:33:12 +0800
committertcberner <tcberner@FreeBSD.org>2018-01-07 06:33:12 +0800
commitbc9a30603f1d9c214bb08c6d3fc3d5c75f4c04a8 (patch)
treebceb249eca7784d74c398ffd74f9f29d1ae39c63 /textproc
parent090f0f65e07637087fe9c611c0d3e8359e2a6c96 (diff)
downloadfreebsd-ports-gnome-bc9a30603f1d9c214bb08c6d3fc3d5c75f4c04a8.tar.gz
freebsd-ports-gnome-bc9a30603f1d9c214bb08c6d3fc3d5c75f4c04a8.tar.zst
freebsd-ports-gnome-bc9a30603f1d9c214bb08c6d3fc3d5c75f4c04a8.zip
textproc/soprano, fix build with clang6
PR: 224945 Reported by: jbeich
Diffstat (limited to 'textproc')
-rw-r--r--textproc/soprano/Makefile2
-rw-r--r--textproc/soprano/files/patch-soprano_pluginmanager.cpp17
-rw-r--r--textproc/soprano/files/patch-soprano_sopranodirs.cpp25
3 files changed, 43 insertions, 1 deletions
diff --git a/textproc/soprano/Makefile b/textproc/soprano/Makefile
index 2e5c8ffbe00b..db10888027fc 100644
--- a/textproc/soprano/Makefile
+++ b/textproc/soprano/Makefile
@@ -3,7 +3,7 @@
PORTNAME= soprano
PORTVERSION= 2.9.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= SF/${PORTNAME}/Soprano/${PORTVERSION}
diff --git a/textproc/soprano/files/patch-soprano_pluginmanager.cpp b/textproc/soprano/files/patch-soprano_pluginmanager.cpp
new file mode 100644
index 000000000000..eaa4c23b5eac
--- /dev/null
+++ b/textproc/soprano/files/patch-soprano_pluginmanager.cpp
@@ -0,0 +1,17 @@
+error: invalid suffix on literal; C++11 requires a space between literal and identifier
+ [-Wreserved-user-defined-literal]
+ fileSearchPaths << file.fileName().section( "/", 0, -5,
+ QString::SectionIncludeTrailingSep ) + QLatin1String( "lib"SOPRANO_LIB_SUFFIX );
+ ^
+
+--- soprano/pluginmanager.cpp.orig 2013-10-09 17:22:28 UTC
++++ soprano/pluginmanager.cpp
+@@ -43,7 +43,7 @@ namespace {
+ fileSearchPaths << file.fileName().section( '/', 0, -2 );
+ #ifndef Q_OS_WIN
+ // the lib folder in the same prefix
+- fileSearchPaths << file.fileName().section( "/", 0, -5, QString::SectionIncludeTrailingSep ) + QLatin1String( "lib"SOPRANO_LIB_SUFFIX );
++ fileSearchPaths << file.fileName().section( "/", 0, -5, QString::SectionIncludeTrailingSep ) + QLatin1String( "lib" SOPRANO_LIB_SUFFIX );
+ #endif
+ return Soprano::findLibraryPath( file.library(), fileSearchPaths, QStringList() << QLatin1String( "soprano" ) );
+ }
diff --git a/textproc/soprano/files/patch-soprano_sopranodirs.cpp b/textproc/soprano/files/patch-soprano_sopranodirs.cpp
new file mode 100644
index 000000000000..57538d728842
--- /dev/null
+++ b/textproc/soprano/files/patch-soprano_sopranodirs.cpp
@@ -0,0 +1,25 @@
+error: invalid suffix on literal; C++11 requires a space between literal and identifier
+ paths << QLatin1String( SOPRANO_PREFIX"/lib"SOPRANO_LIB_SUFFIX );
+ ^
+--- soprano/sopranodirs.cpp.orig 2018-01-06 22:23:48 UTC
++++ soprano/sopranodirs.cpp
+@@ -124,14 +124,14 @@ QStringList Soprano::envDirList( const char* var )
+ QStringList Soprano::libDirs()
+ {
+ QStringList paths = QCoreApplication::libraryPaths();
+- paths << QLatin1String( SOPRANO_PREFIX"/lib"SOPRANO_LIB_SUFFIX );
++ paths << QLatin1String( SOPRANO_PREFIX "/lib" SOPRANO_LIB_SUFFIX );
+ #ifdef Q_OS_WIN
+- paths << QLatin1String( SOPRANO_PREFIX"/bin" );
++ paths << QLatin1String( SOPRANO_PREFIX "/bin" );
+ paths << getWinPrefix() + QLatin1String( "/bin" );
+- paths << getWinPrefix() + QLatin1String( "/lib"SOPRANO_LIB_SUFFIX );
++ paths << getWinPrefix() + QLatin1String( "/lib" SOPRANO_LIB_SUFFIX );
+ #else
+- paths << QLatin1String( "/usr/lib"SOPRANO_LIB_SUFFIX );
+- paths << QLatin1String( "/usr/local/lib"SOPRANO_LIB_SUFFIX );
++ paths << QLatin1String( "/usr/lib" SOPRANO_LIB_SUFFIX );
++ paths << QLatin1String( "/usr/local/lib" SOPRANO_LIB_SUFFIX );
+ paths += Soprano::envDirList( "LD_LIBRARY_PATH" );
+ #endif
+ return paths;