aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2014-04-29 12:57:55 +0800
committertota <tota@FreeBSD.org>2014-04-29 12:57:55 +0800
commitc2e56601ec17a2da5737d6ab7a1b0265c8d5d08a (patch)
tree0f9278f744a9503272c26882b13f95db86f7dbca /textproc
parentd354eef35f1eecb1b70a8ebbc8702cf8085ed5c8 (diff)
downloadfreebsd-ports-gnome-c2e56601ec17a2da5737d6ab7a1b0265c8d5d08a.tar.gz
freebsd-ports-gnome-c2e56601ec17a2da5737d6ab7a1b0265c8d5d08a.tar.zst
freebsd-ports-gnome-c2e56601ec17a2da5737d6ab7a1b0265c8d5d08a.zip
- Unbreak
- Add LICENSE - Support STAGEDIR - Make DOCS and EXAMPLES unconditional to stage - Replace tab with a single space after WWW: in pkg-descr
Diffstat (limited to 'textproc')
-rw-r--r--textproc/ruby-rttool/Makefile19
-rw-r--r--textproc/ruby-rttool/files/patch-setup.rb51
-rw-r--r--textproc/ruby-rttool/pkg-descr2
3 files changed, 60 insertions, 12 deletions
diff --git a/textproc/ruby-rttool/Makefile b/textproc/ruby-rttool/Makefile
index 4a3f29177ce2..1320501cd6db 100644
--- a/textproc/ruby-rttool/Makefile
+++ b/textproc/ruby-rttool/Makefile
@@ -12,7 +12,7 @@ DIST_SUBDIR= ${RUBY_PKGNAMEPREFIX:S|${RUBY_SUFFIX}-||}
MAINTAINER= tota@FreeBSD.org
COMMENT= RT into HTML and plain text converter
-BROKEN= not staged
+LICENSE= RUBY
USE_RUBY= yes
USE_RUBY_SETUP= yes
@@ -24,20 +24,17 @@ RUBY_MODNAME= rt
DOCS_EN= rttool.en.html rttool.en.rd
DOCS_JA= rttool.ja.html rttool.ja.rd
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS EXAMPLES
+
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_MODDOCDIR}/ja
+ @${MKDIR} ${STAGEDIR}${RUBY_MODDOCDIR}/ja
.for f in ${DOCS_EN}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${RUBY_MODDOCDIR}/
.endfor
.for f in ${DOCS_JA}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/ja/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${RUBY_MODDOCDIR}/ja/
.endfor
-.endif
-.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}
- cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${RUBY_MODEXAMPLESDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}
+ cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${RUBY_MODEXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/textproc/ruby-rttool/files/patch-setup.rb b/textproc/ruby-rttool/files/patch-setup.rb
new file mode 100644
index 000000000000..ccc6f15490be
--- /dev/null
+++ b/textproc/ruby-rttool/files/patch-setup.rb
@@ -0,0 +1,51 @@
+--- setup.rb.orig 2009-01-22 02:19:43.000000000 +0900
++++ setup.rb 2014-04-29 06:10:59.000000000 +0900
+@@ -169,6 +169,11 @@
+ args.each do |i|
+ if i == '--no-harm' then
+ @no_harm = true
++ elsif /\A--prefix=(.*)\z/ =~ i then
++ path = $1
++ path = File.expand_path(path) unless path[0,1] == '/'
++ @config['prefix'] = path
++ @config.save
+ else
+ raise InstallError, "install: unknown option #{i}"
+ end
+@@ -320,7 +325,7 @@
+
+ class ConfigTable
+
+- c = ::Config::CONFIG
++ c = ::RbConfig::CONFIG
+
+ rubypath = c['bindir'] + '/' + c['ruby_install_name']
+
+@@ -581,15 +586,15 @@
+ #
+
+ def install_bin
+- install_all isdir(@config['bin-dir']), 0555
++ install_all isdir(@config['prefix'] + @config['bin-dir']), 0555
+ end
+
+ def install_rb( dir )
+- install_all isdir(@config['rb-dir'] + '/' + dir), 0644
++ install_all isdir(@config['prefix'] + @config['rb-dir'] + '/' + dir), 0644
+ end
+
+ def install_dat( dir )
+- install_all isdir(@config['data-dir'] + '/' + dir), 0644
++ install_all isdir(@config['prefix'] + @config['data-dir'] + '/' + dir), 0644
+ end
+
+ def install_all( dest, mode )
+@@ -635,7 +640,7 @@
+ end
+ end
+
+- DLEXT = ::Config::CONFIG['DLEXT']
++ DLEXT = ::RbConfig::CONFIG['DLEXT']
+
+ def find_so( dir )
+ fnames = nil
diff --git a/textproc/ruby-rttool/pkg-descr b/textproc/ruby-rttool/pkg-descr
index e16d32180f44..0343f2d24280 100644
--- a/textproc/ruby-rttool/pkg-descr
+++ b/textproc/ruby-rttool/pkg-descr
@@ -5,4 +5,4 @@ RT can be incorporated into RD.
At this time, RTtool can convert RT into HTML and plain text.
To convert into plain text, you need w3m.
-WWW: http://www.rubyist.net/~rubikitch/computer/rttool/index.en.html
+WWW: http://www.rubyist.net/~rubikitch/computer/rttool/index.en.html