aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2014-01-19 01:56:47 +0800
committerrakuco <rakuco@FreeBSD.org>2014-01-19 01:56:47 +0800
commitd03bdda9adbe324a3744e22dab8fda26926c44e7 (patch)
treefa8b4fdfc28ed4bdb8596da83935371815721fd7 /textproc
parentefed5cd40f98ec4e1affa4f84335b555ae6c8945 (diff)
downloadfreebsd-ports-gnome-d03bdda9adbe324a3744e22dab8fda26926c44e7.tar.gz
freebsd-ports-gnome-d03bdda9adbe324a3744e22dab8fda26926c44e7.tar.zst
freebsd-ports-gnome-d03bdda9adbe324a3744e22dab8fda26926c44e7.zip
- Allow the port to build with archivers/libzip installed.
libzip installs /usr/local/include/zip.h, and -I/usr/local/include ended up being passed to the compiler before -I<path-to-internal-minizip-copy>, which caused problems. [1] While here, modernize the Makefile: - Move LICENSE to the appropriate place. - Remove USE_DOS2UNIX: the files it was supposed to fix are not DOS-encoded anymore. - Support staging. - Convert from manually calling update-desktop-database and USE_GNOME=desktopfileutils to USES=desktop-file-utils. PR: ports/180350 [1] Approved by: maintainer timeout (no activity since the original report 7 months ago) MFH: 2014Q1
Diffstat (limited to 'textproc')
-rw-r--r--textproc/sigil/Makefile12
-rw-r--r--textproc/sigil/files/patch-src_Sigil_CMakeLists.txt18
2 files changed, 21 insertions, 9 deletions
diff --git a/textproc/sigil/Makefile b/textproc/sigil/Makefile
index 1ba4223bd9ab..21280015264b 100644
--- a/textproc/sigil/Makefile
+++ b/textproc/sigil/Makefile
@@ -11,25 +11,19 @@ DISTNAME= Sigil-${PORTVERSION}-Code
MAINTAINER= jonc@chen.org.nz
COMMENT= WYSIWYG ePub editor
+LICENSE= GPLv3
+
LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs \
libxerces-c.so:${PORTSDIR}/textproc/xerces-c3 \
libhunspell-1.3.so:${PORTSDIR}/textproc/hunspell \
libpcre.so:${PORTSDIR}/devel/pcre
-LICENSE= GPLv3
-
USE_ZIP= yes
-USES= cmake pkgconfig
-USE_DOS2UNIX= CMakeLists.txt DirEnumerator.cpp ZipFile_stl.cpp ZipPlatform_lnx.cpp
+USES= cmake desktop-file-utils pkgconfig
NO_WRKSUBDIR= yes
USE_QT4= qmake gui svg webkit xml moc uic rcc imageformats linguist
-USE_GNOME= desktopfileutils
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/CMakeLists.txt
-post-install:
- @-update-desktop-database > /dev/null
-
.include <bsd.port.mk>
diff --git a/textproc/sigil/files/patch-src_Sigil_CMakeLists.txt b/textproc/sigil/files/patch-src_Sigil_CMakeLists.txt
new file mode 100644
index 000000000000..f0a03b62fc0a
--- /dev/null
+++ b/textproc/sigil/files/patch-src_Sigil_CMakeLists.txt
@@ -0,0 +1,18 @@
+See ports/180350: if archivers/libzip is installed there's a conflict because
+/usr/local/include ends up being included before the minizip directory inside
+the port.
+--- src/Sigil/CMakeLists.txt.orig 2012-10-27 20:24:40.000000000 +0300
++++ src/Sigil/CMakeLists.txt 2014-01-18 19:08:50.000000000 +0200
+@@ -594,11 +594,11 @@
+ ${HUNSPELL_INCLUDE_DIRS}
+ ${PCRE_INCLUDE_DIRS}
+ ${tidyLib_SOURCE_DIR}
+- ${MINIZIP_INCLUDE_DIRS}
+ ${ZLIB_INCLUDE_DIRS}
+ ${XERCESEXTENSIONS_INCLUDE_DIRS}
+ ${XERCES_INCLUDE_DIRS}
+ ${BOOST_INCLUDE_DIRS}
++ ${MINIZIP_INCLUDE_DIRS}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR} )
+