aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2001-03-15 07:47:29 +0800
committervanilla <vanilla@FreeBSD.org>2001-03-15 07:47:29 +0800
commitd89ab9047e1450843b3d9e5f805751692fac7c13 (patch)
tree19b02578e92f8575e38a094f7639cc5d9944bb60 /textproc
parentb1c8009964d62ff0a137f1f8199850299a3dc286 (diff)
downloadfreebsd-ports-gnome-d89ab9047e1450843b3d9e5f805751692fac7c13.tar.gz
freebsd-ports-gnome-d89ab9047e1450843b3d9e5f805751692fac7c13.tar.zst
freebsd-ports-gnome-d89ab9047e1450843b3d9e5f805751692fac7c13.zip
a small yet fast Python extension module (written
in C) to parse or generate comma-separated value (CSV) files. PR: ports/25408 Submitted by: Johann Visagie <johann@egenetics.com>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-csv/Makefile24
-rw-r--r--textproc/py-csv/distinfo1
-rw-r--r--textproc/py-csv/pkg-comment1
-rw-r--r--textproc/py-csv/pkg-descr10
-rw-r--r--textproc/py-csv/pkg-plist1
6 files changed, 38 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 36f1adb4efcf..9a4143579a94 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -121,6 +121,7 @@
SUBDIR += pspell
SUBDIR += pspell-ispell
SUBDIR += py-HyperText
+ SUBDIR += py-csv
SUBDIR += py-expat
SUBDIR += py-martel
SUBDIR += py-mxTextTools
diff --git a/textproc/py-csv/Makefile b/textproc/py-csv/Makefile
new file mode 100644
index 000000000000..8eeabef1bd27
--- /dev/null
+++ b/textproc/py-csv/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: py-csv
+# Date created: 27 February 2001
+# Whom: Johann Visagie <johann@egenetics.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= csv
+PORTVERSION= 0.2
+CATEGORIES= textproc python
+MASTER_SITES= http://object-craft.com.au/projects/csv/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= johann@egenetics.com
+
+USE_PYTHON= yes
+
+WRKSRC= ${WRKDIR}/csv
+
+do-configure:
+ @ (cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${MAKE} -f \
+ Makefile.pre.in boot)
+
+.include <bsd.port.mk>
diff --git a/textproc/py-csv/distinfo b/textproc/py-csv/distinfo
new file mode 100644
index 000000000000..bed5ee9aec62
--- /dev/null
+++ b/textproc/py-csv/distinfo
@@ -0,0 +1 @@
+MD5 (csv-0.2.tar.gz) = 1ce3b210b1d15404c9ea0660faab4cb7
diff --git a/textproc/py-csv/pkg-comment b/textproc/py-csv/pkg-comment
new file mode 100644
index 000000000000..f830ebe912e1
--- /dev/null
+++ b/textproc/py-csv/pkg-comment
@@ -0,0 +1 @@
+A Python module to parse or write comma-separated value (CSV) files
diff --git a/textproc/py-csv/pkg-descr b/textproc/py-csv/pkg-descr
new file mode 100644
index 000000000000..6549827d097e
--- /dev/null
+++ b/textproc/py-csv/pkg-descr
@@ -0,0 +1,10 @@
+A small, fast Python extension module - written in C - to parse or write
+files in comma-separated value (CSV) format. It allows for the use of
+alternative field separator characters (besides commas).
+
+This module is only documented on its web site.
+
+Author: Dave Cole <djc@object-craft.com.au>
+WWW: http://object-craft.com.au/projects/csv/
+
+-- Johann Visagie <johann@egenetics.com>
diff --git a/textproc/py-csv/pkg-plist b/textproc/py-csv/pkg-plist
new file mode 100644
index 000000000000..03ca8bd7c33a
--- /dev/null
+++ b/textproc/py-csv/pkg-plist
@@ -0,0 +1 @@
+lib/%%PYTHON_VERSION%%/site-packages/csv.so