aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2004-07-29 22:38:12 +0800
committerskv <skv@FreeBSD.org>2004-07-29 22:38:12 +0800
commitde139928f80f8069c94ab2fbc2f9a6e123547e0a (patch)
tree2c00e740fb2381e572da0ce7ced114f833fb617b /textproc
parente5b332a3c3fca50d1e6a5b2693eeb1e7d9d4b1d7 (diff)
downloadfreebsd-ports-gnome-de139928f80f8069c94ab2fbc2f9a6e123547e0a.tar.gz
freebsd-ports-gnome-de139928f80f8069c94ab2fbc2f9a6e123547e0a.tar.zst
freebsd-ports-gnome-de139928f80f8069c94ab2fbc2f9a6e123547e0a.zip
Add tinyxml 2.3.1, small C++ XML parser.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/tinyxml/Makefile37
-rw-r--r--textproc/tinyxml/distinfo2
-rw-r--r--textproc/tinyxml/files/Makefile13
-rw-r--r--textproc/tinyxml/pkg-descr4
-rw-r--r--textproc/tinyxml/pkg-plist44
6 files changed, 101 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 55baf7d07da7..1d3fe053ace8 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -581,6 +581,7 @@
SUBDIR += tex2im
SUBDIR += texi2db
SUBDIR += texi2html
+ SUBDIR += tinyxml
SUBDIR += tkdiff
SUBDIR += tn-aspell
SUBDIR += tnef2txt
diff --git a/textproc/tinyxml/Makefile b/textproc/tinyxml/Makefile
new file mode 100644
index 000000000000..d7bb80f52c2d
--- /dev/null
+++ b/textproc/tinyxml/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: tinyxml
+# Date created: 28 July 2004
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tinyxml
+PORTVERSION= 2.3.1
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}_${PORTVERSION:S/./_/g}
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Small C++ XML parser
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+MAKE_ENV= PREFIX=${PREFIX}
+
+INSTALLS_SHLIB= YES
+SHLIB_MAJOR= 1
+PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
+
+post-patch:
+ ${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.prev
+ @${SED} -e "s=%%SHLIB_MAJOR%%=${SHLIB_MAJOR}=g" \
+ ${FILESDIR}/Makefile > ${WRKSRC}/Makefile
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing documentation for ${PKGNAME}"
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/tinyxml/distinfo b/textproc/tinyxml/distinfo
new file mode 100644
index 000000000000..a6d8a811bb56
--- /dev/null
+++ b/textproc/tinyxml/distinfo
@@ -0,0 +1,2 @@
+MD5 (tinyxml_2_3_1.tar.gz) = 1dcd6f41c0bacc8d8834c3a0bdb61434
+SIZE (tinyxml_2_3_1.tar.gz) = 120198
diff --git a/textproc/tinyxml/files/Makefile b/textproc/tinyxml/files/Makefile
new file mode 100644
index 000000000000..b83ee8231278
--- /dev/null
+++ b/textproc/tinyxml/files/Makefile
@@ -0,0 +1,13 @@
+# $FreeBSD$
+# $Id$
+
+LIB = tinyxml
+SRCS= tinystr.cpp tinyxmlerror.cpp tinyxml.cpp tinyxmlparser.cpp
+INCS= tinyxml.h tinystr.h
+
+SHLIB_MAJOR= %%SHLIB_MAJOR%%
+
+LIBDIR= ${PREFIX}/lib
+INCLUDEDIR= ${PREFIX}/include
+
+.include <bsd.lib.mk>
diff --git a/textproc/tinyxml/pkg-descr b/textproc/tinyxml/pkg-descr
new file mode 100644
index 000000000000..9db4a9a248a7
--- /dev/null
+++ b/textproc/tinyxml/pkg-descr
@@ -0,0 +1,4 @@
+TinyXml is a simple, small, C++ XML parser that can be easily
+integrating into other programs.
+
+WWW: http://sourceforge.net/projects/tinyxml/
diff --git a/textproc/tinyxml/pkg-plist b/textproc/tinyxml/pkg-plist
new file mode 100644
index 000000000000..770b2309ebd5
--- /dev/null
+++ b/textproc/tinyxml/pkg-plist
@@ -0,0 +1,44 @@
+include/tinystr.h
+include/tinyxml.h
+lib/libtinyxml.a
+lib/libtinyxml.so
+lib/libtinyxml.so.%%SHLIB_MAJOR%%
+%%PORTDOCS%%%%DOCSDIR%%/annotated.html
+%%PORTDOCS%%%%DOCSDIR%%/classTiXmlAttribute-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classTiXmlAttribute.html
+%%PORTDOCS%%%%DOCSDIR%%/classTiXmlAttribute.png
+%%PORTDOCS%%%%DOCSDIR%%/classTiXmlBase-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classTiXmlBase.html
+%%PORTDOCS%%%%DOCSDIR%%/classTiXmlBase.png
+%%PORTDOCS%%%%DOCSDIR%%/classTiXmlComment-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classTiXmlComment.html
+%%PORTDOCS%%%%DOCSDIR%%/classTiXmlComment.png
+%%PORTDOCS%%%%DOCSDIR%%/classTiXmlDeclaration-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classTiXmlDeclaration.html
+%%PORTDOCS%%%%DOCSDIR%%/classTiXmlDeclaration.png
+%%PORTDOCS%%%%DOCSDIR%%/classTiXmlDocument-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classTiXmlDocument.html
+%%PORTDOCS%%%%DOCSDIR%%/classTiXmlDocument.png
+%%PORTDOCS%%%%DOCSDIR%%/classTiXmlElement-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classTiXmlElement.html
+%%PORTDOCS%%%%DOCSDIR%%/classTiXmlElement.png
+%%PORTDOCS%%%%DOCSDIR%%/classTiXmlHandle-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classTiXmlHandle.html
+%%PORTDOCS%%%%DOCSDIR%%/classTiXmlNode-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classTiXmlNode.html
+%%PORTDOCS%%%%DOCSDIR%%/classTiXmlNode.png
+%%PORTDOCS%%%%DOCSDIR%%/classTiXmlText-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classTiXmlText.html
+%%PORTDOCS%%%%DOCSDIR%%/classTiXmlText.png
+%%PORTDOCS%%%%DOCSDIR%%/classTiXmlUnknown-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classTiXmlUnknown.html
+%%PORTDOCS%%%%DOCSDIR%%/classTiXmlUnknown.png
+%%PORTDOCS%%%%DOCSDIR%%/doxygen.css
+%%PORTDOCS%%%%DOCSDIR%%/doxygen.png
+%%PORTDOCS%%%%DOCSDIR%%/files.html
+%%PORTDOCS%%%%DOCSDIR%%/functions.html
+%%PORTDOCS%%%%DOCSDIR%%/hierarchy.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/tinystr_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/tinyxml_8h-source.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%