aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2006-07-12 04:58:42 +0800
committerrafan <rafan@FreeBSD.org>2006-07-12 04:58:42 +0800
commitf4805bf85b5dc08be20fafb9fbee33201af4d175 (patch)
treee85b4606f6f3d806b1c5692215bcd889203ae035 /textproc
parentfb0d4d03239023dc44750f3881515d7911fd5399 (diff)
downloadfreebsd-ports-gnome-f4805bf85b5dc08be20fafb9fbee33201af4d175.tar.gz
freebsd-ports-gnome-f4805bf85b5dc08be20fafb9fbee33201af4d175.tar.zst
freebsd-ports-gnome-f4805bf85b5dc08be20fafb9fbee33201af4d175.zip
You might want to know the difference between JSON and JSON::Syck.
Since JSON is a pure-perl module and JSON::Syck is based on libsyck, JSON::Syck is supposed to be very fast and memory efficient. See chansen's benchmark table at http://idisk.mac.com/christian.hansen/Public/perl/serialize.pl JSON.pm comes with dozens of ways to do the same thing and lots of options, while JSON::Syck doesn't. There's only Load and Dump. Oh, and JSON::Syck doesn't use camelCase method names :-) Author: Audrey Tang <autrijus@autrijus.org> Tatsuhiko Miyagawa <miyagawa@gmail.com> WWW: http://search.cpan.org/dist/JSON-Syck/ PR: ports/100071 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-JSON-Syck/Makefile28
-rw-r--r--textproc/p5-JSON-Syck/distinfo3
-rw-r--r--textproc/p5-JSON-Syck/pkg-descr15
-rw-r--r--textproc/p5-JSON-Syck/pkg-plist8
5 files changed, 55 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index be9fafef8a47..951c555ce4aa 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -331,6 +331,7 @@
SUBDIR += p5-Hash-Merge
SUBDIR += p5-IDNA-Punycode
SUBDIR += p5-IO-CSVHeaderFile
+ SUBDIR += p5-JSON-Syck
SUBDIR += p5-KinoSearch
SUBDIR += p5-LJ-SpellCheck
SUBDIR += p5-Lingua-Conjunction
diff --git a/textproc/p5-JSON-Syck/Makefile b/textproc/p5-JSON-Syck/Makefile
new file mode 100644
index 000000000000..562a3d49bbdc
--- /dev/null
+++ b/textproc/p5-JSON-Syck/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-JSON-Syck
+# Date created: 2006-07-11
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= JSON-Syck
+PORTVERSION= 0.07
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= JSON
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= JSON is YAML
+
+PERL_CONFIGURE= yes
+
+MAN3= JSON::Syck.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-JSON-Syck/distinfo b/textproc/p5-JSON-Syck/distinfo
new file mode 100644
index 000000000000..b4c5b7a6143c
--- /dev/null
+++ b/textproc/p5-JSON-Syck/distinfo
@@ -0,0 +1,3 @@
+MD5 (JSON-Syck-0.07.tar.gz) = b6a3d39bbec98100fc9433e41ebc773b
+SHA256 (JSON-Syck-0.07.tar.gz) = b977740056130d3d1e74a82ffaa3f48744b52dd06c69b3e300aef6cb1ad93527
+SIZE (JSON-Syck-0.07.tar.gz) = 101024
diff --git a/textproc/p5-JSON-Syck/pkg-descr b/textproc/p5-JSON-Syck/pkg-descr
new file mode 100644
index 000000000000..b208d7636bfa
--- /dev/null
+++ b/textproc/p5-JSON-Syck/pkg-descr
@@ -0,0 +1,15 @@
+You might want to know the difference between JSON and JSON::Syck.
+
+Since JSON is a pure-perl module and JSON::Syck is based on libsyck,
+JSON::Syck is supposed to be very fast and memory efficient. See
+chansen's benchmark table at
+http://idisk.mac.com/christian.hansen/Public/perl/serialize.pl
+
+JSON.pm comes with dozens of ways to do the same thing and lots of
+options, while JSON::Syck doesn't. There's only Load and Dump.
+
+Oh, and JSON::Syck doesn't use camelCase method names :-)
+
+Author: Audrey Tang <autrijus@autrijus.org>
+ Tatsuhiko Miyagawa <miyagawa@gmail.com>
+WWW: http://search.cpan.org/dist/JSON-Syck/
diff --git a/textproc/p5-JSON-Syck/pkg-plist b/textproc/p5-JSON-Syck/pkg-plist
new file mode 100644
index 000000000000..f3679e027d2a
--- /dev/null
+++ b/textproc/p5-JSON-Syck/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/JSON/Syck.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON/Syck/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON/Syck/Syck.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON/Syck/Syck.so
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON/Syck
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/JSON