aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2008-04-17 04:35:19 +0800
committerthierry <thierry@FreeBSD.org>2008-04-17 04:35:19 +0800
commitfcb67d30b46784994fb1666bb532d6de6cf539bb (patch)
treef90c20bb20a0957ddbb8631e5fc26f75fda893ee /textproc
parent17f25240b3aa3ed2189390fc440c019f8eaaf0d3 (diff)
downloadfreebsd-ports-gnome-fcb67d30b46784994fb1666bb532d6de6cf539bb.tar.gz
freebsd-ports-gnome-fcb67d30b46784994fb1666bb532d6de6cf539bb.tar.zst
freebsd-ports-gnome-fcb67d30b46784994fb1666bb532d6de6cf539bb.zip
Upgrade to 0.60.6.
List of changes from 0.60.5: * Compile fixes for Gcc 4.3. * Minor tweak to suggestion code which improved suggestion results in certain cases. * Always line buffer stdout and stderr in the Aspell utility when there is the potential for it to be used interactively through a pipe. * Removed debug output in `aspell munch-list'. * Other minor updates and bug fixes. * Enable Unicode support.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/aspell/Makefile4
-rw-r--r--textproc/aspell/distinfo6
-rw-r--r--textproc/aspell/files/patch-configure46
-rw-r--r--textproc/aspell/pkg-plist1
4 files changed, 23 insertions, 34 deletions
diff --git a/textproc/aspell/Makefile b/textproc/aspell/Makefile
index 5ab6f35af6d6..a9e4460622cf 100644
--- a/textproc/aspell/Makefile
+++ b/textproc/aspell/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= aspell
-PORTVERSION= 0.60.5
-PORTREVISION= 2
+PORTVERSION= 0.60.6
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= aspell
@@ -24,6 +23,7 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-dict-dir=${DATADIR} \
--enable-docdir=${DOCSDIR} \
+ --enable-curses=ncursesw \
--enable-static
PTHREAD_CFLAGS= # Disable threading
PTHREAD_LIBS= # libaspell may be used by unthreaded apps.
diff --git a/textproc/aspell/distinfo b/textproc/aspell/distinfo
index 869ae156d052..d4126aba9dfb 100644
--- a/textproc/aspell/distinfo
+++ b/textproc/aspell/distinfo
@@ -1,6 +1,6 @@
-MD5 (aspell-0.60.5.tar.gz) = 17fd8acac6293336bcef44391b71e337
-SHA256 (aspell-0.60.5.tar.gz) = ee9e81d2e3e66b01ad91da736e48568ed8acd6dfb6b664d904066ecc5ea4e84b
-SIZE (aspell-0.60.5.tar.gz) = 1754865
+MD5 (aspell-0.60.6.tar.gz) = bc80f0198773d5c05086522be67334eb
+SHA256 (aspell-0.60.6.tar.gz) = 4f5b1520e26cf6bbb1b5ca8a2f9f22948c3ca38ac4c2dd9e02df042fee7c0e36
+SIZE (aspell-0.60.6.tar.gz) = 1777930
MD5 (aspell6-en-6.0-0.tar.bz2) = 16449e0a266e1ecc526b2f3cd39d4bc2
SHA256 (aspell6-en-6.0-0.tar.bz2) = 24f0688711d2b893fa06c16d14d0aa3a8000e326226b839aad32611f7ace4898
SIZE (aspell6-en-6.0-0.tar.bz2) = 182442
diff --git a/textproc/aspell/files/patch-configure b/textproc/aspell/files/patch-configure
index 3b4333f295d1..01628c54baf6 100644
--- a/textproc/aspell/files/patch-configure
+++ b/textproc/aspell/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Wed Oct 19 10:36:26 2005
-+++ configure Wed Oct 19 18:13:12 2005
-@@ -2916,7 +2916,7 @@
+--- configure.orig 2008-04-07 06:31:31.000000000 +0200
++++ configure 2008-04-16 20:55:32.000000000 +0200
+@@ -3505,7 +3505,7 @@
fi
@@ -9,24 +9,10 @@
then
CXXFLAGS="$CXXFLAGS -fno-exceptions"
fi
-@@ -9975,13 +9975,6 @@
- ;;
- esac
-
-- if grep "^# ### BEGIN LIBTOOL TAG CONFIG: $tagname$" < "${ofile}" > /dev/null
-- then
-- { { echo "$as_me:$LINENO: error: tag name \"$tagname\" already exists" >&5
--echo "$as_me: error: tag name \"$tagname\" already exists" >&2;}
-- { (exit 1); exit 1; }; }
-- fi
--
- # Update the list of available tags.
- if test -n "$tagname"; then
- echo appending configuration tag \"$tagname\" to $ofile
-@@ -19872,6 +19865,10 @@
+@@ -8101,6 +8101,10 @@
# This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
+ LIBTOOL_DEPS="$ltmain"
+save_CC="$CC"
+CC="$CXX"
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
@@ -34,7 +20,7 @@
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-@@ -23160,7 +23157,7 @@
+@@ -18179,7 +18183,7 @@
CURSES_LIB=-lncurses
cat >>confdefs.h <<\_ACEOF
@@ -43,12 +29,14 @@
_ACEOF
else
-@@ -23341,7 +23338,7 @@
-
-
- cat >>confdefs.h <<\_ACEOF
--#define CURSES_HEADER <curses.h>
-+#define CURSES_HEADER <ncurses/ncurses.h>
- _ACEOF
-
-
+@@ -18366,8 +18370,8 @@
+ if test "$enable_wide_curses" != "no"
+ then
+
+- { echo "$as_me:$LINENO: checking for wide character support in curses libraray" >&5
+-echo $ECHO_N "checking for wide character support in curses libraray... $ECHO_C" >&6; }
++ { echo "$as_me:$LINENO: checking for wide character support in curses library" >&5
++echo $ECHO_N "checking for wide character support in curses library... $ECHO_C" >&6; }
+ if test -n "$have_mblen"
+ then
+ cat >conftest.$ac_ext <<_ACEOF
diff --git a/textproc/aspell/pkg-plist b/textproc/aspell/pkg-plist
index 97df058d1ca1..3d28eeca84db 100644
--- a/textproc/aspell/pkg-plist
+++ b/textproc/aspell/pkg-plist
@@ -104,6 +104,7 @@ lib/libpspell.so.16
%%NLS%%share/locale/ro/LC_MESSAGES/aspell.mo
%%NLS%%share/locale/ru/LC_MESSAGES/aspell.mo
%%NLS%%share/locale/rw/LC_MESSAGES/aspell.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/aspell.mo
%%NLS%%share/locale/sl/LC_MESSAGES/aspell.mo
%%NLS%%share/locale/sr/LC_MESSAGES/aspell.mo
%%NLS%%share/locale/sv/LC_MESSAGES/aspell.mo