aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2011-11-14 01:43:52 +0800
committercrees <crees@FreeBSD.org>2011-11-14 01:43:52 +0800
commit2daa45ebc26407a071316dc2b2d266f00832a5a4 (patch)
treecc124409c7a6dd5665ea60d46adf0a4c0f210f9f /textproc
parent6287ebef6117b7451395e357b4ba9af6562d170d (diff)
downloadfreebsd-ports-gnome-2daa45ebc26407a071316dc2b2d266f00832a5a4.tar.gz
freebsd-ports-gnome-2daa45ebc26407a071316dc2b2d266f00832a5a4.tar.zst
freebsd-ports-gnome-2daa45ebc26407a071316dc2b2d266f00832a5a4.zip
Lucene version 3.x has many new features.
Lucene 2.9.4 is based on Java 4, while the Lucene 3.x series is based on Java 5. Java 4 was deprecated recently on FreeBSD. Versions of lucene and py-lucene are meant to match and since py-lucene was updated recently to version 3.4.0 it was only natural to do this update. PR: ports/161119 Submitted by: Pedro Giffuni <giffunip@tutopia.com> Approved by: maintainer timeout (gerrit.beine@gmx.de) Feature safe: yes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/lucene/Makefile73
-rw-r--r--textproc/lucene/distinfo4
2 files changed, 35 insertions, 42 deletions
diff --git a/textproc/lucene/Makefile b/textproc/lucene/Makefile
index 0808630880ed..72efe4a9aded 100644
--- a/textproc/lucene/Makefile
+++ b/textproc/lucene/Makefile
@@ -3,12 +3,15 @@
# Whom: Gerrit Beine <gerrit.beine@gmx.de>
#
# $FreeBSD$
+#
+# Please don't forget to bump the version in py-lucene if this changes!
PORTNAME= lucene
-PORTVERSION= 2.9.4
+PORTVERSION= 3.4.0
CATEGORIES= textproc java devel
MASTER_SITES= ${MASTER_SITE_APACHE:S,%SUBDIR%,lucene/java/$(PORTVERSION),}
DISTNAME= lucene-${PORTVERSION}
+EXTRACT_SUFX= .tgz
MAINTAINER= gerrit.beine@gmx.de
COMMENT= A full-text search engine for Java
@@ -24,33 +27,27 @@ OPTIONS= DOCS "Install docs & examples" on \
PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}-core-${PORTVERSION}.jar
+.include <bsd.port.options.mk>
+
CONTRIBS= analyzers \
- ant \
benchmark \
- collation \
- bdb \
- bdb-je \
- instantiated \
+ facet \
+ grouping \
highlighter \
- lucli \
+ icu \
+ instantiated \
+ join \
memory \
misc \
queries \
queryparser \
- regex \
remote \
smartcn \
- snowball \
spatial \
spellchecker \
- surround \
- swing \
- wikipedia \
- wordnet \
+ stempel \
xml-query-parser
-.include <bsd.port.pre.mk>
-
.if defined(WITH_CONTRIB)
.for f in ${CONTRIBS}
PLIST_FILES+=%%JAVAJARDIR%%/${PORTNAME}-${f}-${PORTVERSION}.jar
@@ -59,25 +56,31 @@ PLIST_FILES+=%%JAVAJARDIR%%/${PORTNAME}-${f}-${PORTVERSION}.jar
.if defined(WITHOUT_DOCS) || !defined(WITH_DOCS)
NOPORTDOCS= yes
+NOPORTEXAMPLES= yes
.endif
-.if !defined(NOPORTDOCS)
PORTDOCS= *
-.endif
+PORTEXAMPLES= *
-DEMODIR= src/demo/org/apache/lucene/demo
+DEMODIR= contrib/demo
-do-install:
- @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}-core-${PORTVERSION}.jar ${JAVAJARDIR}
.if defined(WITH_CONTRIB)
- ${MV} ${WRKSRC}/contrib/analyzers/common/*.jar ${WRKSRC}/contrib/analyzers/
+post-extract:
+ ${MV} ${WRKSRC}/contrib/analyzers/common/* ${WRKSRC}/contrib/analyzers/
${RMDIR} ${WRKSRC}/contrib/analyzers/common
${MV} ${WRKSRC}/contrib/analyzers/smartcn/ ${WRKSRC}/contrib/
- ${MV} ${WRKSRC}/contrib/db/bdb/ ${WRKSRC}/contrib/bdb
- ${MV} ${WRKSRC}/contrib/db/bdb-je/ ${WRKSRC}/contrib/bdb-je
- ${INSTALL_DATA} \
- ${CONTRIBS:C,^(.*)$,${WRKSRC}/contrib/\1/${PORTNAME}-\1-${PORTVERSION}.jar,} \
+ ${MV} ${WRKSRC}/contrib/analyzers/stempel/ ${WRKSRC}/contrib/
+.endif
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}-core-${PORTVERSION}.jar \
+ ${JAVAJARDIR}
+.if defined(WITH_CONTRIB)
+. for f in ${CONTRIBS}
+ @${INSTALL_DATA} \
+ ${WRKSRC}/contrib/${f}/${PORTNAME}-${f}-${PORTVERSION}.jar \
${JAVAJARDIR}
+. endfor
.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@@ -85,21 +88,11 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/LICENSE.txt ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/NOTICE.txt ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
- @cd ${WRKSRC}/docs/ \
- && ${FIND} . -type d -exec ${MKDIR} ${DOCSDIR}/{} \; \
- && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
- @${MKDIR} ${EXAMPLESDIR}
- @cd ${WRKSRC}/${DEMODIR} \
- && ${FIND} . -type d -exec ${MKDIR} ${EXAMPLESDIR}/{} \; \
- && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${EXAMPLESDIR}/{} \;
+ @(cd ${WRKSRC}/docs && ${COPYTREE_SHARE} \* ${DOCSDIR})
.endif
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${FIND} -s ${WRKSRC}/${DEMODIR} -not -type d \
- | ${SED} -ne 's,^${WRKSRC}/${DEMODIR},${EXAMPLESDIR:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
- @${FIND} -s -d ${WRKSRC}/${DEMODIR} -type d \
- | ${SED} -ne 's,^${WRKSRC}/${DEMODIR},@dirrm ${EXAMPLESDIR:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/${DEMODIR} && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/lucene/distinfo b/textproc/lucene/distinfo
index 295bd9d525cb..a2642818ab65 100644
--- a/textproc/lucene/distinfo
+++ b/textproc/lucene/distinfo
@@ -1,2 +1,2 @@
-SHA256 (lucene-2.9.4.tar.gz) = e04fb2aa72e828c2f1b9a80823edfd9935915e83b19a9f9d84ebe92ab2232b00
-SIZE (lucene-2.9.4.tar.gz) = 18096066
+SHA256 (lucene-3.4.0.tgz) = 56fa8afd3b9cbce1b990aa10dd9af30aef434a06506f08814fb6b8c7c526af57
+SIZE (lucene-3.4.0.tgz) = 42933801