aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2013-10-23 00:57:44 +0800
committermat <mat@FreeBSD.org>2013-10-23 00:57:44 +0800
commit5b0861254115b1fb7a4bd36253c7b14c33eec687 (patch)
tree2ed4c76f0deb869ff88ddc33cb7fe84640602aa9 /textproc
parent2ccfacad99afb28356990ca8c04e660979242d1d (diff)
downloadfreebsd-ports-gnome-5b0861254115b1fb7a4bd36253c7b14c33eec687.tar.gz
freebsd-ports-gnome-5b0861254115b1fb7a4bd36253c7b14c33eec687.tar.zst
freebsd-ports-gnome-5b0861254115b1fb7a4bd36253c7b14c33eec687.zip
Try and be consistent with what commands are silent and not in *install.
- MKDIR is silent - ECHO is silent - INSTALL_* are not silent - CP/FIND/... are not silent I fixed a few PORTDOCS misusage, I'll do a second pass. With Hat: perl@
Diffstat (limited to 'textproc')
-rw-r--r--textproc/p5-CAM-PDF/Makefile2
-rw-r--r--textproc/p5-HTML-Tidy/Makefile2
-rw-r--r--textproc/p5-PerlPoint-Converters/Makefile2
-rw-r--r--textproc/p5-PerlPoint-Package/Makefile6
-rw-r--r--textproc/p5-RDF-Core/Makefile2
-rw-r--r--textproc/p5-SGMLSpm/Makefile4
-rw-r--r--textproc/p5-SVG/Makefile2
-rw-r--r--textproc/p5-Spreadsheet-ParseExcel/Makefile6
-rw-r--r--textproc/p5-Text-NSP/Makefile6
-rw-r--r--textproc/p5-Text-NSP/pkg-plist11
-rw-r--r--textproc/p5-WDDX/Makefile2
-rw-r--r--textproc/p5-XML-DTDParser/Makefile2
-rw-r--r--textproc/p5-XML-RSS-LibXML/Makefile2
-rw-r--r--textproc/p5-XML-Smart/Makefile2
-rw-r--r--textproc/p5-XML-TreePP/Makefile2
-rw-r--r--textproc/p5-XML-Validator-Schema/Makefile2
16 files changed, 21 insertions, 34 deletions
diff --git a/textproc/p5-CAM-PDF/Makefile b/textproc/p5-CAM-PDF/Makefile
index 7026f3f8566c..6f248bb502a3 100644
--- a/textproc/p5-CAM-PDF/Makefile
+++ b/textproc/p5-CAM-PDF/Makefile
@@ -45,7 +45,7 @@ PORTDOCS= CHANGES README
post-install:
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/textproc/p5-HTML-Tidy/Makefile b/textproc/p5-HTML-Tidy/Makefile
index aec8a073ce45..85b503899b47 100644
--- a/textproc/p5-HTML-Tidy/Makefile
+++ b/textproc/p5-HTML-Tidy/Makefile
@@ -28,7 +28,7 @@ post-patch:
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${STAGEDIR}${DOCSDIR}/
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/
cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/textproc/p5-PerlPoint-Converters/Makefile b/textproc/p5-PerlPoint-Converters/Makefile
index b6b3dd6bd6eb..3fdbf76e8e29 100644
--- a/textproc/p5-PerlPoint-Converters/Makefile
+++ b/textproc/p5-PerlPoint-Converters/Makefile
@@ -37,7 +37,7 @@ post-build:
post-install:
@${MKDIR} ${DOCSDIR}
- @cd ${WRKSRC}/doc; ${FIND} . | ${CPIO} -padm ${DOCSDIR}
+ cd ${WRKSRC}/doc; ${FIND} . | ${CPIO} -padm ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/textproc/p5-PerlPoint-Package/Makefile b/textproc/p5-PerlPoint-Package/Makefile
index a0b6533c2b32..e740ae52bc78 100644
--- a/textproc/p5-PerlPoint-Package/Makefile
+++ b/textproc/p5-PerlPoint-Package/Makefile
@@ -38,10 +38,10 @@ PORTDOCS= # suck all DOCSDIR
post-install:
@${MKDIR} ${DOCSDIR}
- @cd ${WRKSRC}/doc; ${FIND} . | ${CPIO} -padm ${DOCSDIR}
- @cd ${WRKSRC}; ${FIND} utilities | ${CPIO} -padm ${DOCSDIR}
+ cd ${WRKSRC}/doc; ${FIND} . | ${CPIO} -padm ${DOCSDIR}
+ cd ${WRKSRC}; ${FIND} utilities | ${CPIO} -padm ${DOCSDIR}
@${MKDIR} ${EXAMPLESDIR}
- @cd ${WRKSRC}/demo; ${FIND} . | ${CPIO} -padm ${EXAMPLESDIR}
+ cd ${WRKSRC}/demo; ${FIND} . | ${CPIO} -padm ${EXAMPLESDIR}
.endif
.include <bsd.port.mk>
diff --git a/textproc/p5-RDF-Core/Makefile b/textproc/p5-RDF-Core/Makefile
index 73d54c968e00..6126fb9e9d94 100644
--- a/textproc/p5-RDF-Core/Makefile
+++ b/textproc/p5-RDF-Core/Makefile
@@ -40,7 +40,7 @@ post-install:
@${ECHO_MSG} "===> Installing documentation for ${PKGNAME}"
.for DOCDIR in ${DOCSUBDIR}
@${MKDIR} ${DOCSDIR}/${DOCDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/${DOCDIR}/*.html ${DOCSDIR}/${DOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${DOCDIR}/*.html ${DOCSDIR}/${DOCDIR}
.endfor
.endif
diff --git a/textproc/p5-SGMLSpm/Makefile b/textproc/p5-SGMLSpm/Makefile
index 707bfcf101df..8049b9472612 100644
--- a/textproc/p5-SGMLSpm/Makefile
+++ b/textproc/p5-SGMLSpm/Makefile
@@ -39,10 +39,10 @@ EXTRA_PATCHES= ${PATCHDIR}/noportexamples-patch-Makefile
pre-su-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
- ${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${EXAMPLESDIR}
.endif
.include <bsd.port.mk>
diff --git a/textproc/p5-SVG/Makefile b/textproc/p5-SVG/Makefile
index a3f24c4d5264..10f2d7f53c6d 100644
--- a/textproc/p5-SVG/Makefile
+++ b/textproc/p5-SVG/Makefile
@@ -28,7 +28,7 @@ NO_STAGE= yes
post-install:
.if ${PORT_OPTIONS:MEXAMPLES}
@${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
- ${MKDIR} ${EXAMPLESDIR}/
+ @${MKDIR} ${EXAMPLESDIR}/
${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${EXAMPLESDIR}/
.endif
diff --git a/textproc/p5-Spreadsheet-ParseExcel/Makefile b/textproc/p5-Spreadsheet-ParseExcel/Makefile
index aa7d714287f0..712c0184822c 100644
--- a/textproc/p5-Spreadsheet-ParseExcel/Makefile
+++ b/textproc/p5-Spreadsheet-ParseExcel/Makefile
@@ -40,9 +40,9 @@ post-install:
.ifndef(NOPORTEXAMPLES)
@${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
@${MKDIR} ${EXAMPLESDIR}/Excel
- @${INSTALL_DATA} ${WRKSRC}/sample/README ${EXAMPLESDIR}
- @${INSTALL_SCRIPT} ${WRKSRC}/sample/*.pl ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/sample/Excel/* ${EXAMPLESDIR}/Excel
+ ${INSTALL_DATA} ${WRKSRC}/sample/README ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/sample/*.pl ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample/Excel/* ${EXAMPLESDIR}/Excel
.endif
.include <bsd.port.mk>
diff --git a/textproc/p5-Text-NSP/Makefile b/textproc/p5-Text-NSP/Makefile
index 71b6071d23b7..b7b038b51d33 100644
--- a/textproc/p5-Text-NSP/Makefile
+++ b/textproc/p5-Text-NSP/Makefile
@@ -56,16 +56,14 @@ MAN3= Text::NSP.3 \
Text::NSP::Measures::4D::MI.3 \
Text::NSP::Measures::4D::MI::ll.3
-DOCS= CHANGES README doc/FAQ.pod doc/NSP-Class-diagram.pdf \
+PORTDOCS= CHANGES README doc/FAQ.pod doc/NSP-Class-diagram.pdf \
doc/NSP-Class-diagram.png doc/README.pod doc/TODO.pod \
doc/USAGE.pod doc/cicling2003.pdf doc/cicling2003.ps \
.ifndef (NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
-.for FILE in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
-.endfor
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
@${ECHO_MSG} "===> Installing documentation in ${DOCSDIR}"
.endif
diff --git a/textproc/p5-Text-NSP/pkg-plist b/textproc/p5-Text-NSP/pkg-plist
index 5cad98a60b84..7b1b69365b4c 100644
--- a/textproc/p5-Text-NSP/pkg-plist
+++ b/textproc/p5-Text-NSP/pkg-plist
@@ -47,17 +47,6 @@ bin/statistic.pl
%%SITE_PERL%%/Text/NSP/Measures/4D/MI.pm
%%SITE_PERL%%/Text/NSP/Measures/4D/MI/ll.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/NSP/.packlist
-%%PORTDOCS%%%%DOCSDIR%%/CHANGES
-%%PORTDOCS%%%%DOCSDIR%%/FAQ.pod
-%%PORTDOCS%%%%DOCSDIR%%/NSP-Class-diagram.pdf
-%%PORTDOCS%%%%DOCSDIR%%/NSP-Class-diagram.png
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/README.pod
-%%PORTDOCS%%%%DOCSDIR%%/TODO.pod
-%%PORTDOCS%%%%DOCSDIR%%/USAGE.pod
-%%PORTDOCS%%%%DOCSDIR%%/cicling2003.pdf
-%%PORTDOCS%%%%DOCSDIR%%/cicling2003.ps
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/NSP
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text
@dirrm %%SITE_PERL%%/Text/NSP/Measures/4D/MI
diff --git a/textproc/p5-WDDX/Makefile b/textproc/p5-WDDX/Makefile
index b0b4258db0bd..18374dabbf3a 100644
--- a/textproc/p5-WDDX/Makefile
+++ b/textproc/p5-WDDX/Makefile
@@ -23,7 +23,7 @@ MAN3= WDDX.3
NO_STAGE= yes
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/Changes ${DOCSDIR}
.endif
diff --git a/textproc/p5-XML-DTDParser/Makefile b/textproc/p5-XML-DTDParser/Makefile
index 7fef35763a9d..59c61fc00a60 100644
--- a/textproc/p5-XML-DTDParser/Makefile
+++ b/textproc/p5-XML-DTDParser/Makefile
@@ -21,7 +21,7 @@ PORTDOCS= Changes
post-install:
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/textproc/p5-XML-RSS-LibXML/Makefile b/textproc/p5-XML-RSS-LibXML/Makefile
index 4d3aa0bdaf4c..f1d8ab50913a 100644
--- a/textproc/p5-XML-RSS-LibXML/Makefile
+++ b/textproc/p5-XML-RSS-LibXML/Makefile
@@ -33,7 +33,7 @@ MAN3= XML::RSS::LibXML.3 \
NO_STAGE= yes
post-install:
.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${EXAMPLESDIR}/
+ @${MKDIR} ${EXAMPLESDIR}/
${INSTALL_SCRIPT} ${WRKSRC}/tools/benchmark.pl ${EXAMPLESDIR}/
.endif
diff --git a/textproc/p5-XML-Smart/Makefile b/textproc/p5-XML-Smart/Makefile
index 58f36497c849..30633469b5c2 100644
--- a/textproc/p5-XML-Smart/Makefile
+++ b/textproc/p5-XML-Smart/Makefile
@@ -30,7 +30,7 @@ PORTDOCS= Changes README
post-install:
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/textproc/p5-XML-TreePP/Makefile b/textproc/p5-XML-TreePP/Makefile
index 85066c098067..a43984c18649 100644
--- a/textproc/p5-XML-TreePP/Makefile
+++ b/textproc/p5-XML-TreePP/Makefile
@@ -17,7 +17,7 @@ MAN3= XML::TreePP.3
NO_STAGE= yes
post-install:
- ${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${EXAMPLESDIR}
${INSTALL_SCRIPT} ${WRKSRC}/example/envxml.cgi ${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/textproc/p5-XML-Validator-Schema/Makefile b/textproc/p5-XML-Validator-Schema/Makefile
index 4d3e0e56bba9..9b7fa1bbac9d 100644
--- a/textproc/p5-XML-Validator-Schema/Makefile
+++ b/textproc/p5-XML-Validator-Schema/Makefile
@@ -43,7 +43,7 @@ PORTDOCS= ANNOUNCE Changes README TODO
post-install:
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif