aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-11-30 06:09:32 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-11-30 06:09:32 +0800
commit5e751d3303828881e3ae453520ed0b96f87d82ea (patch)
treeb5728cc4b106fbc5bef748afadbd7575ffcf50ce /textproc
parent571e6f8f3c0216215d0289fdb6cbd8806ed07e55 (diff)
downloadfreebsd-ports-gnome-5e751d3303828881e3ae453520ed0b96f87d82ea.tar.gz
freebsd-ports-gnome-5e751d3303828881e3ae453520ed0b96f87d82ea.tar.zst
freebsd-ports-gnome-5e751d3303828881e3ae453520ed0b96f87d82ea.zip
- Update to 8.6.9
- Use REINPLACE_CMD instead of patch files Changes: http://www.methods.co.nz/asciidoc/CHANGELOG.html
Diffstat (limited to 'textproc')
-rw-r--r--textproc/asciidoc/Makefile37
-rw-r--r--textproc/asciidoc/distinfo4
-rw-r--r--textproc/asciidoc/files/patch-Makefile.in76
-rw-r--r--textproc/asciidoc/files/patch-asciidoc.py8
-rw-r--r--textproc/asciidoc/pkg-plist13
5 files changed, 24 insertions, 114 deletions
diff --git a/textproc/asciidoc/Makefile b/textproc/asciidoc/Makefile
index 8a2f3c4701f7..b0f2761973fe 100644
--- a/textproc/asciidoc/Makefile
+++ b/textproc/asciidoc/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= asciidoc
-PORTVERSION= 8.6.8
-PORTREVISION= 1
+PORTVERSION= 8.6.9
CATEGORIES= textproc
MASTER_SITES= SF
@@ -18,48 +17,38 @@ RUN_DEPENDS= python2:${PORTSDIR}/lang/python2
OPTIONS_DEFINE= VIM
OPTIONS_DEFAULT=VIM
OPTIONS_SUB= yes
-VIM_DESC= Install Vim ftdetect & syntax files
+VIM_DESC= Install Vim syntax file
GNU_CONFIGURE= yes
USE_PYTHON= -2.7
USES= gmake
-CONF_FILES= asciidoc.conf docbook45.conf \
- filters/code/code-filter.conf \
+CONF_FILES= asciidoc.conf docbook45.conf filters/code/code-filter.conf \
filters/graphviz/graphviz-filter.conf \
filters/latex/latex-filter.conf \
filters/music/music-filter.conf \
- filters/source/source-highlight-filter.conf \
- help.conf html4.conf html5.conf \
- lang-de.conf lang-el.conf lang-en.conf lang-es.conf \
- lang-fr.conf lang-hu.conf lang-it.conf lang-nl.conf \
- lang-pt-BR.conf lang-ru.conf lang-uk.conf \
- latex.conf slidy.conf text.conf wordpress.conf \
+ filters/source/source-highlight-filter.conf help.conf \
+ html4.conf html5.conf lang-cs.conf lang-de.conf lang-el.conf \
+ lang-en.conf lang-es.conf lang-fr.conf lang-hu.conf \
+ lang-it.conf lang-nl.conf lang-pt-BR.conf lang-ro.conf \
+ lang-ru.conf lang-uk.conf latex.conf slidy.conf text.conf \
xhtml11.conf xhtml11-quirks.conf
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MVIM}
-MAKE_ENV+= vimdir=${PREFIX}/share/vim/${VIM_DATADIR}
PLIST_SUB+= VIM_DATADIR=${VIM_DATADIR}
-VIM__DATADIR!= ${MAKE} -C ../../editors/vim/ -V _DATADIR
+VIM_DATADIR!= ${MAKE} -C ../../editors/vim/ -V _DATADIR
.else
PLIST_SUB+= VIM_DATADIR=""
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|${SETENV} python|&2|' ${WRKSRC}/a2x.py
+ @${REINPLACE_CMD} -e '/^INSTALL_PROG/ s|INSTALL_PROGRAM|INSTALL_SCRIPT|; s|\.conf|&.sample|' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|${SETENV} python|&2|' ${WRKSRC}/a2x.py ${WRKSRC}/asciidoc.py
.for conf_file in ${CONF_FILES}
@cd ${WRKSRC}/ && ${MV} ${conf_file} ${conf_file}.sample
.endfor
-.if ${PORT_OPTIONS:MVIM}
- @${REINPLACE_CMD} -e '/^vimdir = /d' ${WRKSRC}/Makefile.in
-.endif
-
-pre-install:
-.if ${PORT_OPTIONS:MVIM}
- @${MKDIR} ${STAGEDIR}${PREFIX}/share/vim/${VIM_DATADIR}/
-.endif
post-install:
.for conf_file in ${CONF_FILES}
@@ -67,5 +56,9 @@ post-install:
${CP} -p ${STAGEDIR}${ETCDIR}/${conf_file}.sample ${STAGEDIR}${ETCDIR}/${conf_file}; \
fi
.endfor
+.if ${PORT_OPTIONS:MVIM}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/vim/${VIM_DATADIR}/syntax/
+ ${INSTALL_DATA} ${WRKSRC}/vim/syntax/asciidoc.vim ${STAGEDIR}${PREFIX}/share/vim/${VIM_DATADIR}/syntax/
+.endif
.include <bsd.port.mk>
diff --git a/textproc/asciidoc/distinfo b/textproc/asciidoc/distinfo
index 20f1dc1ce156..c5f1a001d180 100644
--- a/textproc/asciidoc/distinfo
+++ b/textproc/asciidoc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (asciidoc-8.6.8.tar.gz) = ffb67f59dccaf6f15db72fcd04fdf21a2f9b703d31f94fcd0c49a424a9fcfbc4
-SIZE (asciidoc-8.6.8.tar.gz) = 900422
+SHA256 (asciidoc-8.6.9.tar.gz) = 78db9d0567c8ab6570a6eff7ffdf84eadd91f2dfc0a92a2d0105d323cab4e1f0
+SIZE (asciidoc-8.6.9.tar.gz) = 907253
diff --git a/textproc/asciidoc/files/patch-Makefile.in b/textproc/asciidoc/files/patch-Makefile.in
deleted file mode 100644
index a200634319c7..000000000000
--- a/textproc/asciidoc/files/patch-Makefile.in
+++ /dev/null
@@ -1,76 +0,0 @@
---- Makefile.in.orig 2011-05-31 05:54:30.000000000 +0900
-+++ Makefile.in 2012-08-18 21:30:48.000000000 +0900
-@@ -5,7 +5,7 @@
- .NOTPARALLEL:
-
- INSTALL = @INSTALL@
--INSTALL_PROG = @INSTALL_PROGRAM@
-+INSTALL_PROG = @INSTALL_SCRIPT@
- INSTALL_DATA = @INSTALL_DATA@
- PACKAGE_TARNAME = @PACKAGE_TARNAME@
- SED = @SED@
-@@ -27,37 +27,37 @@
- prog = asciidoc.py a2x.py
- progdir = $(bindir)
-
--vimdir = @sysconfdir@/vim
-+vimdir = @datadir@/vim/vimfiles
-
- manp = $(patsubst %1.txt,%1,$(wildcard doc/*.1.txt))
- manpdir = $(mandir)/man1
-
--conf = $(wildcard *.conf)
-+conf = $(wildcard *.conf.sample)
- confdir = $(ASCIIDOCCONF)
-
- filtersdir = $(ASCIIDOCCONF)/filters
-
- codefilter = filters/code/code-filter.py
- codefilterdir = $(filtersdir)/code
--codefilterconf = filters/code/code-filter.conf
-+codefilterconf = filters/code/code-filter.conf.sample
- codefilterconfdir = $(filtersdir)/code
-
- graphvizfilter = filters/graphviz/graphviz2png.py
- graphvizfilterdir = $(filtersdir)/graphviz
--graphvizfilterconf = filters/graphviz/graphviz-filter.conf
-+graphvizfilterconf = filters/graphviz/graphviz-filter.conf.sample
- graphvizfilterconfdir = $(filtersdir)/graphviz
-
- musicfilter = filters/music/music2png.py
- musicfilterdir = $(filtersdir)/music
--musicfilterconf = filters/music/music-filter.conf
-+musicfilterconf = filters/music/music-filter.conf.sample
- musicfilterconfdir = $(filtersdir)/music
-
--sourcefilterconf = filters/source/source-highlight-filter.conf
-+sourcefilterconf = filters/source/source-highlight-filter.conf.sample
- sourcefilterconfdir = $(filtersdir)/source
-
- latexfilter = filters/latex/latex2png.py
- latexfilterdir = $(filtersdir)/latex
--latexfilterconf = filters/latex/latex-filter.conf
-+latexfilterconf = filters/latex/latex-filter.conf.sample
- latexfilterconfdir = $(filtersdir)/latex
-
- themesdir = $(ASCIIDOCCONF)/themes
-@@ -145,8 +145,7 @@
- done
-
- install-vim:
-- @for d in $(DESTDIR)/$(vimdir) /etc/vim; do \
-- if ! test -d $$d; then continue; fi ; \
-+ @for d in $(DESTDIR)/$(vimdir); do \
- echo "installing Vim files in $$d" ; \
- $(INSTALL) -d $$d/syntax ; \
- $(INSTALL_DATA) vim/syntax/asciidoc.vim $$d/syntax ; \
-@@ -155,8 +154,7 @@
- done
-
- uninstall-vim:
-- @for d in $(DESTDIR)/$(vimdir) /etc/vim; do \
-- if ! test -d $$d; then continue; fi ; \
-+ @for d in $(DESTDIR)/$(vimdir); do \
- echo "uninstalling Vim files in $$d" ; \
- rm -f $$d/syntax/asciidoc.vim ; \
- rm -f $$d/ftdetect/asciidoc_filetype.vim ; \
diff --git a/textproc/asciidoc/files/patch-asciidoc.py b/textproc/asciidoc/files/patch-asciidoc.py
deleted file mode 100644
index c7c627aa8f41..000000000000
--- a/textproc/asciidoc/files/patch-asciidoc.py
+++ /dev/null
@@ -1,8 +0,0 @@
---- ./asciidoc.py.orig 2013-05-20 13:25:45.362337047 +0200
-+++ ./asciidoc.py 2013-05-20 13:25:55.524336439 +0200
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python2
- """
- asciidoc - converts an AsciiDoc text file to HTML or DocBook
-
diff --git a/textproc/asciidoc/pkg-plist b/textproc/asciidoc/pkg-plist
index f9c7e13c769c..a2375f885e88 100644
--- a/textproc/asciidoc/pkg-plist
+++ b/textproc/asciidoc/pkg-plist
@@ -77,6 +77,9 @@ bin/asciidoc.py
%%ETCDIR%%/javascripts/asciidoc.js
%%ETCDIR%%/javascripts/slidy.js
%%ETCDIR%%/javascripts/toc.js
+@unexec if cmp -s %D/%%ETCDIR%%/lang-cs.conf.sample %D/%%ETCDIR%%/lang-cs.conf; then rm -f %D/%%ETCDIR%%/lang-cs.conf; fi
+%%ETCDIR%%/lang-cs.conf.sample
+@exec if [ ! -f %D/%%ETCDIR%%/lang-cs.conf ]; then cp -p %D/%F %B/lang-cs.conf; fi
@unexec if cmp -s %D/%%ETCDIR%%/lang-de.conf.sample %D/%%ETCDIR%%/lang-de.conf; then rm -f %D/%%ETCDIR%%/lang-de.conf; fi
%%ETCDIR%%/lang-de.conf.sample
@exec if [ ! -f %D/%%ETCDIR%%/lang-de.conf ]; then cp -p %D/%F %B/lang-de.conf; fi
@@ -104,6 +107,9 @@ bin/asciidoc.py
@unexec if cmp -s %D/%%ETCDIR%%/lang-pt-BR.conf.sample %D/%%ETCDIR%%/lang-pt-BR.conf; then rm -f %D/%%ETCDIR%%/lang-pt-BR.conf; fi
%%ETCDIR%%/lang-pt-BR.conf.sample
@exec if [ ! -f %D/%%ETCDIR%%/lang-pt-BR.conf ]; then cp -p %D/%F %B/lang-pt-BR.conf; fi
+@unexec if cmp -s %D/%%ETCDIR%%/lang-ro.conf.sample %D/%%ETCDIR%%/lang-ro.conf; then rm -f %D/%%ETCDIR%%/lang-ro.conf; fi
+%%ETCDIR%%/lang-ro.conf.sample
+@exec if [ ! -f %D/%%ETCDIR%%/lang-ro.conf ]; then cp -p %D/%F %B/lang-ro.conf; fi
@unexec if cmp -s %D/%%ETCDIR%%/lang-ru.conf.sample %D/%%ETCDIR%%/lang-ru.conf; then rm -f %D/%%ETCDIR%%/lang-ru.conf; fi
%%ETCDIR%%/lang-ru.conf.sample
@exec if [ ! -f %D/%%ETCDIR%%/lang-ru.conf ]; then cp -p %D/%F %B/lang-ru.conf; fi
@@ -127,9 +133,6 @@ bin/asciidoc.py
@exec if [ ! -f %D/%%ETCDIR%%/text.conf ]; then cp -p %D/%F %B/text.conf; fi
%%ETCDIR%%/themes/flask/flask.css
%%ETCDIR%%/themes/volnitsky/volnitsky.css
-@unexec if cmp -s %D/%%ETCDIR%%/wordpress.conf.sample %D/%%ETCDIR%%/wordpress.conf; then rm -f %D/%%ETCDIR%%/wordpress.conf; fi
-%%ETCDIR%%/wordpress.conf.sample
-@exec if [ ! -f %D/%%ETCDIR%%/wordpress.conf ]; then cp -p %D/%F %B/wordpress.conf; fi
@unexec if cmp -s %D/%%ETCDIR%%/xhtml11.conf.sample %D/%%ETCDIR%%/xhtml11.conf; then rm -f %D/%%ETCDIR%%/xhtml11.conf; fi
%%ETCDIR%%/xhtml11.conf.sample
@exec if [ ! -f %D/%%ETCDIR%%/xhtml11.conf ]; then cp -p %D/%F %B/xhtml11.conf; fi
@@ -138,10 +141,8 @@ bin/asciidoc.py
@exec if [ ! -f %D/%%ETCDIR%%/xhtml11-quirks.conf ]; then cp -p %D/%F %B/xhtml11-quirks.conf; fi
man/man1/a2x.1.gz
man/man1/asciidoc.1.gz
-%%VIM%%%%VIM_DATADIR%%share/vim/ftdetect/asciidoc_filetype.vim
-%%VIM%%%%VIM_DATADIR%%share/vim/syntax/asciidoc.vim
+%%VIM%%share/vim/%%VIM_DATADIR%%/syntax/asciidoc.vim
%%VIM%%@dirrmtry share/vim/%%VIM_DATADIR%%/syntax
-%%VIM%%@dirrmtry share/vim/%%VIM_DATADIR%%/ftdetect
%%VIM%%@dirrmtry share/vim/%%VIM_DATADIR%%
%%VIM%%@dirrmtry share/vim
@dirrm %%ETCDIR%%/themes/volnitsky