aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2002-05-27 16:52:26 +0800
committerskv <skv@FreeBSD.org>2002-05-27 16:52:26 +0800
commit7100a596906699ab85128eb27fe91f078bb9a075 (patch)
treebd8c9d77192baf011789e3b3c903acf642772c15 /textproc
parenta9591337921b8e13e4f6002ec03a43fc887ceb04 (diff)
downloadfreebsd-ports-gnome-7100a596906699ab85128eb27fe91f078bb9a075.tar.gz
freebsd-ports-gnome-7100a596906699ab85128eb27fe91f078bb9a075.tar.zst
freebsd-ports-gnome-7100a596906699ab85128eb27fe91f078bb9a075.zip
Add p5-XML-Filter-XInclude 1.0, xInclude as a SAX Filter.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-XML-Filter-XInclude/Makefile26
-rw-r--r--textproc/p5-XML-Filter-XInclude/distinfo1
-rw-r--r--textproc/p5-XML-Filter-XInclude/pkg-comment1
-rw-r--r--textproc/p5-XML-Filter-XInclude/pkg-descr8
-rw-r--r--textproc/p5-XML-Filter-XInclude/pkg-plist7
6 files changed, 44 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index e73488819352..c0bec1683fcb 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -189,6 +189,7 @@
SUBDIR += p5-XML-Filter-BufferText
SUBDIR += p5-XML-Filter-DetectWS
SUBDIR += p5-XML-Filter-SAXT
+ SUBDIR += p5-XML-Filter-XInclude
SUBDIR += p5-XML-Filter-XSLT
SUBDIR += p5-XML-Generator-DBI
SUBDIR += p5-XML-Handler-Trees
diff --git a/textproc/p5-XML-Filter-XInclude/Makefile b/textproc/p5-XML-Filter-XInclude/Makefile
new file mode 100644
index 000000000000..5ae945c716a8
--- /dev/null
+++ b/textproc/p5-XML-Filter-XInclude/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: XML::Filter::XInclude
+# Date created: 28 Jan 2002
+# Whom: Sergey Skvortsov <skv@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Filter-XInclude
+PORTVERSION= 1.0
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/XML/SAX.pm:${PORTSDIR}/textproc/p5-XML-SAX
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::Filter::XInclude.3
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-Filter-XInclude/distinfo b/textproc/p5-XML-Filter-XInclude/distinfo
new file mode 100644
index 000000000000..e4d496782004
--- /dev/null
+++ b/textproc/p5-XML-Filter-XInclude/distinfo
@@ -0,0 +1 @@
+MD5 (XML-Filter-XInclude-1.0.tar.gz) = 6fd41f32027f3dbf6993fcef0ee81578
diff --git a/textproc/p5-XML-Filter-XInclude/pkg-comment b/textproc/p5-XML-Filter-XInclude/pkg-comment
new file mode 100644
index 000000000000..98d1a629e342
--- /dev/null
+++ b/textproc/p5-XML-Filter-XInclude/pkg-comment
@@ -0,0 +1 @@
+XInclude as a SAX Filter
diff --git a/textproc/p5-XML-Filter-XInclude/pkg-descr b/textproc/p5-XML-Filter-XInclude/pkg-descr
new file mode 100644
index 000000000000..fa5dc8590a1c
--- /dev/null
+++ b/textproc/p5-XML-Filter-XInclude/pkg-descr
@@ -0,0 +1,8 @@
+This module implements a simple SAX filter that provides XInclude
+support. It does NOT support XPointer.
+
+WWW: http://search.cpan.org/search?dist=XML-Filter-XInclude
+WWW: http://www.w3.org/TR/XInclude
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/textproc/p5-XML-Filter-XInclude/pkg-plist b/textproc/p5-XML-Filter-XInclude/pkg-plist
new file mode 100644
index 000000000000..afd4341d188c
--- /dev/null
+++ b/textproc/p5-XML-Filter-XInclude/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/Filter/XInclude/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/XML/Filter/XInclude.pm
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/XML/Filter 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/XML 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/Filter/XInclude
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/Filter 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML 2>/dev/null || true