aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2005-10-09 21:00:35 +0800
committerehaupt <ehaupt@FreeBSD.org>2005-10-09 21:00:35 +0800
commit84d57c7bbc6f6442a308e01fc48e544529c91cde (patch)
tree54daf9767653bbd33c9338bfde7e58bc5a7443b3 /textproc
parent021744413dc19d18e95f133cab9559f70ad45c5d (diff)
downloadfreebsd-ports-gnome-84d57c7bbc6f6442a308e01fc48e544529c91cde.tar.gz
freebsd-ports-gnome-84d57c7bbc6f6442a308e01fc48e544529c91cde.tar.zst
freebsd-ports-gnome-84d57c7bbc6f6442a308e01fc48e544529c91cde.zip
Adding p5-Text-Chomp, a module implementing a portable chomp.
PR: 87132 Submitted by: Jason Burgess <dev@fenux.net> Approved by: novel (mentor)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Text-Chomp/Makefile29
-rw-r--r--textproc/p5-Text-Chomp/distinfo2
-rw-r--r--textproc/p5-Text-Chomp/pkg-descr7
-rw-r--r--textproc/p5-Text-Chomp/pkg-plist5
5 files changed, 44 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index e895c8c47ab3..af199d034cf9 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -391,6 +391,7 @@
SUBDIR += p5-Text-Bind
SUBDIR += p5-Text-CSV
SUBDIR += p5-Text-CSV_XS
+ SUBDIR += p5-Text-Chomp
SUBDIR += p5-Text-Diff
SUBDIR += p5-Text-Diff-HTML
SUBDIR += p5-Text-DoubleMetaphone
diff --git a/textproc/p5-Text-Chomp/Makefile b/textproc/p5-Text-Chomp/Makefile
new file mode 100644
index 000000000000..4f882adeeca4
--- /dev/null
+++ b/textproc/p5-Text-Chomp/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Text-Chomp
+# Date created: 08 Oct 2005
+# Whom: Jason Burgess <dev@fenux.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-Chomp
+PORTVERSION= 0.02
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dev@fenux.net
+COMMENT= A module implementing a portable chomp
+
+PERL_CONFIGURE= yes
+USE_REINPLACE= yes
+
+MAN3= Text::Chomp.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500806
+IGNORE= needs Perl 5.8.6 or above (lang/perl5.8)
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Text-Chomp/distinfo b/textproc/p5-Text-Chomp/distinfo
new file mode 100644
index 000000000000..92144f3020ef
--- /dev/null
+++ b/textproc/p5-Text-Chomp/distinfo
@@ -0,0 +1,2 @@
+MD5 (Text-Chomp-0.02.tar.gz) = 4e0c9d3faa4653a8d43ffeb29968f0d7
+SIZE (Text-Chomp-0.02.tar.gz) = 2747
diff --git a/textproc/p5-Text-Chomp/pkg-descr b/textproc/p5-Text-Chomp/pkg-descr
new file mode 100644
index 000000000000..eccd46997172
--- /dev/null
+++ b/textproc/p5-Text-Chomp/pkg-descr
@@ -0,0 +1,7 @@
+This module implements a single function, tchomp, which will remove all known
+line separators.
+
+The regular chomp() works only on the value in $/, which can be difficult if
+working in multi-platform environments.
+
+WWW: http://search.cpan.org/dist/Text-Chomp/
diff --git a/textproc/p5-Text-Chomp/pkg-plist b/textproc/p5-Text-Chomp/pkg-plist
new file mode 100644
index 000000000000..fa47e1a0a37d
--- /dev/null
+++ b/textproc/p5-Text-Chomp/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Text/Chomp.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Chomp/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Chomp
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Text 2>/dev/null || true