aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-03-04 20:09:33 +0800
committerijliao <ijliao@FreeBSD.org>2001-03-04 20:09:33 +0800
commitc5f3706d07469195edcc19dcb1a44f90dec1e2b4 (patch)
tree1a7e26621d739a331a533b8e5d241443fc0da1e0 /textproc
parente400e013090b83a0387e3dd153886947815f4f4e (diff)
downloadfreebsd-ports-gnome-c5f3706d07469195edcc19dcb1a44f90dec1e2b4.tar.gz
freebsd-ports-gnome-c5f3706d07469195edcc19dcb1a44f90dec1e2b4.tar.zst
freebsd-ports-gnome-c5f3706d07469195edcc19dcb1a44f90dec1e2b4.zip
add perltidy
Indents and reformats Perl scripts to make them easier to read
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/perltidy/Makefile35
-rw-r--r--textproc/perltidy/distinfo1
-rw-r--r--textproc/perltidy/files/patch-Makefile20
-rw-r--r--textproc/perltidy/pkg-comment1
-rw-r--r--textproc/perltidy/pkg-descr5
-rw-r--r--textproc/perltidy/pkg-plist8
7 files changed, 71 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 678860ecd432..44609127136a 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -114,6 +114,7 @@
SUBDIR += p5-dTemplate
SUBDIR += par
SUBDIR += perl2html
+ SUBDIR += perltidy
SUBDIR += pspell
SUBDIR += pspell-ispell
SUBDIR += py-HyperText
diff --git a/textproc/perltidy/Makefile b/textproc/perltidy/Makefile
new file mode 100644
index 000000000000..00280c9f5a97
--- /dev/null
+++ b/textproc/perltidy/Makefile
@@ -0,0 +1,35 @@
+# ex:ts=8
+# New ports collection makefile for: perltidy
+# Date created: Mar 4, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= perltidy
+PORTVERSION= 20010304
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ijliao@FreeBSD.org
+
+USE_PERL5= yes
+NO_BUILD= yes
+
+MAN1= perltidy.1
+
+post-patch:
+ @${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g ; \
+ s|%%MANPREFIX%%|${MANPREFIX}|g" ${WRKSRC}/Makefile
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/perltidy
+.for ext in html pod txt
+ ${CP} ${WRKSRC}/docs/*.${ext} ${PREFIX}/share/doc/perltidy/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/perltidy/distinfo b/textproc/perltidy/distinfo
new file mode 100644
index 000000000000..ec684662e7c3
--- /dev/null
+++ b/textproc/perltidy/distinfo
@@ -0,0 +1 @@
+MD5 (perltidy-20010304.tgz) = 047e74dfba19bbd44c2792e7625e34ac
diff --git a/textproc/perltidy/files/patch-Makefile b/textproc/perltidy/files/patch-Makefile
new file mode 100644
index 000000000000..104a9f41a0ef
--- /dev/null
+++ b/textproc/perltidy/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig Sun Mar 4 19:47:45 2001
++++ Makefile Sun Mar 4 19:49:36 2001
+@@ -2,7 +2,7 @@
+
+ # Step 1: edit BINDIR to reflect where you want to put perltidy
+ # This is fairly standard:
+-BINDIR = /usr/local/bin
++BINDIR = %%PREFIX%%/bin
+
+ # Step 2: edit MANDIR to reflect where you want to put the man page, perltidy.1
+ # or comment out MANDIR to skip installing a man page.
+@@ -10,7 +10,7 @@
+ # Hint: if directory usr/local/man/man1 does not exist,
+ # you might find the man path by entering the command
+ # perl '-V:install.*' and looking for the value of 'installman1dir'
+-MANDIR = /usr/local/man/man1
++MANDIR = %%MANPREFIX%%/man/man1
+
+ # Step 3: Then become superuser (if necessary) and issue the command
+ # make install
diff --git a/textproc/perltidy/pkg-comment b/textproc/perltidy/pkg-comment
new file mode 100644
index 000000000000..51fb2971081b
--- /dev/null
+++ b/textproc/perltidy/pkg-comment
@@ -0,0 +1 @@
+Indents and reformats Perl scripts to make them easier to read
diff --git a/textproc/perltidy/pkg-descr b/textproc/perltidy/pkg-descr
new file mode 100644
index 000000000000..1ee44ff02b86
--- /dev/null
+++ b/textproc/perltidy/pkg-descr
@@ -0,0 +1,5 @@
+Perltidy reads a Perl script and writes an indented, reformatted
+script. The default formatting closely follows the recommendations
+in perlstyle(1).
+
+WWW: http://perltidy.sourceforge.net/
diff --git a/textproc/perltidy/pkg-plist b/textproc/perltidy/pkg-plist
new file mode 100644
index 000000000000..b7618d3a03e7
--- /dev/null
+++ b/textproc/perltidy/pkg-plist
@@ -0,0 +1,8 @@
+bin/perltidy
+%%PORTDOCS%%share/doc/perltidy/perltidy.html
+%%PORTDOCS%%share/doc/perltidy/perltidy.pod
+%%PORTDOCS%%share/doc/perltidy/perltidy.txt
+%%PORTDOCS%%share/doc/perltidy/tutorial.html
+%%PORTDOCS%%share/doc/perltidy/tutorial.pod
+%%PORTDOCS%%share/doc/perltidy/tutorial.txt
+%%PORTDOCS%%@dirrm share/doc/perltidy