aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2008-08-21 14:18:49 +0800
committerrafan <rafan@FreeBSD.org>2008-08-21 14:18:49 +0800
commitc8007265d81e778bec43e1f7b073b196887b3604 (patch)
treea30fd3dc7b50670b88ce6f8cf28e0ccf2b1e599a /textproc
parent9f3176cd391ec72812d7f37e93b881faa3648b45 (diff)
downloadfreebsd-ports-gnome-c8007265d81e778bec43e1f7b073b196887b3604.tar.gz
freebsd-ports-gnome-c8007265d81e778bec43e1f7b073b196887b3604.tar.zst
freebsd-ports-gnome-c8007265d81e778bec43e1f7b073b196887b3604.zip
Update CONFIGURE_ARGS for how we pass CONFIGURE_TARGET to configure script.
Specifically, newer autoconf (> 2.13) has different semantic of the configure target. In short, one should use --build=CONFIGURE_TARGET instead of CONFIGURE_TARGET directly. Otherwise, you will get a warning and the old semantic may be removed in later autoconf releases. To workaround this issue, many ports hack the CONFIGURE_TARGET variable so that it contains the ``--build='' prefix. To solve this issue, under the fact that some ports still have configure script generated by the old autoconf, we use runtime detection in the do-configure target so that the proper argument can be used. Changes to Mk/*: - Add runtime detection magic in bsd.port.mk - Remove CONFIGURE_TARGET hack in various bsd.*.mk - USE_GNOME=gnometarget is now an no-op Changes to individual ports, other than removing the CONFIGURE_TARGET hack: = pkg-plist changed (due to the ugly CONFIGURE_TARGET prefix in * executables) - comms/gnuradio - science/abinit - science/elmer-fem - science/elmer-matc - science/elmer-meshgen2d - science/elmerfront - science/elmerpost = use x86_64 as ARCH - devel/g-wrap = other changes - print/magicfilter GNU_CONFIGURE -> HAS_CONFIGURE since it's not generated by autoconf Total # of ports modified: 1,027 Total # of ports affected: ~7,000 (set GNU_CONFIGURE to yes) PR: 126524 (obsoletes 52917) Submitted by: rafan Tested on: two pointyhat 7-amd64 exp runs (by pav) Approved by: portmgr (pav)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/aft/Makefile1
-rw-r--r--textproc/aspell/Makefile1
-rw-r--r--textproc/dbacl/Makefile1
-rw-r--r--textproc/dictfmt/Makefile1
-rw-r--r--textproc/expat2/Makefile1
-rw-r--r--textproc/filepp/Makefile1
-rw-r--r--textproc/gmetadom/Makefile1
-rw-r--r--textproc/gsed/Makefile1
-rw-r--r--textproc/hyperestraier/Makefile1
-rw-r--r--textproc/ipdf/Makefile1
-rw-r--r--textproc/kmflcomp/Makefile1
-rw-r--r--textproc/libkmfl/Makefile1
-rw-r--r--textproc/libnxml/Makefile1
-rw-r--r--textproc/libparsifal/Makefile1
-rw-r--r--textproc/libpathan/Makefile1
-rw-r--r--textproc/libtext-charwidth-perl/Makefile1
-rw-r--r--textproc/libtext-wrapi18n-perl/Makefile1
-rw-r--r--textproc/libtextcat/Makefile1
-rw-r--r--textproc/libxdiff/Makefile1
-rw-r--r--textproc/rand/Makefile1
-rw-r--r--textproc/scim-kmfl-imengine/Makefile1
-rw-r--r--textproc/sdcv/Makefile1
-rw-r--r--textproc/source-highlight/Makefile1
-rw-r--r--textproc/sowing/Makefile1
-rw-r--r--textproc/sphinxsearch-devel/Makefile1
-rw-r--r--textproc/sphinxsearch/Makefile1
-rw-r--r--textproc/webcpp/Makefile1
-rw-r--r--textproc/xlhtml/Makefile1
-rw-r--r--textproc/xmlto/Makefile1
29 files changed, 0 insertions, 29 deletions
diff --git a/textproc/aft/Makefile b/textproc/aft/Makefile
index 71bf2d1b2cba..eddf54e9aa39 100644
--- a/textproc/aft/Makefile
+++ b/textproc/aft/Makefile
@@ -16,7 +16,6 @@ COMMENT= A document preparation system using an Almost Free Text input format
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= -build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
.if defined(NOPORTDOCS)
diff --git a/textproc/aspell/Makefile b/textproc/aspell/Makefile
index ccd082ce1130..e09f0ae0eb7c 100644
--- a/textproc/aspell/Makefile
+++ b/textproc/aspell/Makefile
@@ -21,7 +21,6 @@ MAINTAINER= thierry@FreeBSD.org
COMMENT= Spelling checker with better suggestion logic than ispell
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-dict-dir=${DATADIR} \
--enable-docdir=${DOCSDIR} \
--enable-static
diff --git a/textproc/dbacl/Makefile b/textproc/dbacl/Makefile
index 140fdedf82f0..b6adebd840cf 100644
--- a/textproc/dbacl/Makefile
+++ b/textproc/dbacl/Makefile
@@ -18,7 +18,6 @@ COMMENT= Digramic Bayesian classifier
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
PROGRAMS= bayesol dbacl mailinspect hmine hypex
SCRIPTS= mailcross mailtoe mailfoot
diff --git a/textproc/dictfmt/Makefile b/textproc/dictfmt/Makefile
index 949815d50668..01dd73168cfd 100644
--- a/textproc/dictfmt/Makefile
+++ b/textproc/dictfmt/Makefile
@@ -17,7 +17,6 @@ COMMENT= Formats a DICT protocol dictionary database
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-cflags="${CFLAGS}"
ALL_TARGET= dictfmt
diff --git a/textproc/expat2/Makefile b/textproc/expat2/Makefile
index ada560c58a8c..74a5cf882787 100644
--- a/textproc/expat2/Makefile
+++ b/textproc/expat2/Makefile
@@ -15,7 +15,6 @@ MAINTAINER= kuriyama@FreeBSD.org
COMMENT= XML 1.0 parser written in C
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
ALL_TARGET= default
USE_LDCONFIG= yes
MAN1= xmlwf.1
diff --git a/textproc/filepp/Makefile b/textproc/filepp/Makefile
index af8947fd4ee3..53d732c54f59 100644
--- a/textproc/filepp/Makefile
+++ b/textproc/filepp/Makefile
@@ -16,7 +16,6 @@ COMMENT= A generic file preprocessor
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
NO_BUILD= yes
MAN1= filepp.1
diff --git a/textproc/gmetadom/Makefile b/textproc/gmetadom/Makefile
index 3a3d96207c96..6a32476f3a60 100644
--- a/textproc/gmetadom/Makefile
+++ b/textproc/gmetadom/Makefile
@@ -25,7 +25,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GNOME= glib20 gnomehack libxml2
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
USE_LDCONFIG= yes
diff --git a/textproc/gsed/Makefile b/textproc/gsed/Makefile
index 2942e28926aa..e9077abd49df 100644
--- a/textproc/gsed/Makefile
+++ b/textproc/gsed/Makefile
@@ -18,7 +18,6 @@ COMMENT= The GNU stream editor
# Global variables
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV+= MAKEINFO="makeinfo --no-split"
CONFIGURE_ARGS+=--disable-nls
USE_GMAKE= yes
diff --git a/textproc/hyperestraier/Makefile b/textproc/hyperestraier/Makefile
index 5d3c95fe354a..f19c9be19a7f 100644
--- a/textproc/hyperestraier/Makefile
+++ b/textproc/hyperestraier/Makefile
@@ -21,7 +21,6 @@ LIB_DEPENDS= qdbm.14:${PORTSDIR}/databases/qdbm
USE_ICONV= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-bzip2 --disable-zlib
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
diff --git a/textproc/ipdf/Makefile b/textproc/ipdf/Makefile
index 08192f76e04f..df0f0c06983f 100644
--- a/textproc/ipdf/Makefile
+++ b/textproc/ipdf/Makefile
@@ -20,7 +20,6 @@ LIB_DEPENDS= pdf.8:${PORTSDIR}/print/pdflib \
tiff.4:${PORTSDIR}/graphics/tiff
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/textproc/kmflcomp/Makefile b/textproc/kmflcomp/Makefile
index 2404bc7b32b2..83047b9afc4f 100644
--- a/textproc/kmflcomp/Makefile
+++ b/textproc/kmflcomp/Makefile
@@ -27,7 +27,6 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lintl"
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
DOCSDIR= ${PREFIX}/share/doc/kmfl/${PORTNAME}
DOCS= ${DISTDIR}/${DIST_SUBDIR}/KMFL-Compiler.sxw \
diff --git a/textproc/libkmfl/Makefile b/textproc/libkmfl/Makefile
index bb7afc206d96..2b429db7a06f 100644
--- a/textproc/libkmfl/Makefile
+++ b/textproc/libkmfl/Makefile
@@ -24,7 +24,6 @@ USE_GETTEXT= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
DOCSDIR= ${PREFIX}/share/doc/kmfl/${PORTNAME}
PORTDOCS= AUTHORS COPYING ChangeLog
diff --git a/textproc/libnxml/Makefile b/textproc/libnxml/Makefile
index 7bfb8b0142d5..a332b06515ae 100644
--- a/textproc/libnxml/Makefile
+++ b/textproc/libnxml/Makefile
@@ -18,7 +18,6 @@ LIB_DEPENDS= curl.4:${PORTSDIR}/ftp/curl
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CPPFLAGS="-I/${LOCALBASE}/include" LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_LDCONFIG= yes
diff --git a/textproc/libparsifal/Makefile b/textproc/libparsifal/Makefile
index 954d52e51b64..a09cf598339b 100644
--- a/textproc/libparsifal/Makefile
+++ b/textproc/libparsifal/Makefile
@@ -18,7 +18,6 @@ COMMENT= Lightweight XML Parser
USE_AUTOTOOLS= libtool:15
USE_ICONV= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
USE_LDCONFIG= yes
diff --git a/textproc/libpathan/Makefile b/textproc/libpathan/Makefile
index ef059ef8f021..0ff38d50d167 100644
--- a/textproc/libpathan/Makefile
+++ b/textproc/libpathan/Makefile
@@ -25,7 +25,6 @@ GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}beta
USE_LDCONFIG= yes
XERCESCROOT= `cd ${PORTSDIR}/textproc/xerces-c2; ${MAKE} -V WRKSRC`
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV+= XERCESCROOT=${XERCESCROOT}
CONFIGURE_SCRIPT= runConfigure
CONFIGURE_ARGS+= --disable-static
diff --git a/textproc/libtext-charwidth-perl/Makefile b/textproc/libtext-charwidth-perl/Makefile
index e865555e01db..6cae9999a80a 100644
--- a/textproc/libtext-charwidth-perl/Makefile
+++ b/textproc/libtext-charwidth-perl/Makefile
@@ -15,7 +15,6 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
MAINTAINER= ports@FreeBSD.org
COMMENT= Documentation gettext tools
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PERL_CONFIGURE= 5.8.0+
diff --git a/textproc/libtext-wrapi18n-perl/Makefile b/textproc/libtext-wrapi18n-perl/Makefile
index 0314a5b95f64..9a001bec7ec0 100644
--- a/textproc/libtext-wrapi18n-perl/Makefile
+++ b/textproc/libtext-wrapi18n-perl/Makefile
@@ -17,7 +17,6 @@ COMMENT= Documentation gettext tools
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Text/CharWidth.pm:${PORTSDIR}/textproc/libtext-charwidth-perl
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PERL_CONFIGURE= yes
diff --git a/textproc/libtextcat/Makefile b/textproc/libtextcat/Makefile
index 51ba158139dc..8d1eb1f40b34 100644
--- a/textproc/libtextcat/Makefile
+++ b/textproc/libtextcat/Makefile
@@ -20,7 +20,6 @@ COMMENT= Language guessing by N-Gram-Based Text Categorization
USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_LDCONFIG= yes
PORTDOCS= LICENSE README TODO
diff --git a/textproc/libxdiff/Makefile b/textproc/libxdiff/Makefile
index 5aa32da7ef53..68e8c2d36ce8 100644
--- a/textproc/libxdiff/Makefile
+++ b/textproc/libxdiff/Makefile
@@ -19,7 +19,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-shared --enable-static
MAN3= xdiff.3
diff --git a/textproc/rand/Makefile b/textproc/rand/Makefile
index 490c0a43e8b0..b49d6ae1b6f0 100644
--- a/textproc/rand/Makefile
+++ b/textproc/rand/Makefile
@@ -15,7 +15,6 @@ COMMENT= Utility to display files or streams in random order
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= rand.1
PLIST_FILES= bin/rand
diff --git a/textproc/scim-kmfl-imengine/Makefile b/textproc/scim-kmfl-imengine/Makefile
index bc330440e27a..f65196c3eed9 100644
--- a/textproc/scim-kmfl-imengine/Makefile
+++ b/textproc/scim-kmfl-imengine/Makefile
@@ -30,7 +30,6 @@ USE_LDCONFIG= yes
USE_CONFIGURE= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
DOCSDIR= ${PREFIX}/share/doc/kmfl/${PORTNAME}
PORTDOCS= AUTHORS COPYING ChangeLog
diff --git a/textproc/sdcv/Makefile b/textproc/sdcv/Makefile
index 8f6723d4247b..b44a7cce0c81 100644
--- a/textproc/sdcv/Makefile
+++ b/textproc/sdcv/Makefile
@@ -19,7 +19,6 @@ USE_ICONV= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool:15
USE_GNOME= glib20
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
SUB_FILES= pkg-message
.if !defined(WITHOUT_NLS)
diff --git a/textproc/source-highlight/Makefile b/textproc/source-highlight/Makefile
index 2964fc3747f4..c815250d4ca1 100644
--- a/textproc/source-highlight/Makefile
+++ b/textproc/source-highlight/Makefile
@@ -19,7 +19,6 @@ BUILD_DEPENDS= exctags:${PORTSDIR}/devel/ctags
LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= LDFLAGS=-L${LOCALBASE}/lib CPPFLAGS=-I${LOCALBASE}/include
.if defined(NOPORTDOCS)
MAKE_ENV+= NOPORTDOCS="${NOPORTDOCS}"
diff --git a/textproc/sowing/Makefile b/textproc/sowing/Makefile
index 328db48db4a8..8c1e4dc5dd6e 100644
--- a/textproc/sowing/Makefile
+++ b/textproc/sowing/Makefile
@@ -24,7 +24,6 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= INSTALL_SCRIPT="${INSTALL_SCRIPT}"
CONFIGURE_ARGS= --datadir=${DATADIR}
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
ALL_TARGET= all-redirect
MAN1= bfort.1 doctext.1 tohtml.1
diff --git a/textproc/sphinxsearch-devel/Makefile b/textproc/sphinxsearch-devel/Makefile
index ca2afac0cd63..53b543cefd09 100644
--- a/textproc/sphinxsearch-devel/Makefile
+++ b/textproc/sphinxsearch-devel/Makefile
@@ -41,7 +41,6 @@ SPHINX_LOG?= /var/log/${PORTNAME}
# don't ask.
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV+= CC=${CC} CPPFLAGS="${CXXFLAGS}"
CFGFILE= ${PREFIX}/etc/sphinx.conf
USE_RC_SUBR= sphinxsearch.sh
diff --git a/textproc/sphinxsearch/Makefile b/textproc/sphinxsearch/Makefile
index b2e453c57155..ff359d995071 100644
--- a/textproc/sphinxsearch/Makefile
+++ b/textproc/sphinxsearch/Makefile
@@ -35,7 +35,6 @@ SPHINX_LOG?= /var/log/${PORTNAME}
# don't ask.
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV+= CC=${CC} CPPFLAGS="${CXXFLAGS}"
CFGFILE= ${PREFIX}/etc/sphinx.conf
USE_RC_SUBR= sphinxsearch.sh
diff --git a/textproc/webcpp/Makefile b/textproc/webcpp/Makefile
index 8a1f0cd15828..961e6d0efe86 100644
--- a/textproc/webcpp/Makefile
+++ b/textproc/webcpp/Makefile
@@ -18,7 +18,6 @@ COMMENT= Convert your source code to syntax highlighted HTML
.include <bsd.port.pre.mk>
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
.if defined(WANT_FINAL)
diff --git a/textproc/xlhtml/Makefile b/textproc/xlhtml/Makefile
index bfb226531114..d5e225fbab9a 100644
--- a/textproc/xlhtml/Makefile
+++ b/textproc/xlhtml/Makefile
@@ -20,7 +20,6 @@ COMMENT= Convert Excel and PowerPoint files to HTML and text
USE_GMAKE= yes
USE_AUTOTOOLS= automake:14 autoconf:262
CONFIGURE_ARGS= --mandir=${PREFIX}/man
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= ppthtml.1 xlhtml.1
diff --git a/textproc/xmlto/Makefile b/textproc/xmlto/Makefile
index fba384890bbe..6f7c8e854aff 100644
--- a/textproc/xmlto/Makefile
+++ b/textproc/xmlto/Makefile
@@ -28,7 +28,6 @@ OPTIONS= PASSIVETEX "Enable PassiveTeX support for DVI/PS/PDF" OFF \
USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-bash=${BASH_CMD} --with-getopt=${GETOPT_CMD}
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
BASH_CMD= ${LOCALBASE}/bin/bash
GETOPT_CMD= ${LOCALBASE}/bin/getopt