aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-11-22 21:21:29 +0800
committermiwi <miwi@FreeBSD.org>2009-11-22 21:21:29 +0800
commit169faab876ffe7cd83d3460cbbd1ebd2ae1c1b0c (patch)
tree28113b477a0ffcb0049ad55e22a3bce7bcdc9d63 /textproc
parentf99a620f0c57cca24d146e83a04f70b89ec77fa7 (diff)
downloadfreebsd-ports-gnome-169faab876ffe7cd83d3460cbbd1ebd2ae1c1b0c.tar.gz
freebsd-ports-gnome-169faab876ffe7cd83d3460cbbd1ebd2ae1c1b0c.tar.zst
freebsd-ports-gnome-169faab876ffe7cd83d3460cbbd1ebd2ae1c1b0c.zip
This is the table based input method framework for IBus (Intelligent Input
Bus). It does not include real tables except two demo layouts, "Compose" (which mimics Compose Key input) and "LaTeX" (which allows you to use LaTeX commands as keyboard sequences to input various symbols). WWW: http://code.google.com/p/ibus PR: ports/140761 Submitted by: Nikola Lecic <nikola.lecic at anthesphoria.net>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/ibus-table/Makefile42
-rw-r--r--textproc/ibus-table/distinfo3
-rw-r--r--textproc/ibus-table/pkg-descr6
-rw-r--r--textproc/ibus-table/pkg-plist54
5 files changed, 106 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index d2e4f5225d71..3843b0827790 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -239,6 +239,7 @@
SUBDIR += ibus
SUBDIR += ibus-m17n
SUBDIR += ibus-qt
+ SUBDIR += ibus-table
SUBDIR += id-aspell
SUBDIR += idnits
SUBDIR += iiimf-client-lib
diff --git a/textproc/ibus-table/Makefile b/textproc/ibus-table/Makefile
new file mode 100644
index 000000000000..4c2021a6aef7
--- /dev/null
+++ b/textproc/ibus-table/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: ibus-table
+# Date created: 20 November 2009
+# Whom: Nikola Lecic <nikola.lecic@anthesphoria.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ibus-table
+PORTVERSION= 1.2.0.20091113
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
+ http://anthesphoria.net/FreeBSD/ports/distfiles/
+
+MAINTAINER= nikola.lecic@anthesphoria.net
+COMMENT= Table based input method framework for IBus
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
+LIB_DEPENDS= ibus.1:${PORTSDIR}/textproc/ibus
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PYTHON= 2.5+
+USE_GNOME= pkgconfig pygtk2
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+PROJECTHOST= ibus
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|' \
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e "s|/usr/|${PREFIX}/|g" ${WRKSRC}/engine/*.py
+
+.include <bsd.port.mk>
diff --git a/textproc/ibus-table/distinfo b/textproc/ibus-table/distinfo
new file mode 100644
index 000000000000..01f0ed51bdac
--- /dev/null
+++ b/textproc/ibus-table/distinfo
@@ -0,0 +1,3 @@
+MD5 (ibus-table-1.2.0.20091113.tar.gz) = 9e48e3844b61a5985802cd203e31aca0
+SHA256 (ibus-table-1.2.0.20091113.tar.gz) = b1858883e54b5dbe25b408af62cebbf6d543a8f34c5ca66ee5ae406e1818228e
+SIZE (ibus-table-1.2.0.20091113.tar.gz) = 412864
diff --git a/textproc/ibus-table/pkg-descr b/textproc/ibus-table/pkg-descr
new file mode 100644
index 000000000000..acccd4f801a1
--- /dev/null
+++ b/textproc/ibus-table/pkg-descr
@@ -0,0 +1,6 @@
+This is the table based input method framework for IBus (Intelligent Input
+Bus). It does not include real tables except two demo layouts, "Compose"
+(which mimics Compose Key input) and "LaTeX" (which allows you to use LaTeX
+commands as keyboard sequences to input various symbols).
+
+WWW: http://code.google.com/p/ibus
diff --git a/textproc/ibus-table/pkg-plist b/textproc/ibus-table/pkg-plist
new file mode 100644
index 000000000000..3cd21063b1d5
--- /dev/null
+++ b/textproc/ibus-table/pkg-plist
@@ -0,0 +1,54 @@
+bin/ibus-table-createdb
+libdata/pkgconfig/ibus-table.pc
+libexec/ibus-engine-table
+share/ibus/component/table.xml
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/ibus-table.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/ibus-table.mo
+%%NLS%%share/locale/zh_HK/LC_MESSAGES/ibus-table.mo
+%%DATADIR%%/data/pinyin_table.txt.bz2
+%%DATADIR%%/engine/factory.py
+%%DATADIR%%/engine/factory.pyc
+%%DATADIR%%/engine/factory.pyo
+%%DATADIR%%/engine/main.py
+%%DATADIR%%/engine/main.pyc
+%%DATADIR%%/engine/main.pyo
+%%DATADIR%%/engine/tabcreatedb.py
+%%DATADIR%%/engine/tabcreatedb.pyc
+%%DATADIR%%/engine/tabcreatedb.pyo
+%%DATADIR%%/engine/tabdict.py
+%%DATADIR%%/engine/tabdict.pyc
+%%DATADIR%%/engine/tabdict.pyo
+%%DATADIR%%/engine/table.py
+%%DATADIR%%/engine/table.pyc
+%%DATADIR%%/engine/table.pyo
+%%DATADIR%%/engine/tabsqlitedb.py
+%%DATADIR%%/engine/tabsqlitedb.pyc
+%%DATADIR%%/engine/tabsqlitedb.pyo
+%%DATADIR%%/icons/acommit.svg
+%%DATADIR%%/icons/cb-mode.svg
+%%DATADIR%%/icons/chinese.svg
+%%DATADIR%%/icons/compose.svg
+%%DATADIR%%/icons/english.svg
+%%DATADIR%%/icons/full-letter.svg
+%%DATADIR%%/icons/full-punct.svg
+%%DATADIR%%/icons/half-letter.svg
+%%DATADIR%%/icons/half-punct.svg
+%%DATADIR%%/icons/ibus-table.svg
+%%DATADIR%%/icons/latex.svg
+%%DATADIR%%/icons/ncommit.svg
+%%DATADIR%%/icons/onechar.svg
+%%DATADIR%%/icons/phrase.svg
+%%DATADIR%%/icons/py-mode.svg
+%%DATADIR%%/icons/sc-mode.svg
+%%DATADIR%%/icons/scb-mode.svg
+%%DATADIR%%/icons/tab-mode.svg
+%%DATADIR%%/icons/tc-mode.svg
+%%DATADIR%%/icons/tcb-mode.svg
+%%DATADIR%%/tables/compose.db
+%%DATADIR%%/tables/latex.db
+%%DATADIR%%/tables/template.txt
+@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%/engine
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%/tables
+@dirrm %%DATADIR%%